summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-11-05 13:46:59 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-11-05 13:46:59 +0000
commit1e4b34b64ad07865993796e534fc0527a57a9f76 (patch)
treeb699c423316db48a6d1cb746ad7f57668ec0d407 /net-mail/gnubiff
parentRemoved beepmp support from the 0.91-rc1 ebuild. (Manifest recommit) (diff)
downloadgentoo-2-1e4b34b64ad07865993796e534fc0527a57a9f76.tar.gz
gentoo-2-1e4b34b64ad07865993796e534fc0527a57a9f76.tar.bz2
gentoo-2-1e4b34b64ad07865993796e534fc0527a57a9f76.zip
Initial import. Closes #39429.
Diffstat (limited to 'net-mail/gnubiff')
-rw-r--r--net-mail/gnubiff/ChangeLog8
-rw-r--r--net-mail/gnubiff/Manifest4
-rw-r--r--net-mail/gnubiff/files/digest-gnubiff-2.0.21
-rw-r--r--net-mail/gnubiff/gnubiff-2.0.2.ebuild36
-rw-r--r--net-mail/gnubiff/metadata.xml5
5 files changed, 54 insertions, 0 deletions
diff --git a/net-mail/gnubiff/ChangeLog b/net-mail/gnubiff/ChangeLog
new file mode 100644
index 000000000000..9fb65ea3f17f
--- /dev/null
+++ b/net-mail/gnubiff/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-mail/gnubiff
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.1 2004/11/05 13:46:59 ticho Exp $
+
+ 05 Nov 2004; Andrej Kacian <ticho@gentoo.org> :
+ Initial import, closes #39429. Ebuild submitted by Andreas Waschinski
+ <wascha@web.de>.
+
diff --git a/net-mail/gnubiff/Manifest b/net-mail/gnubiff/Manifest
new file mode 100644
index 000000000000..216d90eddc7d
--- /dev/null
+++ b/net-mail/gnubiff/Manifest
@@ -0,0 +1,4 @@
+MD5 b1301b8fe58c00a73674137c87622236 ChangeLog 117
+MD5 a3b8e79272244cc35d76cd946555855d gnubiff-2.0.2.ebuild 699
+MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
+MD5 e99d3f45a896c224ba095e188794221f files/digest-gnubiff-2.0.2 65
diff --git a/net-mail/gnubiff/files/digest-gnubiff-2.0.2 b/net-mail/gnubiff/files/digest-gnubiff-2.0.2
new file mode 100644
index 000000000000..c3b2e1444b41
--- /dev/null
+++ b/net-mail/gnubiff/files/digest-gnubiff-2.0.2
@@ -0,0 +1 @@
+MD5 38ee04ed9e41454e3e1b40677cdb70d5 gnubiff-2.0.2.tar.gz 608475
diff --git a/net-mail/gnubiff/gnubiff-2.0.2.ebuild b/net-mail/gnubiff/gnubiff-2.0.2.ebuild
new file mode 100644
index 000000000000..a40852f8e9d8
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.0.2.ebuild,v 1.1 2004/11/05 13:46:59 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gnome"
+
+RDEPEND="virtual/libc
+ >=x11-libs/gtk+-2.4
+ gnome? ( >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2 )"
+
+DEPEND="${RDEPEND}"
+
+src_compile ( ) {
+ local myconf
+
+ if use gnome
+ then myconf="${myconf} --prefix=`pkg-config libpanelapplet-2.0 --variable=prefix`"
+ else myconf="${myconf} --disable-gnome"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
diff --git a/net-mail/gnubiff/metadata.xml b/net-mail/gnubiff/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/net-mail/gnubiff/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>