summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-06-15 11:09:02 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-06-15 11:09:02 +0000
commit85826b3a21828d6233cf3b4fd7333dae3fba86d8 (patch)
tree6a7972049b32e1229e83f364e73021a27a372e4b /net-mail/fetchmail
parentBug #226505 - For compatibility with phase execution order in (diff)
downloadgentoo-2-85826b3a21828d6233cf3b4fd7333dae3fba86d8.tar.gz
gentoo-2-85826b3a21828d6233cf3b4fd7333dae3fba86d8.tar.bz2
gentoo-2-85826b3a21828d6233cf3b4fd7333dae3fba86d8.zip
revbump, include fix for security bug #227105
(Portage version: 2.1.5.5)
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog10
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.8-r2.ebuild88
-rw-r--r--net-mail/fetchmail/files/fetchmail-6.3.8-resize-buffer.patch29
3 files changed, 125 insertions, 2 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index c1b289b36a86..5d48c2a23b38 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/fetchmail
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.139 2007/09/03 14:33:43 falco Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.140 2008/06/15 11:09:01 dertobi123 Exp $
+
+*fetchmail-6.3.8-r2 (15 Jun 2008)
+
+ 15 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +files/fetchmail-6.3.8-resize-buffer.patch, +fetchmail-6.3.8-r2.ebuild:
+ revbump, include fix for security bug #227105
03 Sep 2007; Raphael Marichez <falco@gentoo.org> ChangeLog:
Fix possible security issue (DoS), bug 191154
diff --git a/net-mail/fetchmail/fetchmail-6.3.8-r2.ebuild b/net-mail/fetchmail/fetchmail-6.3.8-r2.ebuild
new file mode 100644
index 000000000000..9e6b6de399d2
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.8-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.8-r2.ebuild,v 1.1 2008/06/15 11:09:01 dertobi123 Exp $
+
+inherit eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="http://download2.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl nls ipv6 kerberos krb4 hesiod"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( app-crypt/mit-krb5 )
+ nls? ( virtual/libintl )
+ elibc_FreeBSD? ( sys-libs/com_err )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fixes DoS, #191154
+ epatch "${FILESDIR}"/${P}-null-msg-pointer.patch
+
+ # bug #227105
+ epatch "${FILESDIR}"/${P}-resize-buffer.patch
+
+ # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+ epatch "${FILESDIR}"/${PN}-6.2.5-broken-headers.patch
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_enable ipv6 inet6) \
+ $(use_with kerberos gssapi) $(use_with kerberos kerberos5) \
+ $(use_with krb4 kerberos) \
+ $(use_with ssl) \
+ $(use_with hesiod) \
+ ${myconf} || die "Configuration failed."
+ # wont compile reliably on smp (mkennedy@gentoo.org 2003-11-12)
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README README.NTLM README.SSL TODO
+
+ newinitd "${FILESDIR}"/fetchmail fetchmail
+ newconfd "${FILESDIR}"/conf.d-fetchmail fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ elog
+ elog "You will not be able to use fetchmailconf(1), because you"
+ elog "don't seem to have Python with tkinter support."
+ elog
+ elog "If you want to be able to use fetchmailconf(1), do the following:"
+ elog " 1. Add 'tk' to the USE variable in /etc/make.conf."
+ elog " 2. (Re-)merge Python."
+ elog
+ fi
+
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+}
diff --git a/net-mail/fetchmail/files/fetchmail-6.3.8-resize-buffer.patch b/net-mail/fetchmail/files/fetchmail-6.3.8-resize-buffer.patch
new file mode 100644
index 000000000000..31075fabd709
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail-6.3.8-resize-buffer.patch
@@ -0,0 +1,29 @@
+--- report.c.orig 2008-06-15 12:35:20.974808379 +0200
++++ report.c 2008-06-15 12:36:51.961927723 +0200
+@@ -238,11 +238,17 @@
+ rep_ensuresize();
+
+ #if defined(VA_START)
+- VA_START (args, message);
+ for ( ; ; )
+ {
++ /*
++ * args has to be initialized before every call of vsnprintf(),
++ * because vsnprintf() invokes va_arg macro and thus args is
++ * undefined after the call.
++ */
++ VA_START(args, message);
+ n = vsnprintf (partial_message + partial_message_size_used, partial_message_size - partial_message_size_used,
+ message, args);
++ va_end (args);
+
+ if (n >= 0
+ && (unsigned)n < partial_message_size - partial_message_size_used)
+@@ -254,7 +260,6 @@
+ partial_message_size += 2048;
+ partial_message = REALLOC (partial_message, partial_message_size);
+ }
+- va_end (args);
+ #else
+ for ( ; ; )
+ {