summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-03-31 02:43:10 +0000
committerJon Portnoy <avenj@gentoo.org>2003-03-31 02:43:10 +0000
commit14da7f34830ccd135eaac061057fbaa9a08ff1f0 (patch)
tree7299a1413ea712f920e35ef65e23c75641251ca4 /net-mail/fetchmail
parentAdded -d 60 to initscript, fixes bug 18491 (diff)
downloadgentoo-2-14da7f34830ccd135eaac061057fbaa9a08ff1f0.tar.gz
gentoo-2-14da7f34830ccd135eaac061057fbaa9a08ff1f0.tar.bz2
gentoo-2-14da7f34830ccd135eaac061057fbaa9a08ff1f0.zip
Revision bump for new initscript
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild73
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.2.2-r11
2 files changed, 74 insertions, 0 deletions
diff --git a/net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild b/net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild
new file mode 100644
index 000000000000..f8e8aef2e777
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild,v 1.1 2003/03/31 02:43:10 avenj Exp $
+
+inherit eutils
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.catb.org/~esr/fetchmail/"
+SRC_URI="http://www.catb.org/~esr/fetchmail/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="x86 ~alpha"
+IUSE="ssl nls ipv6"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/fetchmail-6.2.0-gentoo.diff || die
+}
+
+src_compile() {
+ local myconf
+ use ssl && myconf="${myconf} --with-ssl=/usr"
+ use nls || myconf="${myconf} --disable-nls"
+ use ipv6 && myconf="${myconf} --enable-inet6"
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ doman ${D}/usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.2.2-r1 b/net-mail/fetchmail/files/digest-fetchmail-6.2.2-r1
new file mode 100644
index 000000000000..a1f977811cec
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.2.2-r1
@@ -0,0 +1 @@
+MD5 b3544890a2452b5b04c709c65109c43a fetchmail-6.2.2.tar.gz 1205198