summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-07 00:36:34 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-07 00:36:34 +0000
commit9bb5af3adf87a898a1114146b6fd79c696257c1b (patch)
treec9d7092e812bfd0bc946abf443dce49a15adccb9 /net-mail/evolution
parentNew version (diff)
downloadgentoo-2-9bb5af3adf87a898a1114146b6fd79c696257c1b.tar.gz
gentoo-2-9bb5af3adf87a898a1114146b6fd79c696257c1b.tar.bz2
gentoo-2-9bb5af3adf87a898a1114146b6fd79c696257c1b.zip
removed ldap-stuff until 2.0 is unmasked
Diffstat (limited to 'net-mail/evolution')
-rw-r--r--net-mail/evolution/evolution-1.0-r3.ebuild103
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0-r32
2 files changed, 105 insertions, 0 deletions
diff --git a/net-mail/evolution/evolution-1.0-r3.ebuild b/net-mail/evolution/evolution-1.0-r3.ebuild
new file mode 100644
index 000000000000..9222214081e2
--- /dev/null
+++ b/net-mail/evolution/evolution-1.0-r3.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <hallski@gentoo.org>, Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0-r3.ebuild,v 1.1 2002/01/07 00:36:34 hallski Exp $
+
+DB3=db-3.1.17
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
+ ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz
+ http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
+ http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+
+DEPEND=">=gnome-extra/bonobo-conf-0.14
+ >=gnome-base/bonobo-1.0.15
+ >=gnome-extra/gal-0.18.1
+ >=gnome-base/gconf-1.0.7
+ >=gnome-extra/gtkhtml-1.0.0
+ >=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/ORBit-0.5.10-r1
+ >=gnome-base/libglade-0.17-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1
+ >=dev-libs/libxml-1.8.16
+ >=gnome-base/gnome-vfs-1.0.2-r1
+ >=gnome-base/gnome-print-0.30
+ >=app-text/scrollkeeper-0.2
+ >=dev-util/intltool-0.11
+ ssl? ( >=net-www/mozilla-0.9.6-r3 )
+ mozilla? ( >=net-www/mozilla-0.9.6-r3 )
+ pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )"
+
+# Until ldap >= 2.0 is unmasked.
+# ldap? ( net-nds/openldap )
+
+
+src_compile() {
+
+ cd ${WORKDIR}/${DB3}/build_unix
+ ../dist/configure --prefix=${WORKDIR}/db3 || die
+ make || die # make -j 4 doesn't work, use make
+ make prefix=${WORKDIR}/db3 install || die
+
+ cd ${S}
+
+ local myconf=""
+
+ MOZILLA=$MOZILLA_FIVE_HOME
+
+ if [ "`use pda`" ] ; then
+ myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
+ else
+ myconf="${myconf} --enable-pilot-conduits=no"
+ fi
+
+# if [ "`use ldap`" ] ; then
+# myconf="${myconf} --with-openldap=yes"
+# else
+# myconf="${myconf} --with-openldap=no"
+# fi
+
+ if [ "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nspr-libs --without-nspr-includes"
+ fi
+
+ if [ "`use ssl`" ] ; then
+ myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
+ --with-nss-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nss-libs --without-nss-includes"
+ fi
+
+ # SSL needs NSPR libs ...
+ if [ "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ fi
+
+ CFLAGS="${CFLAGS} -I/usr/include/libpisock"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-file-locking=no \
+ --with-db3=${WORKDIR}/db3 \
+ ${myconf} || die
+
+ # emake might not work, so fall back to make
+ emake || make || die
+}
+
+src_install() {
+
+ # Use DESTDIR // Hallski
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
diff --git a/net-mail/evolution/files/digest-evolution-1.0-r3 b/net-mail/evolution/files/digest-evolution-1.0-r3
new file mode 100644
index 000000000000..446650ff3404
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-1.0-r3
@@ -0,0 +1,2 @@
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1957888
+MD5 89546c8d15c2aca6ca41caa5b5f14a44 evolution-1.0.tar.gz 10244096