summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2008-12-18 11:38:42 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2008-12-18 11:38:42 +0000
commit6d157d3f087a42b2ca6ba8489eefabdf9df21700 (patch)
tree3d2b6dff5952b79e1cff6f4aee3b4d42dc0c0cec /net-mail/dbmail
parentFix test suite. Stable for x86. (diff)
downloadgentoo-2-6d157d3f087a42b2ca6ba8489eefabdf9df21700.tar.gz
gentoo-2-6d157d3f087a42b2ca6ba8489eefabdf9df21700.tar.bz2
gentoo-2-6d157d3f087a42b2ca6ba8489eefabdf9df21700.zip
improved ebuild (init script, python, ldap, contrib stuff)
(Portage version: 2.2_rc14/cvs/Linux 2.6.24-gentoo-r3 x86_64)
Diffstat (limited to 'net-mail/dbmail')
-rw-r--r--net-mail/dbmail/ChangeLog10
-rw-r--r--net-mail/dbmail/dbmail-2.2.11_rc3-r1.ebuild155
2 files changed, 164 insertions, 1 deletions
diff --git a/net-mail/dbmail/ChangeLog b/net-mail/dbmail/ChangeLog
index da0baa8034da..6b4b768af7d5 100644
--- a/net-mail/dbmail/ChangeLog
+++ b/net-mail/dbmail/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/dbmail
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.32 2008/12/01 12:38:03 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.33 2008/12/18 11:38:42 lordvan Exp $
+
+*dbmail-2.2.11_rc3-r1 (18 Dec 2008)
+
+ 18 Dec 2008; Thomas Raschbacher <lordvan@gentoo.org>
+ +dbmail-2.2.11_rc3-r1.ebuild:
+ added 2.2.11_rc3-r1 which used upstream gentoo init scripts and conf.d
+ file. also now installing ldap schema if USE="ldap", contrib stuff into
+ doc dir and also installing python modules if USE="python"
*dbmail-2.3.4 (01 Dec 2008)
diff --git a/net-mail/dbmail/dbmail-2.2.11_rc3-r1.ebuild b/net-mail/dbmail/dbmail-2.2.11_rc3-r1.ebuild
new file mode 100644
index 000000000000..d45c3a2ab5de
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.2.11_rc3-r1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.11_rc3-r1.ebuild,v 1.1 2008/12/18 11:38:42 lordvan Exp $
+
+inherit eutils multilib python
+
+MY_P="${P/_/-}" # for rcX was without the - for versions < 2.2.6
+#MY_P="${P}" # releases
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static python"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=virtual/postgresql-server-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ !mysql? ( !postgres? ( !sqlite3? ( >=dev-db/sqlite-3.0 ) ) )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ ldap? ( >=net-nds/openldap-2.3.33 )
+ python? ( net-zope/zopeinterface )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ =dev-libs/gmime-2.2*
+ >=dev-libs/glib-2.8"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ if ! use postgres && !use mysql && !use sqlite3; then myconf="${myconf} --with-sqlite" ; fi
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS ChangeLog README* INSTALL NEWS THANKS UPGRADING VERSION
+
+ docinto sql/mysql
+ dodoc sql/mysql/*
+ docinto sql/postgresql
+ dodoc sql/postgresql/*
+ docinto sql/sqlite
+ dodoc sql/sqlite/*
+ docinto test-scripts
+ dodoc test-scripts/*
+ docinto contrib/sql2sql
+ dodoc contrib/sql2sql
+ docinto contrib/mailbox2dbmail
+ dodoc contrib/mailbox2dbmail
+ docinto contrib
+ dodoc contrib/quota_warn.pl
+
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ # change config path to our default and use the conf.d and init.d files from the contrib dir
+ sed -i -e "s:/etc/dbmail.conf:/etc/dbmail/dbmail.conf:" contrib/startup-scripts/gentoo/init.d-dbmail
+ newconfd contrib/startup-scripts/gentoo/conf.d-dbmail dbmail
+ newinitd contrib/startup-scripts/gentoo/init.d-dbmail dbmail
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ # ldap schema
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins "${S}/dbmail.schema"
+ fi
+
+ if use python; then
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/dbmail
+ doins python/*.py
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/dbmail/app
+ doins python/app/*.py
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/dbmail/bin
+ doins python/bin/*.py
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/dbmail/lib
+ doins python/lib/*.py
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/dbmail/tests
+ doins python/tests/*.py
+ fi
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ if use python; then
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/dbmail
+ fi
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "DBMail requires either SQLite3, PostgreSQL or MySQL."
+ elog "If none of the use-flags are specified SQLite3 is"
+ elog "used as default. To use another database please"
+ elog "specify the appropriate use-flag and re-emerge dbmail."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+ echo
+ elog "We are now using the init script from upstream."
+ elog "Please edit /etc/conf.d/dbmail to set which services to start"
+ elog "and delete /etc/init.d/dbmail-* when you are done. (don't"
+ elog "forget to rc-update del dbmail-* first)"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+} \ No newline at end of file