summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-01-03 02:05:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-01-03 02:05:03 +0000
commitb855054773305a6a8246bfc452bd87f119132b3e (patch)
treedc3968fca4ceffdcf71034a007f6b71a9e1cc9ea /net-mail/cmd5checkpw
parentAdd ~sparc keyword, bug #237202 (diff)
downloadgentoo-2-b855054773305a6a8246bfc452bd87f119132b3e.tar.gz
gentoo-2-b855054773305a6a8246bfc452bd87f119132b3e.tar.bz2
gentoo-2-b855054773305a6a8246bfc452bd87f119132b3e.zip
DISTDIR is read-only. You cannot use mv in it. Use a symlink in workdir instead as the mv was causing breakage on portage-2.2. Also set cflags from inside src_compile instead of src_unpack, and take out unneeded qmail_set_cc.
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-hardened-r4 x86_64)
Diffstat (limited to 'net-mail/cmd5checkpw')
-rw-r--r--net-mail/cmd5checkpw/ChangeLog11
-rw-r--r--net-mail/cmd5checkpw/cmd5checkpw-0.30-r1.ebuild21
2 files changed, 22 insertions, 10 deletions
diff --git a/net-mail/cmd5checkpw/ChangeLog b/net-mail/cmd5checkpw/ChangeLog
index a7d3546eaac8..742bb53508f1 100644
--- a/net-mail/cmd5checkpw/ChangeLog
+++ b/net-mail/cmd5checkpw/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/cmd5checkpw
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cmd5checkpw/ChangeLog,v 1.46 2008/04/06 17:11:21 hollow Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cmd5checkpw/ChangeLog,v 1.47 2009/01/03 02:05:03 robbat2 Exp $
+
+ 03 Jan 2009; Robin H. Johnson <robbat2@gentoo.org>
+ cmd5checkpw-0.30-r1.ebuild:
+ DISTDIR is read-only. You cannot use mv in it. Use a symlink in workdir
+ instead as the mv was causing breakage on portage-2.2. Also set cflags
+ from inside src_compile instead of src_unpack, and take out unneeded
+ qmail_set_cc.
*cmd5checkpw-0.30-r1 (06 Apr 2008)
diff --git a/net-mail/cmd5checkpw/cmd5checkpw-0.30-r1.ebuild b/net-mail/cmd5checkpw/cmd5checkpw-0.30-r1.ebuild
index 7178c47091ff..8e0b2e195256 100644
--- a/net-mail/cmd5checkpw/cmd5checkpw-0.30-r1.ebuild
+++ b/net-mail/cmd5checkpw/cmd5checkpw-0.30-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cmd5checkpw/cmd5checkpw-0.30-r1.ebuild,v 1.1 2008/04/06 17:11:21 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cmd5checkpw/cmd5checkpw-0.30-r1.ebuild,v 1.2 2009/01/03 02:05:03 robbat2 Exp $
inherit eutils fixheadtails qmail
@@ -30,26 +30,31 @@ pkg_setup() {
}
src_unpack() {
- mv "${DISTDIR}"/${PN}-${MY_VER}{_tgz.bin,.tar.gz}
- unpack ${PN}-${MY_VER}.tar.gz
+ # The old code moved the file in DISTDIR, which is forbidden.
+ # It's read-only.
+ cd "${WORKDIR}"
+ rm -f ${PN}-${MY_VER}.tar.gz
+ ln -s "${DISTDIR}"/${PN}-${MY_VER}_tgz.bin ${PN}-${MY_VER}.tar.gz
+ unpack ./${PN}-${MY_VER}.tar.gz
cd "${S}"
epatch "${FILESDIR}"/euid_${MY_VER}.diff
epatch "${FILESDIR}"/reloc.diff
sed \
- -e "s:-c -g -Wall -O3:${CFLAGS}:" \
+ -e 's:-c -g -Wall -O3:$(OPTCFLAGS):' \
-e "s:cp cmd5checkpw /bin/:cp cmd5checkpw \${D}/bin/:" \
-e "s:cp cmd5checkpw.8 /usr/man/man8/:cp cmd5checkpw.8 \${D}/usr/share/man/man8/:" \
-i Makefile
ht_fix_file Makefile
-
- qmail_set_cc
}
src_compile() {
- emake || die
+ # cmd5checkpw does not use conf-cc/conf-ld
+ # qmail_set_cc
+
+ emake OPTCFLAGS="${CFLAGS}" || die
}
src_install() {