summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-28 23:21:17 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-28 23:21:17 +0000
commitfd5cbd0ddbdf8ae85062116f09f3621dbf6e3d06 (patch)
tree3fda4cb856a34ea39de2ae71ac9d1333ad9729f6 /net-libs
parentVersion bump. Support libmirage-2.0.0. (diff)
downloadgentoo-2-fd5cbd0ddbdf8ae85062116f09f3621dbf6e3d06.tar.gz
gentoo-2-fd5cbd0ddbdf8ae85062116f09f3621dbf6e3d06.tar.bz2
gentoo-2-fd5cbd0ddbdf8ae85062116f09f3621dbf6e3d06.zip
Version bump #454382 by Alexandre Rostovtsev.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libqmi/ChangeLog10
-rw-r--r--net-libs/libqmi/libqmi-1.0.0.ebuild42
-rw-r--r--net-libs/libqmi/libqmi-9999.ebuild18
3 files changed, 57 insertions, 13 deletions
diff --git a/net-libs/libqmi/ChangeLog b/net-libs/libqmi/ChangeLog
index 4249f38870a1..9aac15afe4ec 100644
--- a/net-libs/libqmi/ChangeLog
+++ b/net-libs/libqmi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libqmi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libqmi/ChangeLog,v 1.1 2012/09/23 21:28:19 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libqmi/ChangeLog,v 1.2 2013/01/28 23:21:17 vapier Exp $
+
+*libqmi-1.0.0 (28 Jan 2013)
+
+ 28 Jan 2013; Mike Frysinger <vapier@gentoo.org> +libqmi-1.0.0.ebuild,
+ libqmi-9999.ebuild:
+ Version bump #454382 by Alexandre Rostovtsev.
* libqmi-9999 (23 Sep 2012)
diff --git a/net-libs/libqmi/libqmi-1.0.0.ebuild b/net-libs/libqmi/libqmi-1.0.0.ebuild
new file mode 100644
index 000000000000..5c0161bd0ca6
--- /dev/null
+++ b/net-libs/libqmi/libqmi-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libqmi/libqmi-1.0.0.ebuild,v 1.1 2013/01/28 23:21:17 vapier Exp $
+
+EAPI="4"
+
+inherit multilib autotools
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://anongit.freedesktop.org/libqmi"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="http://cgit.freedesktop.org/libqmi/snapshot/${P}.tar.gz"
+fi
+
+DESCRIPTION="QMI modem protocol helper library"
+HOMEPAGE="http://cgit.freedesktop.org/libqmi/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc static-libs test"
+
+RDEPEND=">=dev-libs/glib-2.32"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig"
+
+src_prepare() {
+ [[ -e configure ]] || eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static{-libs,}) \
+ $(use_with doc{,s}) \
+ $(use_with test{,s})
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/libqmi-glib.la
+}
diff --git a/net-libs/libqmi/libqmi-9999.ebuild b/net-libs/libqmi/libqmi-9999.ebuild
index c1c2e52a1877..4ae7f4411c1e 100644
--- a/net-libs/libqmi/libqmi-9999.ebuild
+++ b/net-libs/libqmi/libqmi-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libqmi/libqmi-9999.ebuild,v 1.1 2012/09/23 21:28:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libqmi/libqmi-9999.ebuild,v 1.2 2013/01/28 23:21:17 vapier Exp $
EAPI="4"
-inherit multilib
+inherit multilib autotools
if [[ ${PV} == "9999" ]] ; then
- inherit git-2 autotools
+ inherit git-2
EGIT_REPO_URI="git://anongit.freedesktop.org/libqmi"
else
KEYWORDS="~amd64 ~arm ~x86"
- SRC_URI=""
+ SRC_URI="http://cgit.freedesktop.org/libqmi/snapshot/${P}.tar.gz"
fi
DESCRIPTION="QMI modem protocol helper library"
@@ -18,7 +18,7 @@ HOMEPAGE="http://cgit.freedesktop.org/libqmi/"
LICENSE="LGPL-2"
SLOT="0"
-IUSE="debug doc static-libs test"
+IUSE="doc static-libs test"
RDEPEND=">=dev-libs/glib-2.32"
DEPEND="${RDEPEND}
@@ -26,16 +26,12 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
- eautoreconf
- fi
- sed -i '/GLIB_MKENUMS=/s:pkg-config:$PKG_CONFIG:' configure
+ [[ -e configure ]] || eautoreconf
}
src_configure() {
econf \
$(use_enable static{-libs,}) \
- $(use_with debug traces) \
$(use_with doc{,s}) \
$(use_with test{,s})
}