summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-13 21:59:32 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-13 21:59:32 +0000
commitf586046d9a8f4f566c70e09f68226f3e11444c09 (patch)
treede1a5408ecbdbb7c00a5c204b5378d3e7d19c8e5 /net-libs
parentMask multilib gnutls. (diff)
downloadgentoo-2-f586046d9a8f4f566c70e09f68226f3e11444c09.tar.gz
gentoo-2-f586046d9a8f4f566c70e09f68226f3e11444c09.tar.bz2
gentoo-2-f586046d9a8f4f566c70e09f68226f3e11444c09.zip
Enable multilib support, bug #493166.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnutls/ChangeLog7
-rw-r--r--net-libs/gnutls/gnutls-3.3.1-r1.ebuild146
2 files changed, 152 insertions, 1 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index a6ca45f13df9..76cca124504d 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gnutls
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.487 2014/04/25 19:05:35 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.488 2014/05/13 21:59:32 mgorny Exp $
+
+*gnutls-3.3.1-r1 (13 May 2014)
+
+ 13 May 2014; Michał Górny <mgorny@gentoo.org> +gnutls-3.3.1-r1.ebuild:
+ Enable multilib support, bug #493166.
25 Apr 2014; Alon Bar-Lev <alonbl@gentoo.org> +files/gnutls-3.3.1-guile.patch,
gnutls-3.3.1.ebuild:
diff --git a/net-libs/gnutls/gnutls-3.3.1-r1.ebuild b/net-libs/gnutls/gnutls-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..f29a2eca5d07
--- /dev/null
+++ b/net-libs/gnutls/gnutls-3.3.1-r1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-3.3.1-r1.ebuild,v 1.1 2014/05/13 21:59:32 mgorny Exp $
+
+EAPI=5
+
+inherit autotools libtool eutils multilib-minimal versionator
+
+DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="mirror://gnupg/gnutls/v$(get_version_component_range 1-2)/${P}.tar.xz"
+
+# LGPL-3 for libgnutls library and GPL-3 for libgnutls-extra library.
+# soon to be relicensed as LGPL-2.1 unless heartbeat extension enabled.
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE_LINGUAS=" en cs de fi fr it ms nl pl sv uk vi zh_CN"
+IUSE="+cxx +crywrap dane doc examples guile nls pkcs11 static-libs test zlib ${IUSE_LINGUAS// / linguas_}"
+# heartbeat support is not disabled until re-licensing happens fullyf
+
+# NOTICE: sys-devel/autogen is required at runtime as we
+# use system libopts
+RDEPEND=">=dev-libs/libtasn1-2.14[${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-2.7[gmp,${MULTILIB_USEDEP}]
+ dev-libs/gmp[${MULTILIB_USEDEP}]
+ sys-devel/autogen
+ crywrap? ( net-dns/libidn )
+ dane? ( net-dns/unbound[${MULTILIB_USEDEP}] )
+ guile? ( >=dev-scheme/guile-1.8[networking] )
+ nls? ( virtual/libintl[${MULTILIB_USEDEP}] )
+ pkcs11? ( >=app-crypt/p11-kit-0.19.2[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.3.1[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.11.6
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )
+ test? ( app-misc/datefudge )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS doc/TODO )
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+src_prepare() {
+ sed -i \
+ -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' \
+ doc/Makefile.am || die
+
+ # force regeneration of autogen-ed files
+ local file
+ for file in $(grep -l AutoGen-ed src/*.c) ; do
+ rm src/$(basename ${file} .c).{c,h} || die
+ done
+
+ epatch "${FILESDIR}/${P}-guile.patch"
+
+ # support user patches
+ epatch_user
+
+ eautoreconf
+
+ # Use sane .so versioning on FreeBSD.
+ elibtoolize
+
+ # bug 497472
+ use cxx || epunt_cxx
+}
+
+multilib_src_configure() {
+ LINGUAS="${LINGUAS//en/en@boldquot en@quot}"
+
+ # TPM needs to be tested before being enabled
+ # hardware-accell is disabled on OSX because the asm files force
+ # GNU-stack (as doesn't support that) and when that's removed ld
+ # complains about duplicate symbols
+ ECONF_SOURCE=${S} \
+ econf \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --disable-valgrind-tests \
+ --enable-heartbeat-support \
+ $(use_enable cxx) \
+ $(use_enable dane libdane) \
+ $(multilib_native_use_enable doc gtk-doc) \
+ $(multilib_native_use_enable doc gtk-doc-pdf) \
+ $(multilib_native_use_enable guile) \
+ $(multilib_native_use_enable crywrap) \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_with pkcs11 p11-kit) \
+ $(use_with zlib) \
+ --without-tpm \
+ $([[ ${CHOST} == *-darwin* ]] && echo --disable-hardware-acceleration)
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake -C gl
+ emake -C lib
+ emake -C extra
+ use dane && emake -C libdane
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ # parallel testing often fails
+ emake -j1 check
+ else
+ emake -C gl -j1 check
+ emake -C tests -j1 check
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ emake DESTDIR="${D}" install
+ else
+ emake -C lib DESTDIR="${D}" install
+ emake -C extra DESTDIR="${D}" install
+ use dane && emake -C libdane DESTDIR="${D}" install
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ dodoc doc/certtool.cfg
+
+ if use doc; then
+ dodoc doc/gnutls.pdf
+ dohtml doc/gnutls.html
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}