summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-16 01:57:17 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-16 01:57:17 +0000
commitf4727af299e5642982529e50986053cd38df55c8 (patch)
treeac330262b9d1004783ab7e479844de2d4893e3f5 /net-libs
parentzip_reader.cc needs to be updated as well. (diff)
downloadgentoo-2-f4727af299e5642982529e50986053cd38df55c8.tar.gz
gentoo-2-f4727af299e5642982529e50986053cd38df55c8.tar.bz2
gentoo-2-f4727af299e5642982529e50986053cd38df55c8.zip
Version bump (thanks to Corentin Chary for the report bug 388667), added gnutls and crypt USE flags. non-maint commit.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libvncserver/ChangeLog8
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.8.2.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/net-libs/libvncserver/ChangeLog b/net-libs/libvncserver/ChangeLog
index 7d5a179c9f8c..d39359334275 100644
--- a/net-libs/libvncserver/ChangeLog
+++ b/net-libs/libvncserver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libvncserver
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/ChangeLog,v 1.47 2011/02/26 21:46:44 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/ChangeLog,v 1.48 2011/11/16 01:57:17 xmw Exp $
+
+*libvncserver-0.9.8.2 (16 Nov 2011)
+
+ 16 Nov 2011; Michael Weber <xmw@gentoo.org> +libvncserver-0.9.8.2.ebuild:
+ Version bump (thanks to Corentin Chary for the report bug 388667), added
+ gnutls and crypt USE flags. non-maint commit.
26 Feb 2011; Kevin McCarthy <signals@gentoo.org> libvncserver-0.9.1.ebuild:
Updated depends from media-libs/jpeg to virtual/jpeg
diff --git a/net-libs/libvncserver/libvncserver-0.9.8.2.ebuild b/net-libs/libvncserver/libvncserver-0.9.8.2.ebuild
new file mode 100644
index 000000000000..ec010aa8c297
--- /dev/null
+++ b/net-libs/libvncserver/libvncserver-0.9.8.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/libvncserver-0.9.8.2.ebuild,v 1.1 2011/11/16 01:57:17 xmw Exp $
+
+EAPI="4"
+
+inherit libtool
+
+DESCRIPTION="library for creating vnc servers"
+HOMEPAGE="http://libvncserver.sourceforge.net/"
+SRC_URI="http://libvncserver.sourceforge.net/LibVNCServer-${PV/_}.tar.gz
+ mirror://sourceforge/libvncserver/LibVNCServer-${PV/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="no24bpp crypt gnutls ipv6 +jpeg test threads +zlib"
+
+DEPEND="crypt? ( dev-libs/libgcrypt )
+ gnutls? ( net-libs/gnutls )
+ jpeg? ( virtual/jpeg )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/LibVNCServer-${PV/_}
+
+src_prepare() {
+ sed -i -r \
+ -e '/^CFLAGS =/d' \
+ -e "/^SUBDIRS/s:\<($(use test || echo 'test|')client_examples|examples)\>::g" \
+ Makefile.in || die
+
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --without-x11vnc \
+ $(use_with !no24bpp 24bpp) \
+ $(use_with crypt gcrypt) \
+ $(use_with ipv6) \
+ $(use_with jpeg) \
+ $(use_with threads pthread) \
+ $(use_with zlib)
+}
+
+src_compile() {
+ default
+ emake -C examples noinst_PROGRAMS=storepasswd
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dobin examples/storepasswd
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}