summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-18 19:20:44 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-18 19:20:44 +0000
commite3ed06ef82c2dcde38beefca4369efcd06f8ed51 (patch)
treee95f1f2bc9a549b94f9555694a3fd0c60e70f04b /net-libs
parentarm/hppa/ia64/s390/sh stable (diff)
downloadgentoo-2-e3ed06ef82c2dcde38beefca4369efcd06f8ed51.tar.gz
gentoo-2-e3ed06ef82c2dcde38beefca4369efcd06f8ed51.tar.bz2
gentoo-2-e3ed06ef82c2dcde38beefca4369efcd06f8ed51.zip
touchups
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnutls/gnutls-1.2.10-r1.ebuild28
1 files changed, 4 insertions, 24 deletions
diff --git a/net-libs/gnutls/gnutls-1.2.10-r1.ebuild b/net-libs/gnutls/gnutls-1.2.10-r1.ebuild
index 6d5154960b37..8336bdf6c3d2 100644
--- a/net-libs/gnutls/gnutls-1.2.10-r1.ebuild
+++ b/net-libs/gnutls/gnutls-1.2.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-1.2.10-r1.ebuild,v 1.1 2006/02/09 22:20:26 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-1.2.10-r1.ebuild,v 1.2 2006/02/18 19:20:44 vapier Exp $
inherit eutils gnuconfig
@@ -8,16 +8,11 @@ DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
HOMEPAGE="http://www.gnutls.org/"
SRC_URI="ftp://ftp.gnutls.org/pub/gnutls/${P}.tar.bz2"
-IUSE="zlib doc crypt"
-
-LICENSE="LGPL-2.1 GPL-2"
# GPL-2 for the gnutls-extras library and LGPL for the gnutls library.
-
+LICENSE="LGPL-2.1 GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-# Removed keywords awaiting >=dev-libs/libtasn1-0.2.10 keywords (bug #61944)
-# ~ia64 ~hppa
+IUSE="zlib doc crypt"
RDEPEND=">=dev-libs/libgcrypt-1.2.2
>=app-crypt/opencdk-0.5.5
@@ -26,25 +21,18 @@ RDEPEND=">=dev-libs/libgcrypt-1.2.2
>=dev-libs/lzo-2
>=dev-libs/libtasn1-0.2.11
dev-libs/libgpg-error"
-
-
# crypt? ( >=app-crypt/opencdk-0.5.5 )
-
DEPEND="${RDEPEND}
sys-apps/gawk
sys-apps/grep
sys-devel/gcc
sys-devel/libtool"
-
# gnutls has its own version of these. should maybe avoid using.
# libtasn1
# opencdk
src_compile() {
- # Needed for mips and probably others
- gnuconfig_update
-
local myconf=""
# use crypt || myconf="${myconf} --disable-extra-pki --disable-openpgp-authentication"
@@ -59,15 +47,7 @@ src_compile() {
}
src_install() {
- # OSX make doesn't handle -jx with x > 1 correctly here.
- # Forcing it to be just one process, solves installation
- # problems that arise here. Fabian Groffen (2005-07-09)
- if use ppc-macos; then
- emake -j1 DESTDIR=${D} install || die
- else
- emake DESTDIR=${D} install || die
- fi
-
+ emake -j1 DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS \
README THANKS doc/TODO