summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-09-01 22:02:33 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-09-01 22:02:33 +0000
commite23e9a3d03abc47fda9f7f8293893b72bff7b2e0 (patch)
tree07f05d05c31b7baaedf75a424b58f7622da6adb1 /net-libs
parentVersion bump. Change LICENSE to LGPL-2.1. Add src_test. (diff)
downloadgentoo-2-e23e9a3d03abc47fda9f7f8293893b72bff7b2e0.tar.gz
gentoo-2-e23e9a3d03abc47fda9f7f8293893b72bff7b2e0.tar.bz2
gentoo-2-e23e9a3d03abc47fda9f7f8293893b72bff7b2e0.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/ChangeLog8
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-0_p36013.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index 3792993dabc4..7fa8221619d7 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.10 2008/08/25 15:46:02 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.11 2008/09/01 22:02:33 jokey Exp $
+
+*webkit-gtk-0_p36013 (01 Sep 2008)
+
+ 01 Sep 2008; Markus Ullmann <jokey@gentoo.org>
+ +webkit-gtk-0_p36013.ebuild:
+ Version bump
*webkit-gtk-0_p35913 (25 Aug 2008)
diff --git a/net-libs/webkit-gtk/webkit-gtk-0_p36013.ebuild b/net-libs/webkit-gtk/webkit-gtk-0_p36013.ebuild
new file mode 100644
index 000000000000..94d381c84632
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-0_p36013.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-0_p36013.ebuild,v 1.1 2008/09/01 22:02:33 jokey Exp $
+
+inherit autotools
+
+MY_P="WebKit-r${PV/0\_p}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkit.org/"
+SRC_URI="http://nightly.webkit.org/files/trunk/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2 LGPL-2.1 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="coverage debug gstreamer pango soup sqlite svg xslt"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ >=dev-libs/icu-3.8.1-r1
+ >=net-misc/curl-7.15
+ media-libs/jpeg
+ media-libs/libpng
+ dev-libs/libxml2
+ sqlite? ( >=dev-db/sqlite-3 )
+ gstreamer? (
+ >=media-libs/gst-plugins-base-0.10
+ >=gnome-base/gnome-vfs-2.0
+ )
+ soup? ( >=net-libs/libsoup-2.23.1 )
+ xslt? ( dev-libs/libxslt )
+ pango? ( x11-libs/pango )"
+
+DEPEND="${RDEPEND}
+ dev-util/gperf
+ dev-util/pkgconfig
+ virtual/perl-Text-Balanced"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ local myconf
+ use pango && myconf="${myconf} --with-font-backend=pango"
+ use soup && myconf="${myconf} --with-http-backend=soup"
+
+ econf \
+ $(use_enable sqlite database) \
+ $(use_enable sqlite icon-database) \
+ $(use_enable sqlite dom-storage) \
+ $(use_enable sqlite offline-web-applications) \
+ $(use_enable gstreamer video) \
+ $(use_enable svg) \
+ $(use_enable debug) \
+ $(use_enable xslt) \
+ $(use_enable coverage) \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}