summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-10-13 21:22:02 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-10-13 21:22:02 +0000
commitc453d2a291f1167b81b759298c4b09ece5234758 (patch)
tree6c5ec36cffc476d8ae16ff05d5615565d1cf9f8f /net-libs
parentversion bump (diff)
downloadgentoo-2-c453d2a291f1167b81b759298c4b09ece5234758.tar.gz
gentoo-2-c453d2a291f1167b81b759298c4b09ece5234758.tar.bz2
gentoo-2-c453d2a291f1167b81b759298c4b09ece5234758.zip
git snapshot of the latest master since it fixes a lot of bugs with virt-manager and upstream for gtk-vnc doesn't recommend the current version with virt-manager since it exposes a crasher in gtk-vnc through normal usage. gtk-vnc upstream is too busy to make another release right now so we'll go with a git snapshot.
(Portage version: 2.1.9.17/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gtk-vnc/ChangeLog12
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.4.2_pre20100917.ebuild53
2 files changed, 64 insertions, 1 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index a9782bac0b1c..9f62c448b9ab 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.51 2010/10/08 23:13:49 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.52 2010/10/13 21:22:02 cardoe Exp $
+
+*gtk-vnc-0.4.2_pre20100917 (13 Oct 2010)
+
+ 13 Oct 2010; Doug Goldstein <cardoe@gentoo.org>
+ +gtk-vnc-0.4.2_pre20100917.ebuild:
+ git snapshot of the latest master since it fixes a lot of bugs with
+ virt-manager and upstream for gtk-vnc doesn't recommend the current
+ version with virt-manager since it exposes a crasher in gtk-vnc through
+ normal usage. gtk-vnc upstream is too busy to make another release right
+ now so we'll go with a git snapshot.
08 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
-gtk-vnc-0.3.8-r1.ebuild:
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.4.2_pre20100917.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.4.2_pre20100917.ebuild
new file mode 100644
index 000000000000..6e3d5ea77fce
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-0.4.2_pre20100917.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.4.2_pre20100917.ebuild,v 1.1 2010/10/13 21:22:02 cardoe Exp $
+
+EAPI="2"
+
+inherit base
+# gnome.org
+
+DESCRIPTION="VNC viewer widget for GTK."
+HOMEPAGE="http://live.gnome.org/gtk-vnc"
+
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples python sasl"
+
+# libview is used in examples/gvncviewer -- no need
+# TODO: review nsplugin when it will be considered less experimental
+
+RDEPEND=">=x11-libs/gtk+-2.18:2
+ >=net-libs/gnutls-1.4
+ x11-libs/cairo
+ x11-libs/libX11
+ python? ( >=dev-python/pygtk-2 )
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-perl/Text-CSV
+ dev-util/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.35"
+
+src_configure() {
+ econf \
+ $(use_with examples) \
+ $(use_with python) \
+ $(use_with sasl) \
+ --with-coroutine=gthread \
+ --without-libview \
+ --with-gtk=2.0 \
+ --disable-introspection \
+ --disable-static
+}
+
+src_install() {
+ # bug #328273
+ MAKEOPTS="${MAKEOPTS} -j1" \
+ base_src_install
+ dodoc AUTHORS ChangeLog NEWS README || die
+}