summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-03-03 22:51:29 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-03-03 22:51:29 +0000
commitbb82447615ebf0f6357a6f13dd57c627e6fe549b (patch)
treeac0c867b4d59ed02d649a3dca783f95e0bd59b5c /net-libs
parentremove old (diff)
downloadgentoo-2-bb82447615ebf0f6357a6f13dd57c627e6fe549b.tar.gz
gentoo-2-bb82447615ebf0f6357a6f13dd57c627e6fe549b.tar.bz2
gentoo-2-bb82447615ebf0f6357a6f13dd57c627e6fe549b.zip
remove old
(Portage version: 2.1.11.53/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog7
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild74
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.6.ebuild77
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.7.ebuild77
4 files changed, 6 insertions, 229 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index afaca6a61d6e..79b09281a11d 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.151 2013/02/10 14:42:00 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.152 2013/03/03 22:51:29 hwoarang Exp $
+
+ 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org>
+ -rb_libtorrent-0.16.3.ebuild, -rb_libtorrent-0.16.6.ebuild,
+ -rb_libtorrent-0.16.7.ebuild:
+ remove old
*rb_libtorrent-0.16.8 (10 Feb 2013)
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild
deleted file mode 100644
index 883818366106..000000000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild,v 1.3 2012/11/08 06:24:13 flameeyes Exp $
-
-EAPI="4"
-PYTHON_DEPEND="python? 2:2.6"
-PYTHON_USE_WITH="threads"
-PYTHON_USE_WITH_OPT="python"
-
-inherit multilib python versionator
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl static-libs"
-RESTRICT="test"
-
-DEPEND=">=dev-libs/boost-1.48[python?,threads(+)]
- >=sys-devel/libtool-2.2
- sys-libs/zlib
- examples? ( !net-p2p/mldonkey )
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- use python && python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- local myconf
-
- # use multi-threading versions of boost libs
- if has_version '>=dev-libs/boost-1.52.0-r1'; then
- myconf+=" --with-boost-python=boost_python-${PYTHON_ABI}"
- else
- myconf+=" --with-boost-system=boost_system-mt \
- --with-boost-python=boost_python-${PYTHON_ABI}-mt"
- fi
-
- local LOGGING
- use debug && myconf+=" --enable-logging=verbose"
-
- econf $(use_enable debug) \
- $(use_enable test tests) \
- $(use_enable examples) \
- $(use_enable python python-binding) \
- $(use_enable ssl encryption) \
- $(use_enable static-libs static) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
- dodoc ChangeLog AUTHORS NEWS README
- if use doc; then
- dohtml docs/*
- fi
-}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.6.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.6.ebuild
deleted file mode 100644
index a17259791211..000000000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.6.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.6.ebuild,v 1.1 2012/12/17 20:45:03 hwoarang Exp $
-
-EAPI="4"
-PYTHON_DEPEND="python? 2:2.6"
-PYTHON_USE_WITH="threads"
-PYTHON_USE_WITH_OPT="python"
-
-inherit multilib python versionator
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl static-libs"
-RESTRICT="test"
-
-DEPEND=">=dev-libs/boost-1.48[python?,threads(+)]
- >=sys-devel/libtool-2.2
- sys-libs/zlib
- examples? ( !net-p2p/mldonkey )
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- use python && python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- local myconf
-
- # bug 441842
- myconf="--disable-silent-rules"
-
- # use multi-threading versions of boost libs
- if has_version '>=dev-libs/boost-1.52.0-r1'; then
- myconf+=" --with-boost-python=boost_python-${PYTHON_ABI}"
- else
- myconf+=" --with-boost-system=boost_system-mt \
- --with-boost-python=boost_python-${PYTHON_ABI}-mt"
- fi
-
- local LOGGING
- use debug && myconf+=" --enable-logging=verbose"
-
- econf $(use_enable debug) \
- $(use_enable test tests) \
- $(use_enable examples) \
- $(use_enable python python-binding) \
- $(use_enable ssl encryption) \
- $(use_enable static-libs static) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
- dodoc ChangeLog AUTHORS NEWS README
- if use doc; then
- dohtml docs/*
- fi
-}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.7.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.7.ebuild
deleted file mode 100644
index c4f61b0496a9..000000000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.7.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.7.ebuild,v 1.1 2013/01/22 20:47:41 hwoarang Exp $
-
-EAPI="4"
-PYTHON_DEPEND="python? 2:2.6"
-PYTHON_USE_WITH="threads"
-PYTHON_USE_WITH_OPT="python"
-
-inherit multilib python versionator
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl static-libs"
-RESTRICT="test"
-
-DEPEND=">=dev-libs/boost-1.48[python?,threads(+)]
- >=sys-devel/libtool-2.2
- sys-libs/zlib
- examples? ( !net-p2p/mldonkey )
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- use python && python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- local myconf
-
- # bug 441842
- myconf="--disable-silent-rules"
-
- # use multi-threading versions of boost libs
- if has_version '>=dev-libs/boost-1.52.0-r1'; then
- myconf+=" --with-boost-python=boost_python-${PYTHON_ABI}"
- else
- myconf+=" --with-boost-system=boost_system-mt \
- --with-boost-python=boost_python-${PYTHON_ABI}-mt"
- fi
-
- local LOGGING
- use debug && myconf+=" --enable-logging=verbose"
-
- econf $(use_enable debug) \
- $(use_enable test tests) \
- $(use_enable examples) \
- $(use_enable python python-binding) \
- $(use_enable ssl encryption) \
- $(use_enable static-libs static) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
- dodoc ChangeLog AUTHORS NEWS README
- if use doc; then
- dohtml docs/*
- fi
-}