summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-08-01 00:38:20 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-08-01 00:38:20 +0000
commitba9bab554706e55e07e65c92eb940290eab101cb (patch)
tree91e53fb5f944346490e74ba33c463d1727f9a3d4 /net-libs
parentAdd missing file and die if cp failed, proxy commit for mozilla team (diff)
downloadgentoo-2-ba9bab554706e55e07e65c92eb940290eab101cb.tar.gz
gentoo-2-ba9bab554706e55e07e65c92eb940290eab101cb.tar.bz2
gentoo-2-ba9bab554706e55e07e65c92eb940290eab101cb.zip
Revision bump so users get the xulrunner-default-prefs.js file. No other changes, proxy commit for mozilla team
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xulrunner/ChangeLog9
-rw-r--r--net-libs/xulrunner/xulrunner-1.9.1.1-r1.ebuild240
2 files changed, 248 insertions, 1 deletions
diff --git a/net-libs/xulrunner/ChangeLog b/net-libs/xulrunner/ChangeLog
index d6489eb3fa77..ed790dcee32b 100644
--- a/net-libs/xulrunner/ChangeLog
+++ b/net-libs/xulrunner/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/xulrunner
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/ChangeLog,v 1.225 2009/08/01 00:31:41 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/ChangeLog,v 1.226 2009/08/01 00:38:20 darkside Exp $
+
+*xulrunner-1.9.1.1-r1 (01 Aug 2009)
+
+ 01 Aug 2009; Jeremy Olexa <darkside@gentoo.org>
+ +xulrunner-1.9.1.1-r1.ebuild:
+ Revision bump so users get the xulrunner-default-prefs.js file. No other
+ changes, proxy commit for mozilla team
01 Aug 2009; Jeremy Olexa <darkside@gentoo.org>
+files/xulrunner-default-prefs.js, xulrunner-1.9.1.1.ebuild:
diff --git a/net-libs/xulrunner/xulrunner-1.9.1.1-r1.ebuild b/net-libs/xulrunner/xulrunner-1.9.1.1-r1.ebuild
new file mode 100644
index 000000000000..6a3c84e5a97c
--- /dev/null
+++ b/net-libs/xulrunner/xulrunner-1.9.1.1-r1.ebuild
@@ -0,0 +1,240 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/xulrunner-1.9.1.1-r1.ebuild,v 1.1 2009/08/01 00:38:20 darkside Exp $
+
+EAPI="2"
+WANT_AUTOCONF="2.1"
+
+inherit flag-o-matic toolchain-funcs eutils mozconfig-3 makeedit multilib java-pkg-opt-2 python autotools
+
+MY_PV="${PV/_beta/b}" # Handle betas
+MY_PV="${PV/_/}" # Handle rc1, rc2 etc
+MY_PV="${MY_PV/1.9.1.1/3.5.1}"
+MAJ_PV="${PV/_*/}"
+PATCH="${PN}-${MAJ_PV}-patches-0.2"
+
+DESCRIPTION="Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications"
+HOMEPAGE="http://developer.mozilla.org/en/docs/XULRunner"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${MY_PV}/source/firefox-${MY_PV}-source.tar.bz2
+ http://dev.gentooexperimental.org/~anarchy/dist/${PATCH}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="1.9"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE="debug python" # qt-experimental
+
+# qt-experimental? (
+# x11-libs/qt-gui
+# x11-libs/qt-core )
+
+# nspr-4.8 due to BMO #499144
+RDEPEND="java? ( >=virtual/jre-1.4 )
+ python? ( >=dev-lang/python-2.3 )
+
+ >=sys-devel/binutils-2.16.1
+ >=dev-libs/nss-3.12.3
+ >=dev-libs/nspr-4.8
+ media-libs/alsa-lib
+ >=dev-db/sqlite-3.6.7
+ >=app-text/hunspell-1.2
+ >=media-libs/lcms-1.17
+
+ >=x11-libs/cairo-1.8.8[X]
+ x11-libs/pango[X]"
+
+DEPEND="java? ( >=virtual/jdk-1.4 )
+ ${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/mozilla-1.9.1"
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+
+pkg_setup(){
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ # Apply our patches
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"
+
+ # Same as in config/autoconf.mk.in
+ MOZLIBDIR="/usr/$(get_libdir)/${PN}-${MAJ_PV}"
+ SDKDIR="/usr/$(get_libdir)/${PN}-devel-${MAJ_PV}/sdk"
+ # Gentoo install dirs
+ sed -e "s/@PV@/${MAJ_PV}/" -i "${S}/config/autoconf.mk.in" \
+ || die "\${MAJ_PV} sed failed!"
+
+ # Enable gnomebreakpad
+ if use debug; then
+ sed -i -e 's/GNOME_DISABLE_CRASH_DIALOG=1/GNOME_DISABLE_CRASH_DIALOG=0/g' \
+ "${S}/build/unix/run-mozilla.sh"
+ fi
+
+ eautoreconf
+
+ cd js/src
+ eautoreconf
+}
+
+src_configure() {
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+ mozconfig_config
+
+ MEXTENSIONS="default"
+ if use python; then
+ MEXTENSIONS="${MEXTENSIONS},python/xpcom"
+ fi
+
+ MOZLIBDIR="/usr/$(get_libdir)/${PN}-${MAJ_PV}"
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
+ mozconfig_annotate '' --enable-application=xulrunner
+ mozconfig_annotate '' --disable-mailnews
+ mozconfig_annotate 'broken' --disable-crashreporter
+ mozconfig_annotate '' --enable-image-encoder=all
+ mozconfig_annotate '' --enable-canvas
+ # Bug 60668: Galeon doesn't build without oji enabled, so enable it
+ # regardless of java setting.
+ mozconfig_annotate '' --enable-oji --enable-mathml
+ mozconfig_annotate 'places' --enable-storage --enable-places
+ mozconfig_annotate '' --enable-safe-browsing
+
+ # System-wide install specs
+ mozconfig_annotate '' --disable-installer
+ mozconfig_annotate '' --disable-updater
+ mozconfig_annotate '' --disable-strip
+ mozconfig_annotate '' --disable-install-strip
+
+ # Use system libraries
+ mozconfig_annotate '' --enable-system-cairo
+ mozconfig_annotate '' --enable-system-hunspell
+ mozconfig_annotate '' --enable-system-sqlite
+ mozconfig_annotate '' --with-system-nspr
+ mozconfig_annotate '' --with-system-nss
+ mozconfig_annotate '' --enable-system-lcms
+ mozconfig_annotate '' --with-system-bz2
+
+ # IUSE qt-experimental
+# if use qt-experimental; then
+# ewarn "You are enabling the EXPERIMENTAL qt toolkit"
+# ewarn "Usage is at your own risk"
+# ewarn "Known to be broken. DO NOT file bugs."
+# mozconfig_annotate '' --disable-system-cairo
+# mozconfig_annotate 'qt-experimental' --enable-default-toolkit=cairo-qt
+# else
+ mozconfig_annotate 'gtk' --enable-default-toolkit=cairo-gtk2
+# fi
+
+ # Other ff-specific settings
+ mozconfig_annotate '' --enable-jsd
+ mozconfig_annotate '' --enable-xpctools
+ mozconfig_annotate '' --with-default-mozilla-five-home="${MOZLIBDIR}"
+
+ #disable java
+ if ! use java ; then
+ mozconfig_annotate '-java' --disable-javaxpcom
+ fi
+
+ # Debug
+ if use debug; then
+ mozconfig_annotate 'debug' --disable-optimize
+ mozconfig_annotate 'debug' --enable-debug=-ggdb
+ mozconfig_annotate 'debug' --enable-debug-modules=all
+ mozconfig_annotate 'debug' --enable-debugger-info-modules
+ fi
+
+ # Finalize and report settings
+ mozconfig_final
+
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ append-cxxflags -fno-stack-protector
+ fi
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+
+ CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+
+ # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
+ # to econf, but the quotes cause configure to fail.
+ sed -i -e \
+ 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|' \
+ "${S}"/config/autoconf.mk \
+ "${S}"/toolkit/content/buildconfig.html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm "${D}"/usr/bin/xulrunner
+
+ MOZLIBDIR="/usr/$(get_libdir)/${PN}-${MAJ_PV}"
+ SDKDIR="/usr/$(get_libdir)/${PN}-devel-${MAJ_PV}/sdk"
+
+ dodir /usr/bin
+ dosym "${MOZLIBDIR}/xulrunner" "/usr/bin/xulrunner-${MAJ_PV}"
+
+ # Install python modules
+ dosym "${MOZLIBDIR}/python/xpcom" "/$(python_get_sitedir)/xpcom"
+
+ # env.d file for ld search path
+ dodir /etc/env.d
+ echo "LDPATH=${MOZLIBDIR}" > "${D}"/etc/env.d/08xulrunner || die "env.d failed"
+
+ # Add our defaults to xulrunner and out of firefox
+ cp "${FILESDIR}"/xulrunner-default-prefs.js "${D}/${MOZLIBDIR}/defaults/pref/all-gentoo.js" || die "cp failed"
+
+ if use java ; then
+ java-pkg_regjar "${D}/${MOZLIBDIR}/javaxpcom.jar"
+ java-pkg_regjar "${D}/${SDKDIR}/lib/MozillaGlue.jar"
+ java-pkg_regjar "${D}/${SDKDIR}/lib/MozillaInterfaces.jar"
+ fi
+}
+
+pkg_postinst() {
+
+ MOZLIBDIR="/usr/$(get_libdir)/${PN}-${MAJ_PV}"
+
+ if use python; then
+ python_need_rebuild
+ python_mod_optimize "${MOZLIBDIR}/python"
+ fi
+
+ ewarn "If firefox fails to start with \"failed to load xpcom\", run revdep-rebuild"
+ ewarn "If that does not fix the problem, rebuild dev-libs/nss"
+ ewarn "Try dev-util/lafilefixer if you get build failures related to .la files"
+
+ einfo
+ einfo "All prefs can be overridden by the user. The preferences are to make"
+ einfo "use of xulrunner out of the box on an average system without the user"
+ einfo "having to go threw and enable the basics."
+}
+
+pkg_postrm() {
+
+ MOZLIBDIR="/usr/$(get_libdir)/${PN}-${MAJ_PV}"
+
+ if use python; then
+ python_mod_cleanup "${MOZLIBDIR}/python"
+ fi
+}