summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-10-07 14:02:05 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-10-07 14:02:05 +0000
commitb70ac68ea0e52ccc29e424cbad73af25237309dd (patch)
tree0906c50dd08c24ee86cfcf3d0715242e0154b52c /net-libs
parentVersion bump for new snapshot. Remove older version. (diff)
downloadgentoo-2-b70ac68ea0e52ccc29e424cbad73af25237309dd.tar.gz
gentoo-2-b70ac68ea0e52ccc29e424cbad73af25237309dd.tar.bz2
gentoo-2-b70ac68ea0e52ccc29e424cbad73af25237309dd.zip
Version bump.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libosip/ChangeLog8
-rw-r--r--net-libs/libosip/libosip-3.6.0.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/net-libs/libosip/ChangeLog b/net-libs/libosip/ChangeLog
index bb95e19df445..e55bfa17393f 100644
--- a/net-libs/libosip/ChangeLog
+++ b/net-libs/libosip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libosip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosip/ChangeLog,v 1.48 2012/01/06 15:04:14 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosip/ChangeLog,v 1.49 2012/10/07 14:02:05 chithanh Exp $
+
+*libosip-3.6.0 (07 Oct 2012)
+
+ 07 Oct 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libosip-3.6.0.ebuild:
+ Version bump.
06 Jan 2012; Brent Baude <ranger@gentoo.org> libosip-3.5.0.ebuild:
Marking libosip-3.5.0 ppc stable for bug 363311
diff --git a/net-libs/libosip/libosip-3.6.0.ebuild b/net-libs/libosip/libosip-3.6.0.ebuild
new file mode 100644
index 000000000000..9af5d4667e3b
--- /dev/null
+++ b/net-libs/libosip/libosip-3.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosip/libosip-3.6.0.ebuild,v 1.1 2012/10/07 14:02:05 chithanh Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+MY_PV=${PV%.?}-${PV##*.}
+MY_PV=${PV}
+MY_P=${PN}2-${MY_PV}
+DESCRIPTION="a simple way to support the Session Initiation Protocol"
+HOMEPAGE="http://www.gnu.org/software/osip/"
+SRC_URI="mirror://gnu/osip/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~ppc-macos ~x86-macos"
+IUSE="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.3.0-out-source-build.patch"
+ AT_M4DIR="scripts" eautoreconf
+}
+
+src_configure() {
+ econf --enable-mt \
+ $(use_enable test)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ dodoc AUTHORS ChangeLog FEATURES HISTORY README NEWS TODO || die
+}