summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2002-09-05 07:06:50 +0000
committerMatthew Turk <satai@gentoo.org>2002-09-05 07:06:50 +0000
commitb3dd79d2cd96c01e1c98103a1bd9ff30d6a0333f (patch)
tree0779a52b1f53db7a0cabc8afa78d9d1c3ecce4c1 /net-libs
parentnew package (diff)
downloadgentoo-2-b3dd79d2cd96c01e1c98103a1bd9ff30d6a0333f.tar.gz
gentoo-2-b3dd79d2cd96c01e1c98103a1bd9ff30d6a0333f.tar.bz2
gentoo-2-b3dd79d2cd96c01e1c98103a1bd9ff30d6a0333f.zip
Fixed the ebuild to accurately reflect --prefix=/usr , thus fixing the
libwww-config script.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libwww/ChangeLog11
-rw-r--r--net-libs/libwww/files/digest-libwww-5.4.0-r11
-rw-r--r--net-libs/libwww/libwww-5.4.0-r1.ebuild54
-rw-r--r--net-libs/libwww/libwww-5.4.0.ebuild3
4 files changed, 67 insertions, 2 deletions
diff --git a/net-libs/libwww/ChangeLog b/net-libs/libwww/ChangeLog
index 0f61445e2517..9771f13da3ec 100644
--- a/net-libs/libwww/ChangeLog
+++ b/net-libs/libwww/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/libwww
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/ChangeLog,v 1.2 2002/06/19 20:37:04 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/ChangeLog,v 1.3 2002/09/05 07:06:50 satai Exp $
+
+*libwww-5.4.0-r1 (05 Sep 2002)
+
+ 05 Sep 2002; Matthew Turk <satai@gentoo.org> libwww-5.4.0-r1.ebuild
+ files/digest-libwww-5.4.0-r1 :
+
+ Bumped revision to reflect *important* change in the ebuild - now the
+ prefixing works properly, which thus provides a proper libwww-config script.
+ This was broken previously.
*libwww-5.4.0 (19 Jun 2002)
diff --git a/net-libs/libwww/files/digest-libwww-5.4.0-r1 b/net-libs/libwww/files/digest-libwww-5.4.0-r1
new file mode 100644
index 000000000000..f875bc95b421
--- /dev/null
+++ b/net-libs/libwww/files/digest-libwww-5.4.0-r1
@@ -0,0 +1 @@
+MD5 c3734ca6caa405707e134cc8c6d7e422 w3c-libwww-5.4.0.tgz 1129121
diff --git a/net-libs/libwww/libwww-5.4.0-r1.ebuild b/net-libs/libwww/libwww-5.4.0-r1.ebuild
new file mode 100644
index 000000000000..ddfd2e516575
--- /dev/null
+++ b/net-libs/libwww/libwww-5.4.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.4.0-r1.ebuild,v 1.1 2002/09/05 07:06:50 satai Exp $
+
+inherit libtool
+
+MY_P=w3c-${P}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A general-purpose client side WEB API"
+SRC_URI="http://www.w3.org/Library/Distribution/${MY_P}.tgz"
+HOMEPAGE="http://www.w3.org/Library/"
+
+SLOT="0"
+LICENSE="W3C"
+KEYWORDS="x86 ppc sparc sparc64"
+
+
+DEPEND="sys-devel/perl
+ >=sys-libs/zlib-1.1.4
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+
+ local myconf
+
+ use mysql \
+ && myconf="--with-mysql" \
+ || myconf="--without-mysql"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ elibtoolize
+
+ ./configure \
+ --prefix=/usr \
+ --with-zlib \
+ --with-md5 \
+ --with-expat \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die
+ dodoc COPYRIGH ChangeLog
+ dohtml -r .
+
+}
diff --git a/net-libs/libwww/libwww-5.4.0.ebuild b/net-libs/libwww/libwww-5.4.0.ebuild
index dd9ea625af22..9d0714f21994 100644
--- a/net-libs/libwww/libwww-5.4.0.ebuild
+++ b/net-libs/libwww/libwww-5.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.4.0.ebuild,v 1.5 2002/08/16 02:57:06 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.4.0.ebuild,v 1.6 2002/09/05 07:06:50 satai Exp $
inherit libtool
@@ -35,6 +35,7 @@ src_compile() {
elibtoolize
./configure \
+ --with-prefix=/usr \
--with-zlib \
--with-md5 \
--with-expat \