summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-05-10 10:16:46 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-05-10 10:16:46 +0000
commitaeabc140f30e49c79f88c74078d6b29c4c16e310 (patch)
tree27d63bb9846fca0d60b836b3ab40ebd8acbe5448 /net-libs
parentVersion bump. Remove old (diff)
downloadgentoo-2-aeabc140f30e49c79f88c74078d6b29c4c16e310.tar.gz
gentoo-2-aeabc140f30e49c79f88c74078d6b29c4c16e310.tar.bz2
gentoo-2-aeabc140f30e49c79f88c74078d6b29c4c16e310.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.16.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index e5273e4ca81d..6b60a1ef5c97 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.172 2014/03/15 16:49:36 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.173 2014/05/10 10:16:46 hwoarang Exp $
+
+*rb_libtorrent-0.16.16 (10 May 2014)
+
+ 10 May 2014; Markos Chandras <hwoarang@gentoo.org>
+ +rb_libtorrent-0.16.16.ebuild:
+ Version bump
15 Mar 2014; Markos Chandras <hwoarang@gentoo.org>
-rb_libtorrent-0.16.12.ebuild, -rb_libtorrent-0.16.13.ebuild,
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.16.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.16.ebuild
new file mode 100644
index 000000000000..6b4449080f67
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.16.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.16.ebuild,v 1.1 2014/05/10 10:16:46 hwoarang Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2:2.6"
+PYTHON_USE_WITH="threads"
+PYTHON_USE_WITH_OPT="python"
+
+inherit multilib python versionator
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples python ssl static-libs"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/boost-1.48[python?,threads(+)]
+ >=sys-devel/libtool-2.2
+ sys-libs/zlib
+ examples? ( !net-p2p/mldonkey )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ use python && python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ local myconf
+
+ # bug 441842
+ myconf="--disable-silent-rules"
+
+ # use multi-threading versions of boost libs
+ if has_version '>=dev-libs/boost-1.52.0-r1'; then
+ myconf+=" --with-boost-python=boost_python-${PYTHON_ABI}"
+ else
+ myconf+=" --with-boost-system=boost_system-mt \
+ --with-boost-python=boost_python-${PYTHON_ABI}-mt"
+ fi
+
+ local LOGGING
+ use debug && myconf+=" --enable-logging=verbose"
+
+ econf $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ $(use_enable ssl encryption) \
+ $(use_enable static-libs static) \
+ --with-boost-libdir=/usr/$(get_libdir) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
+ dodoc ChangeLog AUTHORS NEWS README
+ if use doc; then
+ dohtml docs/*
+ fi
+}