summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-09-27 16:06:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-09-27 16:06:31 +0000
commit92fc59b624137edc82b021060a1b9e3cf72c152a (patch)
tree0d7ee6498f920de6af8f386b9d73812561761e86 /net-libs
parentVersion bump. (diff)
downloadgentoo-2-92fc59b624137edc82b021060a1b9e3cf72c152a.tar.gz
gentoo-2-92fc59b624137edc82b021060a1b9e3cf72c152a.tar.bz2
gentoo-2-92fc59b624137edc82b021060a1b9e3cf72c152a.zip
Fix build with recent check version, bug #498046. Apply a fix to pkgconfig from Debian. Update to EAPI=5 and team guidelines.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnet/ChangeLog12
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-fix-pkgconfig-abuse.patch16
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-test-existing-domain.patch32
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-unittest-build.patch22
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-unittest-service.patch31
-rw-r--r--net-libs/gnet/gnet-2.0.8-r2.ebuild68
6 files changed, 180 insertions, 1 deletions
diff --git a/net-libs/gnet/ChangeLog b/net-libs/gnet/ChangeLog
index 8f778d03ee96..d3b846ce0be7 100644
--- a/net-libs/gnet/ChangeLog
+++ b/net-libs/gnet/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-libs/gnet
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnet/ChangeLog,v 1.81 2014/08/10 20:48:33 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnet/ChangeLog,v 1.82 2014/09/27 16:06:31 eva Exp $
+
+*gnet-2.0.8-r2 (27 Sep 2014)
+
+ 27 Sep 2014; Gilles Dartiguelongue <eva@gentoo.org> +gnet-2.0.8-r2.ebuild,
+ +files/gnet-2.0.8-fix-pkgconfig-abuse.patch,
+ +files/gnet-2.0.8-test-existing-domain.patch,
+ +files/gnet-2.0.8-unittest-build.patch,
+ +files/gnet-2.0.8-unittest-service.patch:
+ Fix build with recent check version, bug #498046. Apply a fix to pkgconfig
+ from Debian. Update to EAPI=5 and team guidelines.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> gnet-2.0.8-r1.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/net-libs/gnet/files/gnet-2.0.8-fix-pkgconfig-abuse.patch b/net-libs/gnet/files/gnet-2.0.8-fix-pkgconfig-abuse.patch
new file mode 100644
index 000000000000..9c85b72d8e29
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-fix-pkgconfig-abuse.patch
@@ -0,0 +1,16 @@
+Bug-Debian: http://bugs.debian.org/652165
+Author: Julien Cristau <jcristau@debian.org>
+
+use pkg-config to get the glib include path, not hardcode it.
+
+--- gnet-2.0.8.orig/gnet-2.0.pc.in
++++ gnet-2.0.8/gnet-2.0.pc.in
+@@ -6,5 +6,6 @@
+ Name: Gnet
+ Description: A network compatibility layer library
+ Version: @VERSION@
+-Libs: -L${libdir} -lgnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@ @GLIB_LIBS@ @GTHREAD_LIBS@
+-Cflags: -I${includedir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@ -I${libdir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@/include/ @GLIB_CFLAGS@ @GTHREAD_CFLAGS@
++Libs: -L${libdir} -lgnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@
++Requires.private: glib-2.0 gthread-2.0
++Cflags: -I${includedir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@ -I${libdir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@/include/
diff --git a/net-libs/gnet/files/gnet-2.0.8-test-existing-domain.patch b/net-libs/gnet/files/gnet-2.0.8-test-existing-domain.patch
new file mode 100644
index 000000000000..b75258e38d02
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-test-existing-domain.patch
@@ -0,0 +1,32 @@
+From 1825f69b1a149cd3f2daa5f6c3333a32f0470f0a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim.muller@collabora.co.uk>
+Date: Sat, 16 Oct 2010 23:10:15 +0100
+Subject: tests: update GConnHttp unit test to not use inactive domains
+
+www.gnetlibrary.org has been abandoned.
+
+diff --git a/tests/check/gnet/gnetconnhttp.c b/tests/check/gnet/gnetconnhttp.c
+index b1cecce..4316f74 100644
+--- a/tests/check/gnet/gnetconnhttp.c
++++ b/tests/check/gnet/gnetconnhttp.c
+@@ -487,7 +487,7 @@ GNET_END_TEST;
+
+ GNET_START_TEST (test_gnet_http_get)
+ {
+- const gchar *urls[] = {"http://www.gnetlibrary.org/src/",
++ const gchar *urls[] = {"http://www.gnome.org/",
+ "http://www.heise.de" };
+ guint i;
+
+@@ -514,7 +514,7 @@ GNET_END_TEST;
+
+ GNET_START_TEST (test_get_binary)
+ {
+- gchar *uris[] = { "http://www.gnetlibrary.org/gnet.png" };
++ gchar *uris[] = { "http://www.gnome.org/img/logo/foot-16.png" };
+ guint i;
+
+ for (i = 0; i < G_N_ELEMENTS (uris); ++i) {
+--
+cgit v0.10.1
+
diff --git a/net-libs/gnet/files/gnet-2.0.8-unittest-build.patch b/net-libs/gnet/files/gnet-2.0.8-unittest-build.patch
new file mode 100644
index 000000000000..9527dbe5da65
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-unittest-build.patch
@@ -0,0 +1,22 @@
+Fix build failure with newer releases of check library.
+
+--- a/tests/check/gnetcheck.h 2014-09-27 15:32:17.088312230 +0200
++++ b/tests/check/gnetcheck.h 2014-09-27 15:32:35.728239492 +0200
+@@ -281,7 +281,7 @@
+ _gnet_check_expecting_log = TRUE; \
+ _gnet_check_raised_critical = FALSE; \
+ code; \
+- _fail_unless (_gnet_check_raised_critical, __FILE__, __LINE__, \
++ (_gnet_check_raised_critical) ? _mark_point(__FILE__, __LINE__) : _ck_assert_failed (__FILE__, __LINE__, \
+ "Expected g_critical, got nothing", NULL); \
+ _gnet_check_expecting_log = FALSE; \
+ } G_STMT_END
+@@ -291,7 +291,7 @@
+ _gnet_check_expecting_log = TRUE; \
+ _gnet_check_raised_warning = FALSE; \
+ code; \
+- _fail_unless (_gnet_check_raised_warning, __FILE__, __LINE__, \
++ (_gnet_check_raised_warning) ? _mark_point(__FILE__, __LINE__) : _ck_assert_failed (__FILE__, __LINE__, \
+ "Expected g_warning, got nothing", NULL); \
+ _gnet_check_expecting_log = FALSE; \
+ } G_STMT_END
diff --git a/net-libs/gnet/files/gnet-2.0.8-unittest-service.patch b/net-libs/gnet/files/gnet-2.0.8-unittest-service.patch
new file mode 100644
index 000000000000..f2946aaf438c
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-unittest-service.patch
@@ -0,0 +1,31 @@
+Disable unittests requiring a running HTTP server on port 80.
+
+--- a/tests/check/gnet/gnetinetaddr.c.old 2014-09-27 17:56:51.130350306 +0200
++++ b/tests/check/gnet/gnetinetaddr.c 2014-09-27 17:57:23.396114568 +0200
+@@ -443,7 +443,7 @@
+
+ GNET_START_TEST (test_inetaddr_list_async)
+ {
+- do_test_inetaddr_list_async ("localhost");
++/* do_test_inetaddr_list_async ("localhost"); */
+ /* FIXME: these might not work right yet because of the timings in the test
+ #ifdef GNET_ENABLE_NETWORK_TESTS
+ do_test_inetaddr_list_async ("www.google.com");
+@@ -573,7 +573,7 @@
+
+ GNET_START_TEST (test_inetaddr_name_async)
+ {
+- do_test_inetaddr_name_async ("localhost");
++/* do_test_inetaddr_name_async ("localhost"); */
+
+ /* FIXME: these might not work right yet because of the timings in the test
+ #ifdef GNET_ENABLE_NETWORK_TESTS
+@@ -798,7 +798,7 @@
+
+ GNET_START_TEST (test_inetaddr_reverse_async)
+ {
+- do_test_inetaddr_reverse_async ("localhost");
++/* do_test_inetaddr_reverse_async ("localhost"); */
+
+ #ifdef GNET_ENABLE_NETWORK_TESTS
+ do_test_inetaddr_reverse_async ("gabe.freedesktop.org");
diff --git a/net-libs/gnet/gnet-2.0.8-r2.ebuild b/net-libs/gnet/gnet-2.0.8-r2.ebuild
new file mode 100644
index 000000000000..e5e32200c2b3
--- /dev/null
+++ b/net-libs/gnet/gnet-2.0.8-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnet/gnet-2.0.8-r2.ebuild,v 1.1 2014/09/27 16:06:31 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A simple network library"
+HOMEPAGE="http://live.gnome.org/GNetLibrary"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+# FIXME: automagic use of valgrind
+RDEPEND=">=dev-libs/glib-2.6:2"
+DEPEND="${RDEPEND}
+ >=dev-libs/check-0.9.11
+ >=dev-util/gtk-doc-am-1.2
+ virtual/pkgconfig
+"
+# FIXME: check should only be needed with USE 'test', bug #349301
+# test? ( >=dev-libs/check-0.9.7 )"
+
+src_prepare() {
+ # Do not leak main context reference, from master
+ epatch "${FILESDIR}"/${PN}-2.0.8-context-leak.patch
+
+ # Fix usage of check framework, bug #296849, from master
+ epatch "${FILESDIR}"/${PN}-2.0.8-check-usage-update.patch
+
+ # ifdef around network tests code, refs. bug #320759
+ epatch "${FILESDIR}"/${PN}-2.0.8-network-tests.patch
+
+ # Do not hardcode glib patch in pkgconfig file, debian bug #652165
+ epatch "${FILESDIR}"/${PN}-2.0.8-fix-pkgconfig-abuse.patch
+
+ # Compatibility with recent check releases, bug #498046
+ epatch "${FILESDIR}"/${PN}-2.0.8-unittest-build.patch
+
+ # gnetlibrary.org has been adandoned, from master
+ epatch "${FILESDIR}"/${PN}-2.0.8-test-existing-domain.patch
+
+ # Do not depend on a running HTTP server on port 80 for unittest
+ epatch "${FILESDIR}"/${PN}-2.0.8-unittest-service.patch
+
+ # Do not pass silly cflags with USE=debug, bug #320759
+ sed -i \
+ -e 's:-Werror::' \
+ -e '/AM_PROG_CC_STDC/d' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' \
+ configure.ac || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README* TODO"
+ # Do not enable network tests in an ebuild environment
+ gnome2_src_configure \
+ --disable-static \
+ --disable-network-tests
+}