summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2013-06-01 23:47:24 +0000
committerJonathan Callen <abcd@gentoo.org>2013-06-01 23:47:24 +0000
commit8ff4c307682873e8a017958934dedd0984b45fe6 (patch)
tree3274799d2fa7b263d8cf1bb6785a20bfbe134a56 /net-libs
parentDrop unused eutils inherit. (diff)
downloadgentoo-2-8ff4c307682873e8a017958934dedd0984b45fe6.tar.gz
gentoo-2-8ff4c307682873e8a017958934dedd0984b45fe6.tar.bz2
gentoo-2-8ff4c307682873e8a017958934dedd0984b45fe6.zip
Fix build with USE=-python and empty PYTHON_TARGETS; force non-empty PYTHON_TARGETS for USE=python
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 229E5838)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gtk-vnc/ChangeLog6
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.5.2.ebuild11
2 files changed, 13 insertions, 4 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index f332d2006f54..173ec5acaa92 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.106 2013/04/24 07:06:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.107 2013/06/01 23:47:24 abcd Exp $
+
+ 01 Jun 2013; Jonathan Callen <abcd@gentoo.org> gtk-vnc-0.5.2.ebuild:
+ Fix build with USE=-python and empty PYTHON_TARGETS; force non-empty
+ PYTHON_TARGETS for USE=python
24 Apr 2013; Justin Lecher <jlec@gentoo.org> gtk-vnc-0.5.2.ebuild,
metadata.xml:
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.5.2.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.5.2.ebuild
index 5f2ecf6ac701..c5388f3233ed 100644
--- a/net-libs/gtk-vnc/gtk-vnc-0.5.2.ebuild
+++ b/net-libs/gtk-vnc/gtk-vnc-0.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.5.2.ebuild,v 1.3 2013/04/24 07:06:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.5.2.ebuild,v 1.4 2013/06/01 23:47:24 abcd Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -16,7 +16,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="examples gtk3 +introspection pulseaudio python sasl vala"
-REQUIRED_USE="vala? ( gtk3 introspection )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ vala? ( gtk3 introspection )
+"
# libview is used in examples/gvncviewer -- no need
# glib-2.30.1 needed to avoid linking failure due to .la files (bug #399129)
@@ -57,7 +60,9 @@ src_prepare() {
prepare_python() {
mkdir -p "${BUILD_DIR}" || die
}
- python_foreach_impl prepare_python
+ if use python; then
+ python_foreach_impl prepare_python
+ fi
# Remove a few files that were autogenerated during distcheck.
# Having these around in srcdir breaks out of tree build since they're