summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-06-23 11:52:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-06-23 11:52:00 +0000
commit8d07ea7e87551f2b5483344094a476048bb793dc (patch)
tree77412523370637b2d805882834748e36060d505a /net-libs
parentcleanup (diff)
downloadgentoo-2-8d07ea7e87551f2b5483344094a476048bb793dc.tar.gz
gentoo-2-8d07ea7e87551f2b5483344094a476048bb793dc.tar.bz2
gentoo-2-8d07ea7e87551f2b5483344094a476048bb793dc.zip
Fix parallel install with locales, bug #551530.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/phodav/ChangeLog6
-rw-r--r--net-libs/phodav/files/phodav-2.0-slot.patch39
-rw-r--r--net-libs/phodav/phodav-2.0-r1.ebuild11
3 files changed, 50 insertions, 6 deletions
diff --git a/net-libs/phodav/ChangeLog b/net-libs/phodav/ChangeLog
index 96241a194cea..d5ab8da94cae 100644
--- a/net-libs/phodav/ChangeLog
+++ b/net-libs/phodav/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/phodav
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/phodav/ChangeLog,v 1.11 2015/06/08 22:01:37 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/phodav/ChangeLog,v 1.12 2015/06/23 11:52:00 eva Exp $
+
+ 23 Jun 2015; Gilles Dartiguelongue <eva@gentoo.org> phodav-2.0-r1.ebuild,
+ +files/phodav-2.0-slot.patch:
+ Fix parallel install with locales, bug #551530.
*phodav-2.0-r1 (08 Jun 2015)
diff --git a/net-libs/phodav/files/phodav-2.0-slot.patch b/net-libs/phodav/files/phodav-2.0-slot.patch
new file mode 100644
index 000000000000..afbefe55c3c6
--- /dev/null
+++ b/net-libs/phodav/files/phodav-2.0-slot.patch
@@ -0,0 +1,39 @@
+From 65b410ddd9b6a797eb54c865e6365365604bc847 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@gmail.com>
+Date: Tue, 24 Feb 2015 22:41:39 +0100
+Subject: [PATCH] Add version prefix to gettext and doc directories
+
+---
+ configure.ac | 2 +-
+ doc/reference/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0fe907e..d87524e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,7 +55,7 @@ gl_WARN_ADD([-Wno-sign-compare])
+ gl_WARN_ADD([-Wno-unused-parameter])
+ gl_WARN_ADD([-Wno-missing-field-initializers])
+
+-GETTEXT_PACKAGE=phodav
++GETTEXT_PACKAGE=phodav-2.0
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, ["$GETTEXT_PACKAGE"], [Define to the Gettext package name])
+ AC_SUBST(GETTEXT_PACKAGE)
+ IT_PROG_INTLTOOL([0.40.0])
+diff --git a/doc/reference/Makefile.am b/doc/reference/Makefile.am
+index dfad455..c89ab35 100644
+--- a/doc/reference/Makefile.am
++++ b/doc/reference/Makefile.am
+@@ -1,7 +1,7 @@
+ NULL =
+ AUTOMAKE_OPTIONS = 1.6
+
+-DOC_MODULE = phodav
++DOC_MODULE = phodav-2.0
+ DOC_MAIN_SGML_FILE = $(DOC_MODULE)-docs.sgml
+ DOC_SOURCE_DIR = $(top_srcdir)/libphodav
+
+--
+2.4.3
+
diff --git a/net-libs/phodav/phodav-2.0-r1.ebuild b/net-libs/phodav/phodav-2.0-r1.ebuild
index d06ebe7769ac..dd51d97eefea 100644
--- a/net-libs/phodav/phodav-2.0-r1.ebuild
+++ b/net-libs/phodav/phodav-2.0-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/phodav/phodav-2.0-r1.ebuild,v 1.1 2015/06/08 22:01:37 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/phodav/phodav-2.0-r1.ebuild,v 1.2 2015/06/23 11:52:00 eva Exp $
EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit gnome2 systemd udev
+inherit autotools gnome2 systemd udev
DESCRIPTION="WebDav server implementation using libsoup"
HOMEPAGE="https://wiki.gnome.org/phodav"
@@ -32,9 +32,6 @@ DEPEND="${RDEPEND}
src_prepare() {
# Make doc parallel installable
cd "${S}"/doc/reference
- sed -e "s/\(DOC_MODULE.*=\).*/\1${PN}-${SLOT}/" \
- -e "s/\(DOC_MAIN_SGML_FILE.*=\).*/\1${PN}-docs-${SLOT}.sgml/" \
- -i Makefile.am Makefile.in || die
sed -e "s/\(<book.*name=\"\)${PN}/\1${PN}-${SLOT}/" \
-i html/${PN}.devhelp2 || die
mv ${PN}-docs{,-${SLOT}}.sgml || die
@@ -43,6 +40,10 @@ src_prepare() {
mv html/${PN}{,-${SLOT}}.devhelp2
cd "${S}"
+ # Fix locale slottability, from master
+ epatch "${FILESDIR}"/${P}-slot.patch
+ eautoreconf
+
gnome2_src_prepare
}