summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-07-11 19:08:02 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-07-11 19:08:02 +0000
commit8be2cd18e568f7ee2bc26d842ca89b2097a1b210 (patch)
treed7552337bcc683dd7ec252cd9ab8e03eb566f31a /net-libs
parentAdd ~alpha/~ia64/~sh/~sparc wrt #323831 (diff)
downloadgentoo-2-8be2cd18e568f7ee2bc26d842ca89b2097a1b210.tar.gz
gentoo-2-8be2cd18e568f7ee2bc26d842ca89b2097a1b210.tar.bz2
gentoo-2-8be2cd18e568f7ee2bc26d842ca89b2097a1b210.zip
QA: Add latest 1.2 series release. Direct stable on amd64 and x86 (fixes only bugs + the current situation is messy). Drop old. Fix enete 1.3. Use static-libs useflag.
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/enet/ChangeLog11
-rw-r--r--net-libs/enet/enet-1.0.ebuild6
-rw-r--r--net-libs/enet/enet-1.2.1.ebuild19
-rw-r--r--net-libs/enet/enet-1.2.2.ebuild23
-rw-r--r--net-libs/enet/enet-1.2.ebuild17
-rw-r--r--net-libs/enet/enet-1.3.0.ebuild16
6 files changed, 47 insertions, 45 deletions
diff --git a/net-libs/enet/ChangeLog b/net-libs/enet/ChangeLog
index b9e655353189..c4da53005e6a 100644
--- a/net-libs/enet/ChangeLog
+++ b/net-libs/enet/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/enet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/ChangeLog,v 1.17 2010/07/01 17:04:43 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/ChangeLog,v 1.18 2010/07/11 19:08:02 scarabeus Exp $
+
+*enet-1.2.2 (11 Jul 2010)
+
+ 11 Jul 2010; Tomáš Chvátal <scarabeus@gentoo.org> enet-1.0.ebuild,
+ -enet-1.2.ebuild, -enet-1.2.1.ebuild, +enet-1.2.2.ebuild,
+ enet-1.3.0.ebuild:
+ Add latest 1.2 series release. Direct stable on amd64 and x86 (fixes only
+ bugs + the current situation is messy). Drop old. Fix enete 1.3. Use
+ static-libs useflag.
*enet-1.3.0 (01 Jul 2010)
diff --git a/net-libs/enet/enet-1.0.ebuild b/net-libs/enet/enet-1.0.ebuild
index 3549751307e5..b035fd780695 100644
--- a/net-libs/enet/enet-1.0.ebuild
+++ b/net-libs/enet/enet-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/enet-1.0.ebuild,v 1.5 2007/07/05 20:03:20 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/enet-1.0.ebuild,v 1.6 2010/07/11 19:08:02 scarabeus Exp $
DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
HOMEPAGE="http://enet.bespin.org/"
@@ -8,7 +8,7 @@ SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~amd64 ppc ~ppc64 x86"
+KEYWORDS="ppc"
IUSE=""
src_install() {
diff --git a/net-libs/enet/enet-1.2.1.ebuild b/net-libs/enet/enet-1.2.1.ebuild
deleted file mode 100644
index f455bd0a8b4b..000000000000
--- a/net-libs/enet/enet-1.2.1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/enet-1.2.1.ebuild,v 1.1 2009/11/19 19:27:28 mr_bones_ Exp $
-
-DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
-HOMEPAGE="http://enet.bespin.org/"
-SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-S=${WORKDIR}/${PN}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ChangeLog *.txt README
-}
diff --git a/net-libs/enet/enet-1.2.2.ebuild b/net-libs/enet/enet-1.2.2.ebuild
new file mode 100644
index 000000000000..5543651a7172
--- /dev/null
+++ b/net-libs/enet/enet-1.2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/enet-1.2.2.ebuild,v 1.1 2010/07/11 19:08:02 scarabeus Exp $
+
+EAPI=3
+inherit base
+
+DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
+HOMEPAGE="http://enet.bespin.org/"
+SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="static-libs"
+
+DOCS=( "ChangeLog" "README" )
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
diff --git a/net-libs/enet/enet-1.2.ebuild b/net-libs/enet/enet-1.2.ebuild
deleted file mode 100644
index f7c04c0685cc..000000000000
--- a/net-libs/enet/enet-1.2.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/enet-1.2.ebuild,v 1.2 2008/07/03 17:08:29 rich0 Exp $
-
-DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
-HOMEPAGE="http://enet.bespin.org/"
-SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ChangeLog *.txt README
-}
diff --git a/net-libs/enet/enet-1.3.0.ebuild b/net-libs/enet/enet-1.3.0.ebuild
index 25a48ae51571..b0889760b035 100644
--- a/net-libs/enet/enet-1.3.0.ebuild
+++ b/net-libs/enet/enet-1.3.0.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/enet-1.3.0.ebuild,v 1.1 2010/07/01 17:04:43 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/enet-1.3.0.ebuild,v 1.2 2010/07/11 19:08:02 scarabeus Exp $
+
+EAPI=3
+inherit base
DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
HOMEPAGE="http://enet.bespin.org/"
@@ -9,9 +12,12 @@ SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
+IUSE="static-libs"
+
+DOCS=( "ChangeLog" "README" )
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ChangeLog *.txt README
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
}