summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-03-19 15:30:47 +0000
committerJeroen Roovers <jer@gentoo.org>2014-03-19 15:30:47 +0000
commit89c7a167a05a8e22dcce498cd639d53180f19c2e (patch)
tree30f214930fcfc4db76729bb5681a425062c86a09 /net-libs
parentStable for alpha, wrt bug #495688 (diff)
downloadgentoo-2-89c7a167a05a8e22dcce498cd639d53180f19c2e.tar.gz
gentoo-2-89c7a167a05a8e22dcce498cd639d53180f19c2e.tar.bz2
gentoo-2-89c7a167a05a8e22dcce498cd639d53180f19c2e.zip
Do not build a static library when it is not going to be installed.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnids/ChangeLog11
-rw-r--r--net-libs/libnids/files/libnids-1.24-static-libs.patch29
-rw-r--r--net-libs/libnids/libnids-1.18-r1.ebuild36
-rw-r--r--net-libs/libnids/libnids-1.24-r2.ebuild39
-rw-r--r--net-libs/libnids/libnids-1.24-r4.ebuild51
5 files changed, 89 insertions, 77 deletions
diff --git a/net-libs/libnids/ChangeLog b/net-libs/libnids/ChangeLog
index acbd23b22996..862d9ec8228c 100644
--- a/net-libs/libnids/ChangeLog
+++ b/net-libs/libnids/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libnids
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/ChangeLog,v 1.61 2013/06/29 18:36:23 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/ChangeLog,v 1.62 2014/03/19 15:30:47 jer Exp $
+
+*libnids-1.24-r4 (19 Mar 2014)
+
+ 19 Mar 2014; Jeroen Roovers <jer@gentoo.org> -libnids-1.18-r1.ebuild,
+ -libnids-1.24-r2.ebuild, +libnids-1.24-r4.ebuild,
+ +files/libnids-1.24-static-libs.patch:
+ Do not build a static library when it is not going to be installed.
29 Jun 2013; Agostino Sarubbo <ago@gentoo.org> libnids-1.18-r2.ebuild,
libnids-1.24-r3.ebuild:
diff --git a/net-libs/libnids/files/libnids-1.24-static-libs.patch b/net-libs/libnids/files/libnids-1.24-static-libs.patch
new file mode 100644
index 000000000000..7bf9a0f1b629
--- /dev/null
+++ b/net-libs/libnids/files/libnids-1.24-static-libs.patch
@@ -0,0 +1,29 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -62,19 +62,22 @@
+
+
+ $(LIBSTATIC): $(OBJS)
+- ar -cr $@ $(OBJS)
++ $(AR) -cr $@ $(OBJS)
+ $(RANLIB) $@
+ $(LIBSHARED): $(OBJS_SHARED)
+ $(CC) -shared -Wl,-soname,$(LIBSHARED) $(LDFLAGS) -o $(LIBSHARED) $(OBJS_SHARED) $(LIBS) $(LNETLIB) $(PCAPLIB)
+
+-_install install: $(LIBSTATIC)
++installbase:
+ ../mkinstalldirs $(install_prefix)$(libdir)
+ ../mkinstalldirs $(install_prefix)$(includedir)
+ ../mkinstalldirs $(install_prefix)$(mandir)/man3
+- $(INSTALL) -c -m 644 libnids.a $(install_prefix)$(libdir)
+ $(INSTALL) -c -m 644 nids.h $(install_prefix)$(includedir)
+ $(INSTALL) -c -m 644 libnids.3 $(install_prefix)$(mandir)/man3
+-_installshared installshared: install $(LIBSHARED)
++
++_install install: $(LIBSTATIC) installbase
++ $(INSTALL) -c -m 644 libnids.a $(install_prefix)$(libdir)
++
++_installshared installshared: $(LIBSHARED) installbase
+ $(INSTALL) -c -m 755 $(LIBSHARED) $(install_prefix)$(libdir)
+ ln -s -f $(LIBSHARED) $(install_prefix)$(libdir)/libnids.so
+
diff --git a/net-libs/libnids/libnids-1.18-r1.ebuild b/net-libs/libnids/libnids-1.18-r1.ebuild
deleted file mode 100644
index 223654ab6e96..000000000000
--- a/net-libs/libnids/libnids-1.18-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.18-r1.ebuild,v 1.7 2012/03/10 16:32:49 ranger Exp $
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="an implementation of an E-component of Network Intrusion Detection System"
-HOMEPAGE="http://www.packetfactory.net/Projects/libnids/"
-SRC_URI="http://www.packetfactory.net/Projects/libnids/dist/${P/_}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1.1"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="net-libs/libpcap
- >=net-libs/libnet-1.1.0-r3"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-chksum.c-ebx.patch \
- "${FILESDIR}"/${P}-elif.patch \
- "${FILESDIR}"/${PN}-1.24-ldflags.patch
-}
-
-src_configure() {
- econf --enable-shared || die "econf failed"
-}
-
-src_install() {
- emake install_prefix="${D}" install || die "emake install failed"
- dodoc CHANGES CREDITS MISC README
-}
diff --git a/net-libs/libnids/libnids-1.24-r2.ebuild b/net-libs/libnids/libnids-1.24-r2.ebuild
deleted file mode 100644
index fee6da60648b..000000000000
--- a/net-libs/libnids/libnids-1.24-r2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.24-r2.ebuild,v 1.5 2012/06/09 06:28:15 jdhore Exp $
-
-EAPI="4"
-
-inherit eutils
-
-DESCRIPTION="an implementation of an E-component of Network Intrusion Detection System"
-HOMEPAGE="http://libnids.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1.2"
-KEYWORDS="amd64 ppc x86"
-IUSE="+glib +libnet static-libs"
-
-DEPEND="net-libs/libpcap
- glib? ( dev-libs/glib )
- libnet? ( >=net-libs/libnet-1.1.0-r3 )"
-RDEPEND="${DEPEND}
- !net-libs/libnids:1.1"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-ldflags.patch"
-}
-
-src_configure() {
- local myconf="--enable-shared"
- use glib || myconf="${myconf} --disable-libglib"
- use libnet || myconf="${myconf} --disable-libnet"
- econf ${myconf}
-}
-
-src_install() {
- emake install_prefix="${D}" install
- use static-libs || rm -f "${D}"/usr/lib*/libnids.a
- dodoc CHANGES CREDITS MISC README doc/*
-}
diff --git a/net-libs/libnids/libnids-1.24-r4.ebuild b/net-libs/libnids/libnids-1.24-r4.ebuild
new file mode 100644
index 000000000000..be8a23c9c724
--- /dev/null
+++ b/net-libs/libnids/libnids-1.24-r4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.24-r4.ebuild,v 1.1 2014/03/19 15:30:47 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="an implementation of an E-component of Network Intrusion Detection System"
+HOMEPAGE="http://libnids.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1.2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+glib +libnet static-libs"
+
+DEPEND="
+ net-libs/libpcap
+ glib? ( dev-libs/glib )
+ libnet? ( >=net-libs/libnet-1.1.0-r3 )
+"
+RDEPEND="
+ ${DEPEND}
+ !net-libs/libnids:1.1
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}-static-libs.patch"
+}
+
+src_configure() {
+ tc-export AR
+ econf \
+ --enable-shared \
+ $(use_enable glib libglib) \
+ $(use_enable libnet libnet)
+}
+
+src_compile() {
+ emake shared $(usex static-libs static '')
+}
+
+src_install() {
+ local tgt
+ for tgt in _installshared $(usex static-libs _install ''); do
+ emake install_prefix="${D}" ${tgt}
+ done
+
+ dodoc CHANGES CREDITS MISC README doc/*
+}