summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-01-31 19:00:25 +0000
committerHanno Böck <hanno@gentoo.org>2010-01-31 19:00:25 +0000
commit832d6b01ad117fefa621f2f97f1a9607c8f34656 (patch)
tree068426131e1b1e970ee100017708d3341cc748c6 /net-libs
parentmake B43 and SSB config checks non-fatal, breaks binpkgs and it not the prope... (diff)
downloadgentoo-2-832d6b01ad117fefa621f2f97f1a9607c8f34656.tar.gz
gentoo-2-832d6b01ad117fefa621f2f97f1a9607c8f34656.tar.bz2
gentoo-2-832d6b01ad117fefa621f2f97f1a9607c8f34656.zip
courier-authlib bump
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/courier-authlib/ChangeLog11
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.63.0.ebuild162
2 files changed, 172 insertions, 1 deletions
diff --git a/net-libs/courier-authlib/ChangeLog b/net-libs/courier-authlib/ChangeLog
index dbfa52e717f3..0b312b9e4cbe 100644
--- a/net-libs/courier-authlib/ChangeLog
+++ b/net-libs/courier-authlib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/courier-authlib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/ChangeLog,v 1.106 2010/01/07 19:52:19 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/ChangeLog,v 1.107 2010/01/31 19:00:25 hanno Exp $
+
+*courier-authlib-0.63.0 (31 Jan 2010)
+
+ 31 Jan 2010; Hanno Boeck <hanno@gentoo.org>
+ +courier-authlib-0.63.0.ebuild:
+ Version bump, don't call install-migrate (there shouldn't be any
+ pre-authlib installations around any more and it causes access
+ violations), depend on postgresql 8.4 to avoid amd64 compilation issues
+ within the libpq-headers.
07 Jan 2010; Brent Baude <ranger@gentoo.org>
courier-authlib-0.62.4.ebuild:
diff --git a/net-libs/courier-authlib/courier-authlib-0.63.0.ebuild b/net-libs/courier-authlib/courier-authlib-0.63.0.ebuild
new file mode 100644
index 000000000000..57014fee0744
--- /dev/null
+++ b/net-libs/courier-authlib/courier-authlib-0.63.0.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.63.0.ebuild,v 1.1 2010/01/31 19:00:25 hanno Exp $
+
+inherit eutils flag-o-matic
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Courier authentication library."
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+HOMEPAGE="http://www.courier-mta.org/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="berkdb crypt debug gdbm ldap mysql pam postgres vpopmail"
+
+RESTRICT="userpriv
+ !berkdb? ( test )"
+
+RDEPEND="gdbm? ( sys-libs/gdbm )
+ !gdbm? ( sys-libs/db )"
+
+DEPEND="${RDEPEND}
+ >=dev-libs/openssl-0.9.6
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( >=virtual/postgresql-base-8.4 )"
+
+pkg_setup() {
+ enewuser mail -1 -1 /var/spool/mail
+
+ if ! has_version 'dev-tcltk/expect' ; then
+ ewarn 'The dev-tcltk/expect package is not installed.'
+ ewarn 'Without it, you will not be able to change system login passwords.'
+ ewarn 'However non-system authentication modules (LDAP, MySQL, PostgreSQL,'
+ ewarn 'and others) will work just fine.'
+ fi
+
+ if use vpopmail ; then
+ eerror
+ eerror "vpopmail support has been removed, it's unmaintained upstream and will be"
+ eerror "removed with the next release."
+ eerror
+ eerror "Please remove vpopmail USE-flag."
+ die "vpopmail support removed"
+ fi
+
+}
+
+src_compile() {
+ filter-flags -fomit-frame-pointer
+
+ local myconf=""
+
+ myconf="${myconf} `use_with pam authpam`"
+ myconf="${myconf} `use_with ldap authldap`"
+
+ if use berkdb ; then
+ if use gdbm ; then
+ ewarn "Both gdbm and berkdb selected. Using gdbm."
+ else
+ myconf="${myconf} --with-db=db"
+ fi
+ fi
+ use gdbm && myconf="${myconf} --with-db=gdbm"
+
+ myconf="${myconf} --without-authvchkpw `use_with mysql authmysql` `use_with postgres authpgsql`"
+
+ use debug && myconf="${myconf} debug=true"
+
+ einfo "Configuring courier-authlib: ${myconf}"
+
+ econf \
+ --sysconfdir=/etc/courier \
+ --datadir=/usr/share/courier \
+ --libexecdir=/usr/$(get_libdir)/courier \
+ --localstatedir=/var/lib/courier \
+ --sharedstatedir=/var/lib/courier/com \
+ --with-authdaemonvar=/var/lib/courier/authdaemon \
+ --with-authshadow \
+ --without-redhat \
+ --with-mailuser=mail \
+ --with-mailgroup=mail \
+ --cache-file="${S}/configuring.cache" \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+orderfirst() {
+ file="${D}/etc/courier/authlib/${1}" ; option="${2}" ; param="${3}"
+ if [[ -e "${file}" ]] ; then
+ orig="$(grep \"^${option}=\" ${file} | cut -d'\"' -f 2)"
+ new="${option}=\"${param} `echo ${orig} | sed -e\"s/${param}//g\" -e\"s/ / /g\"`\""
+ sed -i -e "s/^${option}=.*$/${new}/" "${file}"
+ fi
+}
+
+finduserdb() {
+ for dir in \
+ /etc/courier/authlib /etc/courier /etc/courier-imap \
+ /usr/lib/courier/etc /usr/lib/courier-imap/etc \
+ /usr/local/etc /usr/local/etc/courier /usr/local/courier/etc \
+ /usr/local/lib/courier/etc /usr/local/lib/courier-imap/etc \
+ /usr/local/share/sqwebmail /usr/local/etc/courier-imap ; do
+ if [[ -e "${dir}/userdb" ]] ; then
+ einfo "Found userdb at: ${dir}/userdb"
+ cp -f "${dir}/userdb" "${D}/etc/courier/authlib/"
+ chmod go-rwx "${D}/etc/courier/authlib/userdb"
+ continue
+ fi
+ done
+}
+
+src_install() {
+ diropts -o mail -g mail
+ dodir /etc/courier
+ keepdir /var/lib/courier/authdaemon
+ keepdir /etc/courier/authlib
+ emake DESTDIR="${D}" install || die "emake install failed"
+ [[ ! -e "${D}/etc/courier/authlib/userdb" ]] && finduserdb
+ emake DESTDIR="${D}" install-configure || die "emake install-configure failed"
+ rm -f "${D}"/etc/courier/authlib/*.bak
+ chown mail:mail "${D}"/etc/courier/authlib/*
+ for y in "${D}"/etc/courier/authlib/*.dist ; do
+ [[ ! -e "${y%%.dist}" ]] && cp -f "${y}" "${y%%.dist}"
+ done
+ use pam && orderfirst authdaemonrc authmodulelist authpam
+ use ldap && orderfirst authdaemonrc authmodulelist authldap
+ use postgres && orderfirst authdaemonrc authmodulelist authpgsql
+ use mysql && orderfirst authdaemonrc authmodulelist authmysql
+ dodoc AUTHORS ChangeLog* INSTALL NEWS README
+ dohtml README.html README_authlib.html NEWS.html INSTALL.html README.authdebug.html
+ if use mysql ; then
+ dodoc README.authmysql.myownquery
+ dohtml README.authmysql.html
+ fi
+ if use postgres ; then
+ dohtml README.authpostgres.html README.authmysql.html
+ fi
+ if use ldap ; then
+ dodoc README.ldap
+ dodir /etc/openldap/schema
+ cp -f authldap.schema "${D}/etc/openldap/schema/"
+ fi
+ doinitd "${FILESDIR}/${PN}" || die "doinitd failed"
+}
+
+pkg_postinst() {
+ if [[ -e /etc/courier/authlib/userdb ]] ; then
+ einfo "Running makeuserdb ..."
+ chmod go-rwx /etc/courier/authlib/userdb
+ makeuserdb
+ fi
+
+ # Suggest cleaning out the following old files
+ list="$(find /etc/courier -maxdepth 1 -type f | grep \"^/etc/courier/auth\")"
+ if [[ ! -z "${list}" ]] ; then
+ ewarn "Courier authentication files are now in /etc/courier/authlib/"
+ elog "The following files are no longer needed and can likely be removed:"
+ elog " rm $(echo \"${list}\")"
+ fi
+}