summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-27 16:12:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-27 16:12:48 +0000
commit7e3deb80a5b50d4c75c63228d612415f1af565f9 (patch)
treebd8dfaa7330debf16d6ba7522109bdcb8e0d6037 /net-libs
parentAdded new revision for testing which uses the brand-spankin-new games-mods.ec... (diff)
downloadgentoo-2-7e3deb80a5b50d4c75c63228d612415f1af565f9.tar.gz
gentoo-2-7e3deb80a5b50d4c75c63228d612415f1af565f9.tar.bz2
gentoo-2-7e3deb80a5b50d4c75c63228d612415f1af565f9.zip
Version bump.
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/ChangeLog8
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.10.43
-rw-r--r--net-libs/libtorrent/libtorrent-0.10.4.ebuild45
3 files changed, 55 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 10c241d748ae..533cb0d8cec0 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.71 2006/10/19 01:23:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.72 2006/10/27 16:12:48 flameeyes Exp $
+
+*libtorrent-0.10.4 (27 Oct 2006)
+
+ 27 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +libtorrent-0.10.4.ebuild:
+ Version bump.
*libtorrent-0.10.3-r1 (19 Oct 2006)
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.10.4 b/net-libs/libtorrent/files/digest-libtorrent-0.10.4
new file mode 100644
index 000000000000..98de39e52529
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.10.4
@@ -0,0 +1,3 @@
+MD5 3154a686d9616f04012596b8daa2ff52 libtorrent-0.10.4.tar.gz 485174
+RMD160 43fdfe827e6f56c7caed2406f5c0c6df28dcf007 libtorrent-0.10.4.tar.gz 485174
+SHA256 fbecbbe10e51f018bc8c921932b6134de0f05495e053429434bc9f25b01d2d2f libtorrent-0.10.4.tar.gz 485174
diff --git a/net-libs/libtorrent/libtorrent-0.10.4.ebuild b/net-libs/libtorrent/libtorrent-0.10.4.ebuild
new file mode 100644
index 000000000000..cd9ebfe2d4e1
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.10.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.10.4.ebuild,v 1.1 2006/10/27 16:12:48 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}