summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-17 20:50:51 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-17 20:50:51 +0000
commit7cb9459ee5fbc82b93472b943674f5843aa8409d (patch)
tree10026b729593b4d100636ed886efc832981101b5 /net-libs
parentarm stable, bug #476364 (diff)
downloadgentoo-2-7cb9459ee5fbc82b93472b943674f5843aa8409d.tar.gz
gentoo-2-7cb9459ee5fbc82b93472b943674f5843aa8409d.tar.bz2
gentoo-2-7cb9459ee5fbc82b93472b943674f5843aa8409d.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gupnp-av/ChangeLog7
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.12.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/net-libs/gupnp-av/ChangeLog b/net-libs/gupnp-av/ChangeLog
index 18164397bff5..20661eb2fd73 100644
--- a/net-libs/gupnp-av/ChangeLog
+++ b/net-libs/gupnp-av/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp-av
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/ChangeLog,v 1.31 2013/06/02 09:57:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/ChangeLog,v 1.32 2013/10/17 20:50:51 pacho Exp $
+
+*gupnp-av-0.12.3 (17 Oct 2013)
+
+ 17 Oct 2013; Pacho Ramos <pacho@gentoo.org> +gupnp-av-0.12.3.ebuild:
+ Version bump
02 Jun 2013; Pacho Ramos <pacho@gentoo.org> -gupnp-av-0.12.1.ebuild,
gupnp-av-0.12.2.ebuild:
diff --git a/net-libs/gupnp-av/gupnp-av-0.12.3.ebuild b/net-libs/gupnp-av/gupnp-av-0.12.3.ebuild
new file mode 100644
index 000000000000..e549827c6bf7
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.12.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/gupnp-av-0.12.3.ebuild,v 1.1 2013/10/17 20:50:51 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 vala
+
+DESCRIPTION="Utility library aiming to ease the handling UPnP A/V profiles"
+HOMEPAGE="http://gupnp.org/"
+
+LICENSE="LGPL-2"
+SLOT="0/2" # subslot: soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ >=net-libs/gssdp-0.9.2[introspection?]
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ dev-libs/libxml2
+ >=net-libs/gupnp-0.19[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ virtual/pkgconfig
+ introspection? ( $(vala_depend) )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ use introspection && vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-static
+}