summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-08-05 23:12:14 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-08-05 23:12:14 +0000
commit7c63e34f35b1ad6afe42ee644e775d4b5db342da (patch)
treed2c61acb9178fcb742d7903c4a5046f2b573f6f0 /net-libs
parentMissing deps, configure flags, .. rewrite (diff)
downloadgentoo-2-7c63e34f35b1ad6afe42ee644e775d4b5db342da.tar.gz
gentoo-2-7c63e34f35b1ad6afe42ee644e775d4b5db342da.tar.bz2
gentoo-2-7c63e34f35b1ad6afe42ee644e775d4b5db342da.zip
Version bump. Update to latest telepathy-spec, bug fixes. Clean up old revisions.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-glib/ChangeLog12
-rw-r--r--net-libs/telepathy-glib/files/telepathy-glib-0.7.33-fix-test.patch55
-rw-r--r--net-libs/telepathy-glib/files/telepathy-glib-0.7.33-nobuildtest.patch56
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.7.18.ebuild42
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.7.33.ebuild (renamed from net-libs/telepathy-glib/telepathy-glib-0.7.20.ebuild)25
5 files changed, 142 insertions, 48 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index ab78d6c2ab2f..cfcb96663aa4 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.30 2009/06/18 13:02:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.31 2009/08/05 23:12:13 eva Exp $
+
+*telepathy-glib-0.7.33 (05 Aug 2009)
+
+ 05 Aug 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ -telepathy-glib-0.7.18.ebuild, -telepathy-glib-0.7.20.ebuild,
+ +telepathy-glib-0.7.33.ebuild,
+ +files/telepathy-glib-0.7.33-fix-test.patch,
+ +files/telepathy-glib-0.7.33-nobuildtest.patch:
+ Version bump. Update to latest telepathy-spec, bug fixes. Clean up old
+ revisions.
18 Jun 2009; Alexis Ballier <aballier@gentoo.org>
telepathy-glib-0.7.31.ebuild:
diff --git a/net-libs/telepathy-glib/files/telepathy-glib-0.7.33-fix-test.patch b/net-libs/telepathy-glib/files/telepathy-glib-0.7.33-fix-test.patch
new file mode 100644
index 000000000000..4b6eba262fb8
--- /dev/null
+++ b/net-libs/telepathy-glib/files/telepathy-glib-0.7.33-fix-test.patch
@@ -0,0 +1,55 @@
+From 082f6e61b611efd35fbbd437e5741729244773ca Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Thu, 6 Aug 2009 01:00:05 +0200
+Subject: [PATCH] Do not unref dbus message if it is NULL.
+
+---
+ telepathy-glib/dbus.c | 12 ++++++++----
+ 1 files changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/telepathy-glib/dbus.c b/telepathy-glib/dbus.c
+index 60c9e37..28fba99 100644
+--- a/telepathy-glib/dbus.c
++++ b/telepathy-glib/dbus.c
+@@ -1014,7 +1014,8 @@ _tp_dbus_daemon_get_name_owner (TpDBusDaemon *self,
+ reply = dbus_connection_send_with_reply_and_block (dbc, message,
+ timeout_ms, &dbus_error);
+
+- dbus_message_unref (message);
++ if (message)
++ dbus_message_unref (message);
+
+ if (reply == NULL)
+ {
+@@ -1026,7 +1027,8 @@ _tp_dbus_daemon_get_name_owner (TpDBusDaemon *self,
+ "%s: %s", dbus_error.name, dbus_error.message);
+
+ dbus_error_free (&dbus_error);
+- dbus_message_unref (reply);
++ if (reply)
++ dbus_message_unref (reply);
+ return FALSE;
+ }
+
+@@ -1038,14 +1040,16 @@ _tp_dbus_daemon_get_name_owner (TpDBusDaemon *self,
+ "%s: %s", dbus_error.name, dbus_error.message);
+
+ dbus_error_free (&dbus_error);
+- dbus_message_unref (reply);
++ if (reply)
++ dbus_message_unref (reply);
+ return FALSE;
+ }
+
+ if (unique_name != NULL)
+ *unique_name = g_strdup (name_in_reply);
+
+- dbus_message_unref (reply);
++ if (reply)
++ dbus_message_unref (reply);
+
+ return TRUE;
+ }
+--
+1.6.3.3
+
diff --git a/net-libs/telepathy-glib/files/telepathy-glib-0.7.33-nobuildtest.patch b/net-libs/telepathy-glib/files/telepathy-glib-0.7.33-nobuildtest.patch
new file mode 100644
index 000000000000..f9ea5a9dc998
--- /dev/null
+++ b/net-libs/telepathy-glib/files/telepathy-glib-0.7.33-nobuildtest.patch
@@ -0,0 +1,56 @@
+From c6d18bd6e7b7f578cc97fe38f40e917af2f9270a Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Thu, 6 Aug 2009 00:25:18 +0200
+Subject: [PATCH] Compile test programs only when needed
+
+---
+ tests/Makefile.am | 4 ++--
+ tests/dbus/Makefile.am | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 900c281..e65c01d 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -4,7 +4,7 @@ SUBDIRS = \
+ dbus \
+ tools
+
+-noinst_PROGRAMS = \
++check_PROGRAMS = \
+ test-asv \
+ test-availability-cmp \
+ test-heap \
+@@ -12,7 +12,7 @@ noinst_PROGRAMS = \
+ test-intset \
+ test-util
+
+-TESTS = $(noinst_PROGRAMS) \
++TESTS = $(check_PROGRAMS) \
+ all-errors-documented.py
+
+ TESTS_ENVIRONMENT = \
+diff --git a/tests/dbus/Makefile.am b/tests/dbus/Makefile.am
+index 442ddd1..1baeb3d 100644
+--- a/tests/dbus/Makefile.am
++++ b/tests/dbus/Makefile.am
+@@ -1,6 +1,6 @@
+ include $(top_srcdir)/tools/shave.mk
+
+-noinst_PROGRAMS = \
++check_PROGRAMS = \
+ test-account \
+ test-account-manager \
+ test-call-cancellation \
+@@ -39,7 +39,7 @@ noinst_PROGRAMS = \
+ test-text-respawn \
+ test-unsupported-interface
+
+-TESTS = $(noinst_PROGRAMS)
++TESTS = $(check_PROGRAMS)
+
+ LDADD = \
+ $(top_builddir)/telepathy-glib/libtelepathy-glib.la \
+--
+1.6.3.3
+
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.7.18.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.7.18.ebuild
deleted file mode 100644
index a0bd5aa7c6d5..000000000000
--- a/net-libs/telepathy-glib/telepathy-glib-0.7.18.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.7.18.ebuild,v 1.3 2008/12/24 10:03:16 bluebird Exp $
-
-DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
-HOMEPAGE="http://telepathy.freedesktop.org"
-SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
-IUSE="debug doc"
-
-RDEPEND=">=dev-libs/glib-2.16
- >=dev-libs/dbus-glib-0.73
- >=dev-lang/python-2.3"
-
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- >=dev-util/pkgconfig-0.21
- doc? ( >=dev-util/gtk-doc-1.10 )"
-
-src_compile() {
- econf \
- $(use_enable doc gtk-doc) \
- $(use_enable debug) \
- $(use_enable debug backtrace) \
- $(use_enable debug handle-leak-debug) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_test() {
- if ! dbus-launch emake -j1 check; then
- die "Make check failed. See above for details."
- fi
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README
-}
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.7.20.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.7.33.ebuild
index 0f42ed0b85cb..47ab52c600c1 100644
--- a/net-libs/telepathy-glib/telepathy-glib-0.7.20.ebuild
+++ b/net-libs/telepathy-glib/telepathy-glib-0.7.33.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.7.20.ebuild,v 1.2 2009/01/07 16:57:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.7.33.ebuild,v 1.1 2009/08/05 23:12:13 eva Exp $
+
+EAPI="2"
+
+inherit autotools eutils libtool
DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
HOMEPAGE="http://telepathy.freedesktop.org"
@@ -8,7 +12,7 @@ SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="debug doc"
RDEPEND=">=dev-libs/glib-2.16
@@ -18,16 +22,27 @@ RDEPEND=">=dev-libs/glib-2.16
DEPEND="${RDEPEND}
dev-libs/libxslt
>=dev-util/pkgconfig-0.21
+ dev-util/gtk-doc-am
doc? ( >=dev-util/gtk-doc-1.10 )"
-src_compile() {
+src_prepare() {
+ # Make test suite pass, upstream bug #23164
+ epatch "${FILESDIR}/${P}-fix-test.patch"
+
+ # Do not build tests if not needed
+ epatch "${FILESDIR}/${P}-nobuildtest.patch"
+
+ #elibtoolize # for sane .so versionning on BSD
+ eautoreconf
+}
+
+src_configure() {
econf \
$(use_enable doc gtk-doc) \
$(use_enable debug) \
$(use_enable debug backtrace) \
$(use_enable debug handle-leak-debug) \
|| die "econf failed"
- emake || die "emake failed"
}
src_test() {
@@ -38,5 +53,5 @@ src_test() {
src_install() {
emake install DESTDIR="${D}" || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
}