summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-11-18 14:57:43 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-11-18 14:57:43 +0000
commit78c721f1583b91d7d241f2f49659e5286a377e62 (patch)
tree6185a45dcd6191d57a52df9d9fbf71b0f0784169 /net-libs
parentx86 stable wrt bug #345663 (diff)
downloadgentoo-2-78c721f1583b91d7d241f2f49659e5286a377e62.tar.gz
gentoo-2-78c721f1583b91d7d241f2f49659e5286a377e62.tar.bz2
gentoo-2-78c721f1583b91d7d241f2f49659e5286a377e62.zip
Version bump
(Portage version: 2.2_rc90/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-qt4/ChangeLog8
-rw-r--r--net-libs/telepathy-qt4/telepathy-qt4-0.5.0.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/net-libs/telepathy-qt4/ChangeLog b/net-libs/telepathy-qt4/ChangeLog
index e6c8a8ebf213..7b2d051a2a35 100644
--- a/net-libs/telepathy-qt4/ChangeLog
+++ b/net-libs/telepathy-qt4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/telepathy-qt4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/ChangeLog,v 1.2 2010/06/02 19:50:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/ChangeLog,v 1.3 2010/11/18 14:57:43 chiiph Exp $
+
+*telepathy-qt4-0.5.0 (18 Nov 2010)
+
+ 18 Nov 2010; Tomas Touceda <chiiph@gentoo.org>
+ +telepathy-qt4-0.5.0.ebuild:
+ Version bump
*telepathy-qt4-0.3.4-r1 (02 Jun 2010)
diff --git a/net-libs/telepathy-qt4/telepathy-qt4-0.5.0.ebuild b/net-libs/telepathy-qt4/telepathy-qt4-0.5.0.ebuild
new file mode 100644
index 000000000000..534c90fd15c2
--- /dev/null
+++ b/net-libs/telepathy-qt4/telepathy-qt4-0.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/telepathy-qt4-0.5.0.ebuild,v 1.1 2010/11/18 14:57:43 chiiph Exp $
+
+PYTHON_DEPEND="2"
+
+EAPI="2"
+inherit python base cmake-utils
+
+DESCRIPTION="Qt4 bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-dbus:4"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/pkgconfig
+ net-libs/telepathy-farsight"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs="-DHAVE_QDBUSVARIANT_OPERATOR_EQUAL=1 "
+ if use debug; then
+ mycmakeargs+="-DCMAKE_BUILD_TYPE=Debug"
+ fi
+ cmake-utils_src_configure
+}