summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-22 18:42:11 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-22 18:42:11 +0000
commit7703480f233fc6c1e4772850a3e2cb3697dc6498 (patch)
tree8748d9f74d8ceed370586694a222a306d798dcb6 /net-libs
parentVersion bump. (diff)
downloadgentoo-2-7703480f233fc6c1e4772850a3e2cb3697dc6498.tar.gz
gentoo-2-7703480f233fc6c1e4772850a3e2cb3697dc6498.tar.bz2
gentoo-2-7703480f233fc6c1e4772850a3e2cb3697dc6498.zip
Version bump and fix underlinking problems in gtk3 version (bug #371751).
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/ChangeLog9
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.4.3-underlinking.patch90
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.4.3-r200.ebuild135
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.4.3-r300.ebuild140
4 files changed, 373 insertions, 1 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index e1e0d0ded2f8..27164371cc20 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.119 2011/08/31 13:11:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.120 2011/09/22 18:42:10 pacho Exp $
+
+*webkit-gtk-1.4.3-r300 (22 Sep 2011)
+*webkit-gtk-1.4.3-r200 (22 Sep 2011)
+
+ 22 Sep 2011; Pacho Ramos <pacho@gentoo.org> +webkit-gtk-1.4.3-r200.ebuild,
+ +webkit-gtk-1.4.3-r300.ebuild, +files/webkit-gtk-1.4.3-underlinking.patch:
+ Version bump and fix underlinking problems in gtk3 version (bug #371751).
31 Aug 2011; Pacho Ramos <pacho@gentoo.org> webkit-gtk-1.2.7.ebuild:
Parallel build fails for 1.2.x, seems fixed in 1.4.x (bug #343249).
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.4.3-underlinking.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.4.3-underlinking.patch
new file mode 100644
index 000000000000..f53053102fc7
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.4.3-underlinking.patch
@@ -0,0 +1,90 @@
+Index: /trunk/ChangeLog
+===================================================================
+--- /trunk/ChangeLog (revision 82570)
++++ /trunk/ChangeLog (revision 82599)
+@@ -1,2 +1,16 @@
++2011-03-31 Xan Lopez <xlopez@igalia.com>
++
++ Reviewed by Martin Robinson.
++
++ [GTK] Link explicitly with XRender on Linux/Unix
++ https://bugs.webkit.org/show_bug.cgi?id=57558
++
++ Some linkers, like GNU Gold, require explicit linkage of all the
++ libraries used instead of relying on our dependencies to bring
++ them in. In this case, the build fails because we use XRender in
++ the plugin code but don't link directly to it.
++
++ * configure.ac: check for XRender on UNIX.
++
+ 2011-03-31 Vamshikrishna.Yellenki <vamshi@motorola.com> and Alejandro G. Castro <alex@igalia.com>
+
+Index: /trunk/Source/WebKit/gtk/GNUmakefile.am
+===================================================================
+--- /trunk/Source/WebKit/gtk/GNUmakefile.am (revision 80561)
++++ /trunk/Source/WebKit/gtk/GNUmakefile.am (revision 82599)
+@@ -103,4 +103,5 @@
+ $(SQLITE3_LIBS) \
+ $(UNICODE_LIBS) \
++ $(XRENDER_LIBS) \
+ $(XT_LIBS) \
+ $(WINMM_LIBS) \
+Index: /trunk/Source/WebKit/gtk/ChangeLog
+===================================================================
+--- /trunk/Source/WebKit/gtk/ChangeLog (revision 82582)
++++ /trunk/Source/WebKit/gtk/ChangeLog (revision 82599)
+@@ -1,2 +1,11 @@
++2011-03-31 Xan Lopez <xlopez@igalia.com>
++
++ Reviewed by Martin Robinson.
++
++ [GTK] Link explicitly with XRender on Linux/Unix
++ https://bugs.webkit.org/show_bug.cgi?id=57558
++
++ * GNUmakefile.am: add XRender LIBS.
++
+ 2011-03-31 Evan Martin <evan@chromium.org>
+
+Index: /trunk/Source/WebCore/ChangeLog
+===================================================================
+--- /trunk/Source/WebCore/ChangeLog (revision 82597)
++++ /trunk/Source/WebCore/ChangeLog (revision 82599)
+@@ -1,2 +1,11 @@
++2011-03-31 Xan Lopez <xlopez@igalia.com>
++
++ Reviewed by Martin Robinson.
++
++ [GTK] Link explicitly with XRender on Linux/Unix
++ https://bugs.webkit.org/show_bug.cgi?id=57558
++
++ * GNUmakefile.am: add XRender CFLAGS.
++
+ 2011-03-31 Eric Seidel <eric@webkit.org>
+
+Index: /trunk/Source/WebCore/GNUmakefile.am
+===================================================================
+--- /trunk/Source/WebCore/GNUmakefile.am (revision 82580)
++++ /trunk/Source/WebCore/GNUmakefile.am (revision 82599)
+@@ -5111,4 +5111,5 @@
+ $(SQLITE3_CFLAGS) \
+ $(UNICODE_CFLAGS) \
++ $(XRENDER_CFLAGS) \
+ $(XT_CFLAGS)
+
+Index: /trunk/configure.ac
+===================================================================
+--- /trunk/configure.ac (revision 81641)
++++ /trunk/configure.ac (revision 82599)
+@@ -937,4 +937,12 @@
+ AC_SUBST([GEOCLUE_CFLAGS])
+ AC_SUBST([GEOCLUE_LIBS])
++fi
++
++# check for XRender under Linux/Unix. Some linkers require explicit
++# linkage (like GNU Gold), so we cannot rely on GTK+ pulling XRender
++if test "$os_win32" = "no"; then
++ PKG_CHECK_MODULES([XRENDER], [xrender])
++ AC_SUBST([XRENDER_CFLAGS])
++ AC_SUBST([XRENDER_LIBS])
+ fi
+
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.4.3-r200.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.4.3-r200.ebuild
new file mode 100644
index 000000000000..72e57a83cf2f
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-1.4.3-r200.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.4.3-r200.ebuild,v 1.1 2011/09/22 18:42:10 pacho Exp $
+
+EAPI="4"
+
+inherit autotools flag-o-matic eutils virtualx
+
+MY_P="webkit-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkitgtk.org/"
+SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1 BSD"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+# geoclue
+IUSE="aqua coverage debug doc spell +gstreamer +introspection +jit"
+# bug 372493
+REQUIRED_USE="introspection? ( gstreamer )"
+
+# use sqlite, svg by default
+# dependency on >=x11-libs/gtk+-2.13:2 for gail
+RDEPEND="
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ virtual/jpeg
+ >=media-libs/libpng-1.4:0
+ x11-libs/cairo
+ >=dev-libs/glib-2.27.90:2
+ >=x11-libs/gtk+-2.13:2[aqua=,introspection?]
+ >=dev-libs/icu-3.8.1-r1
+ >=net-libs/libsoup-2.33.6:2.4[introspection?]
+ dev-db/sqlite:3
+ >=x11-libs/pango-1.12
+ x11-libs/libXrender
+
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ >=media-libs/gst-plugins-base-0.10.25:0.10 )
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+
+ spell? ( >=app-text/enchant-0.22 )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/flex-2.5.33
+ sys-devel/gettext
+ virtual/yacc
+ dev-util/gperf
+ dev-util/pkgconfig
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ test? ( x11-themes/hicolor-icon-theme )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ DOCS="Source/WebKit/gtk/NEWS Source/WebKit/gtk/ChangeLog"
+
+ # FIXME: Fix unaligned accesses on ARM, IA64 and SPARC
+ # https://bugs.webkit.org/show_bug.cgi?id=19775
+ use sparc && epatch "${FILESDIR}"/${PN}-1.1.15.2-unaligned.patch
+
+ # intermediate MacPorts hack while upstream bug is not fixed properly
+ # https://bugs.webkit.org/show_bug.cgi?id=28727
+ use aqua && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
+
+ # Fix build on Darwin8 (10.4 Tiger)
+ # XXX: Fails to apply
+ #epatch "${FILESDIR}"/${PN}-1.2.5-darwin8.patch
+
+ # Don't force -O2
+ sed -i 's/-O2//g' "${S}"/configure.ac
+
+ # Don't build tests if not needed, part of bug #343249
+ # XXX: Fails to apply
+ #epatch "${FILESDIR}/${PN}-1.2.5-tests-build.patch"
+
+ # Prevent maintainer mode from being triggered during make
+ AT_M4DIR=Source/autotools eautoreconf
+}
+
+src_configure() {
+ # It doesn't compile on alpha without this in LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # Sigbuses on SPARC with mcpu and co.
+ use sparc && filter-flags "-mcpu=*" "-mvis" "-mtune=*"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ local myconf
+
+ # XXX: Check Web Audio support
+ # XXX: webgl fails compilation
+ # XXX: WebKit2 is the new out-of-process model, doesn't work yet
+ myconf="
+ $(use_enable coverage)
+ $(use_enable debug)
+ $(use_enable spell spellcheck)
+ $(use_enable introspection)
+ $(use_enable gstreamer video)
+ $(use_enable jit)
+ --disable-webgl
+ --with-gtk=2.0
+ --disable-webkit2
+ --disable-web-sockets
+ $(use aqua && echo "--with-font-backend=pango --with-target=quartz")"
+ # Disable web-sockets per bug #326547
+
+ econf ${myconf}
+}
+
+src_compile() {
+ # Fix sandbox error with USE="introspection"
+ # https://bugs.webkit.org/show_bug.cgi?id=35471
+ emake XDG_DATA_HOME="${T}/.local"
+}
+
+src_test() {
+ unset DISPLAY
+ # Tests need virtualx, bug #294691, bug #310695
+ # Set XDG_DATA_HOME for introspection tools, bug #323669
+ Xemake check XDG_DATA_HOME="${T}/.local"
+}
+
+src_install() {
+ default
+
+ # Remove .la files
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.4.3-r300.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.4.3-r300.ebuild
new file mode 100644
index 000000000000..20ee32842999
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-1.4.3-r300.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.4.3-r300.ebuild,v 1.1 2011/09/22 18:42:10 pacho Exp $
+
+EAPI="4"
+
+inherit autotools flag-o-matic eutils virtualx
+
+MY_P="webkit-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkitgtk.org/"
+SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1 BSD"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+# geoclue
+IUSE="aqua coverage debug doc +gstreamer +introspection +jit spell"
+# bug 372493
+REQUIRED_USE="introspection? ( gstreamer )"
+
+# use sqlite, svg by default
+# dependency on >=x11-libs/gtk+-2.13:2 for gail
+# Aqua support in gtk3 is untested
+RDEPEND="
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ virtual/jpeg
+ >=media-libs/libpng-1.4:0
+ x11-libs/cairo
+ >=dev-libs/glib-2.27.90:2
+ >=x11-libs/gtk+-3.0:3[aqua=,introspection?]
+ >=dev-libs/icu-3.8.1-r1
+ >=net-libs/libsoup-2.33.6:2.4[introspection?]
+ dev-db/sqlite:3
+ >=x11-libs/pango-1.12
+ x11-libs/libXrender
+
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ >=media-libs/gst-plugins-base-0.10.25:0.10 )
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+
+ spell? ( >=app-text/enchant-0.22 )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/flex-2.5.33
+ sys-devel/gettext
+ virtual/yacc
+ dev-util/gperf
+ dev-util/pkgconfig
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ test? ( x11-themes/hicolor-icon-theme )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ DOCS="Source/WebKit/gtk/NEWS Source/WebKit/gtk/ChangeLog"
+
+ # Link explicitly with XRender on Linux/Unix, bug #371751
+ epatch "${FILESDIR}/${PN}-1.4.3-underlinking.patch"
+
+ # FIXME: Fix unaligned accesses on ARM, IA64 and SPARC
+ # https://bugs.webkit.org/show_bug.cgi?id=19775
+ use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
+
+ # intermediate MacPorts hack while upstream bug is not fixed properly
+ # https://bugs.webkit.org/show_bug.cgi?id=28727
+ use aqua && epatch "${FILESDIR}"/${PN}-1.2.5-darwin-quartz.patch
+
+ # Fix build on Darwin8 (10.4 Tiger)
+ # XXX: Fails to apply
+ #epatch "${FILESDIR}"/${PN}-1.2.5-darwin8.patch
+
+ # Don't force -O2
+ sed -i 's/-O2//g' "${S}"/configure.ac
+
+ # Don't build tests if not needed, part of bug #343249
+ # XXX: Fails to apply
+ #epatch "${FILESDIR}/${PN}-1.2.5-tests-build.patch"
+
+ # Prevent maintainer mode from being triggered during make
+ AT_M4DIR=Source/autotools eautoreconf
+}
+
+src_configure() {
+ # It doesn't compile on alpha without this in LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # Sigbuses on SPARC with mcpu and co.
+ use sparc && filter-flags "-mcpu=*" "-mvis" "-mtune=*"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ local myconf
+
+ # XXX: Check Web Audio support
+ # XXX: webgl fails compilation
+ # XXX: WebKit2 is the new out-of-process model, doesn't work yet
+ myconf="
+ $(use_enable coverage)
+ $(use_enable debug)
+ $(use_enable spell spellcheck)
+ $(use_enable introspection)
+ $(use_enable gstreamer video)
+ $(use_enable jit)
+ --disable-webgl
+ --with-gtk=3.0
+ --disable-webkit2
+ --disable-web-sockets
+ $(use aqua && echo "--with-font-backend=pango --with-target=quartz")"
+ # Aqua support in gtk3 is untested
+ # Disable web-sockets per bug #326547
+
+ econf ${myconf}
+}
+
+src_compile() {
+ # Fix sandbox error with USE="introspection"
+ # https://bugs.webkit.org/show_bug.cgi?id=35471
+ emake XDG_DATA_HOME="${T}/.local"
+}
+
+src_test() {
+ unset DISPLAY
+ # Tests need virtualx, bug #294691, bug #310695
+ # Set XDG_DATA_HOME for introspection tools, bug #323669
+ Xemake check XDG_DATA_HOME="${T}/.local"
+}
+
+src_install() {
+ default
+
+ # Remove .la files
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}