summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-11-23 00:27:30 +0000
committerJeroen Roovers <jer@gentoo.org>2009-11-23 00:27:30 +0000
commit729723962ac66986ebfdaed97828f658b59bbcd0 (patch)
tree3fa8eacdec4bbdc3964f2c913544f4aeed1e8af4 /net-libs
parentVersion bump. Require wxpython:2.8. Keyword ~amd64. (diff)
downloadgentoo-2-729723962ac66986ebfdaed97828f658b59bbcd0.tar.gz
gentoo-2-729723962ac66986ebfdaed97828f658b59bbcd0.tar.bz2
gentoo-2-729723962ac66986ebfdaed97828f658b59bbcd0.zip
Version bump.
(Portage version: 2.2_rc51/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh2/ChangeLog7
-rw-r--r--net-libs/libssh2/libssh2-1.2.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index 906f8b261af1..3081981e18b5 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libssh2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.22 2009/10/06 20:32:13 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.23 2009/11/23 00:27:30 jer Exp $
+
+*libssh2-1.2.2 (23 Nov 2009)
+
+ 23 Nov 2009; Jeroen Roovers <jer@gentoo.org> +libssh2-1.2.2.ebuild:
+ Version bump.
*libssh2-1.2.1 (06 Oct 2009)
diff --git a/net-libs/libssh2/libssh2-1.2.2.ebuild b/net-libs/libssh2/libssh2-1.2.2.ebuild
new file mode 100644
index 000000000000..8dd4728f53ad
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.2.2.ebuild,v 1.1 2009/11/23 00:27:30 jer Exp $
+
+EAPI="2"
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="http://www.${PN}.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gcrypt zlib"
+
+DEPEND="!gcrypt? ( dev-libs/openssl )
+ gcrypt? ( dev-libs/libgcrypt )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf
+
+ if use gcrypt ; then
+ myconf="--with-libgcrypt"
+ else
+ myconf="--with-openssl"
+ fi
+
+ econf \
+ $(use_with zlib libz) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}