summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-05 15:02:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-05 15:02:45 +0000
commit6ba44198878b769ca9a83d7edc5f25c00d05484f (patch)
tree380718fa45ee59bb0d850490ecf73ab158246cb2 /net-libs
parentDropping sparc keywords, see #96229 (diff)
downloadgentoo-2-6ba44198878b769ca9a83d7edc5f25c00d05484f.tar.gz
gentoo-2-6ba44198878b769ca9a83d7edc5f25c00d05484f.tar.bz2
gentoo-2-6ba44198878b769ca9a83d7edc5f25c00d05484f.zip
Version bump, remove old broken release.
(Portage version: 2.1.2_pre2-r3)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/ChangeLog8
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.10.33
-rw-r--r--net-libs/libtorrent/libtorrent-0.10.3.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 6ee29d2cd562..40a401f3eb80 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.69 2006/09/24 09:11:35 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.70 2006/10/05 15:02:45 flameeyes Exp $
+
+*libtorrent-0.10.3 (05 Oct 2006)
+
+ 05 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -libtorrent-0.10.2.ebuild, +libtorrent-0.10.3.ebuild:
+ Version bump, remove old broken release.
24 Sep 2006; Michael Hanselmann <hansmi@gentoo.org>
libtorrent-0.10.0.ebuild:
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.10.3 b/net-libs/libtorrent/files/digest-libtorrent-0.10.3
new file mode 100644
index 000000000000..e1e2c5a6c663
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.10.3
@@ -0,0 +1,3 @@
+MD5 8697a637db74f42fa23acbee03fa1734 libtorrent-0.10.3.tar.gz 449091
+RMD160 daa0f367f24bf15886c14968045b2d771fb06483 libtorrent-0.10.3.tar.gz 449091
+SHA256 3f850d167d91895462b801069e562ddfc9c886299216b6fde9596795418d975a libtorrent-0.10.3.tar.gz 449091
diff --git a/net-libs/libtorrent/libtorrent-0.10.3.ebuild b/net-libs/libtorrent/libtorrent-0.10.3.ebuild
new file mode 100644
index 000000000000..a7eff76f65e0
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.10.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.10.3.ebuild,v 1.1 2006/10/05 15:02:45 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ replace-flags -Os -O2
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}