summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-11-26 02:40:55 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-11-26 02:40:55 +0000
commit68abf108367b9b50f4df19144af4dfe78909bbee (patch)
tree8df09b9b776b8b3ad4c1db98421268a9818371fc /net-libs
parentAdd an USE flag for samba to bring in the dep for check_smb_share.pl. (diff)
downloadgentoo-2-68abf108367b9b50f4df19144af4dfe78909bbee.tar.gz
gentoo-2-68abf108367b9b50f4df19144af4dfe78909bbee.tar.bz2
gentoo-2-68abf108367b9b50f4df19144af4dfe78909bbee.zip
Fix build failure with USE=mono and >=cmake-2.8.10 (bug #444204, thanks to onip and Chris Reffett).
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libproxy/ChangeLog7
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.10-cmake-2.8.10.patch31
-rw-r--r--net-libs/libproxy/libproxy-0.4.10-r1.ebuild5
3 files changed, 41 insertions, 2 deletions
diff --git a/net-libs/libproxy/ChangeLog b/net-libs/libproxy/ChangeLog
index 342889d3e661..229cbf6d0bae 100644
--- a/net-libs/libproxy/ChangeLog
+++ b/net-libs/libproxy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libproxy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.96 2012/11/25 19:01:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.97 2012/11/26 02:40:55 tetromino Exp $
+
+ 26 Nov 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ libproxy-0.4.10-r1.ebuild, +files/libproxy-0.4.10-cmake-2.8.10.patch:
+ Fix build failure with USE=mono and >=cmake-2.8.10 (bug #444204, thanks to
+ onip and Chris Reffett).
25 Nov 2012; Raúl Porcel <armin76@gentoo.org> libproxy-0.4.10-r1.ebuild:
ia64/sh/sparc stable wrt #442152
diff --git a/net-libs/libproxy/files/libproxy-0.4.10-cmake-2.8.10.patch b/net-libs/libproxy/files/libproxy-0.4.10-cmake-2.8.10.patch
new file mode 100644
index 000000000000..80c99ac5ae1b
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.4.10-cmake-2.8.10.patch
@@ -0,0 +1,31 @@
+From d979e2e99c4a216a473e39078efc8709f8cabfee Mon Sep 17 00:00:00 2001
+From: "dominique.leuenberger@gmail.com"
+ <dominique.leuenberger@gmail.com@c587cffe-e639-0410-9787-d7902ae8ed56>
+Date: Mon, 12 Nov 2012 20:36:59 +0000
+Subject: [PATCH] cmake 2.8.10 has slight changes to the internal API
+
+git-svn-id: http://libproxy.googlecode.com/svn/trunk@866 c587cffe-e639-0410-9787-d7902ae8ed56
+---
+ cmake/CMakeDetermineCSharpCompiler.cmake | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/cmake/CMakeDetermineCSharpCompiler.cmake b/cmake/CMakeDetermineCSharpCompiler.cmake
+index 91c1e9f..86532eb 100644
+--- a/cmake/CMakeDetermineCSharpCompiler.cmake
++++ b/cmake/CMakeDetermineCSharpCompiler.cmake
+@@ -92,7 +92,11 @@ if (CMAKE_CSharp_COMPILER)
+ endif (CMAKE_CSharp_COMPILER)
+
+ # configure variables set in this file for fast reload later on
++if(NOT CMAKE_PLATFORM_INFO_DIR) # pre-2.8.10
++ set(CMAKE_PLATFORM_INFO_DIR ${CMAKE_BINARY_DIR}${CMAKE_FILES_DIRECTORY})
++endif()
++
+ configure_file(${CMAKE_SOURCE_DIR}/cmake/CMakeCSharpCompiler.cmake.in
+- ${CMAKE_BINARY_DIR}${CMAKE_FILES_DIRECTORY}/CMakeCSharpCompiler.cmake IMMEDIATE @ONLY)
++ ${CMAKE_PLATFORM_INFO_DIR}/CMakeCSharpCompiler.cmake IMMEDIATE @ONLY)
+ set(CMAKE_CSharp_COMPILER_ENV_VAR "CSC")
+
+--
+1.8.0
+
diff --git a/net-libs/libproxy/libproxy-0.4.10-r1.ebuild b/net-libs/libproxy/libproxy-0.4.10-r1.ebuild
index 1b5c50697aec..a0d01fa5bc42 100644
--- a/net-libs/libproxy/libproxy-0.4.10-r1.ebuild
+++ b/net-libs/libproxy/libproxy-0.4.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.10-r1.ebuild,v 1.10 2012/11/25 19:01:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.10-r1.ebuild,v 1.11 2012/11/26 02:40:55 tetromino Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.6"
@@ -45,6 +45,9 @@ src_prepare() {
# get-pac-test freezes when run by the ebuild, succeeds when building
# manually; virtualx.eclass doesn't help :(
epatch "${FILESDIR}/${PN}-0.4.10-disable-pac-test.patch"
+
+ # Fix building with cmake-2.8.10 and USE=mono; in next release; bug #444204
+ epatch "${FILESDIR}/${P}-cmake-2.8.10.patch"
}
src_configure() {