summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-09 13:51:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-09 13:51:23 +0000
commit657822555c82dd85562739abc83ed2d0349019f6 (patch)
treec545bf6967b59ec6955420148a27036c127db86f /net-libs
parentIntroduce multibuild_copy_sources as a generic source duplicating function. (diff)
downloadgentoo-2-657822555c82dd85562739abc83ed2d0349019f6.tar.gz
gentoo-2-657822555c82dd85562739abc83ed2d0349019f6.tar.bz2
gentoo-2-657822555c82dd85562739abc83ed2d0349019f6.zip
Version bump (using autotools-utils); remove old.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/liboauth/ChangeLog8
-rw-r--r--net-libs/liboauth/liboauth-1.0.1.ebuild (renamed from net-libs/liboauth/liboauth-0.9.6.ebuild)47
2 files changed, 24 insertions, 31 deletions
diff --git a/net-libs/liboauth/ChangeLog b/net-libs/liboauth/ChangeLog
index 3b1642a3fa83..8cf7f535f3fd 100644
--- a/net-libs/liboauth/ChangeLog
+++ b/net-libs/liboauth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/liboauth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/ChangeLog,v 1.22 2013/02/02 23:04:38 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/ChangeLog,v 1.23 2013/03/09 13:51:23 flameeyes Exp $
+
+*liboauth-1.0.1 (09 Mar 2013)
+
+ 09 Mar 2013; Diego E. Pettenò <flameeyes@gentoo.org> +liboauth-1.0.1.ebuild,
+ -liboauth-0.9.6.ebuild:
+ Version bump (using autotools-utils); remove old.
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> liboauth-0.9.7.ebuild:
Add ~arm, wrt bug #449220
diff --git a/net-libs/liboauth/liboauth-0.9.6.ebuild b/net-libs/liboauth/liboauth-1.0.1.ebuild
index 09f39f615a9c..621f637aef9b 100644
--- a/net-libs/liboauth/liboauth-0.9.6.ebuild
+++ b/net-libs/liboauth/liboauth-1.0.1.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/liboauth-0.9.6.ebuild,v 1.4 2013/02/01 12:08:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/liboauth-1.0.1.ebuild,v 1.1 2013/03/09 13:51:23 flameeyes Exp $
-EAPI=4
+EAPI=5
+
+inherit autotools-utils
DESCRIPTION="C library implementing the OAuth secure authentication protocol"
HOMEPAGE="http://liboauth.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- http://liboauth.sourceforge.net/pool/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/project/${PN}/${P}.tar.gz"
LICENSE="|| ( GPL-2 MIT )"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
IUSE="curl doc bindist +nss"
REQUIRED_USE="bindist? ( nss )"
@@ -39,25 +40,18 @@ DEPEND="${CDEPEND}
virtual/pkgconfig"
src_configure() {
- local myconf=
-
- if use nss || use bindist; then
- myconf="${myconf} --enable-nss"
- else
- myconf="${myconf} --disable-nss"
- fi
+ local myeconfargs=(
+ --disable-static
+ $(use_enable !curl curl)
+ $(use_enable curl libcurl)
+ $(use_enable nss)
+ )
- econf \
- --disable-dependency-tracking \
- --enable-fast-install \
- --disable-static \
- $(use_enable !curl curl) \
- $(use_enable curl libcurl) \
- ${myconf}
+ autotools-utils_src_configure
}
src_compile() {
- emake
+ autotools-utils_src_compile
if use doc ; then
# make sure fonts are found
@@ -66,17 +60,10 @@ src_compile() {
fi
}
-src_test() {
- # explicitly allow parallel test build
- emake check
-}
-
-DOCS=( AUTHORS ChangeLog LICENSE.OpenSSL NEWS README )
+DOCS=( AUTHORS ChangeLog LICENSE.OpenSSL README )
src_install() {
- default
+ use doc && HTML_DOCS=("${BUILD_DIR}"/doc/html)
- if use doc; then
- dohtml -r doc/html/*
- fi
+ autotools-utils_src_install
}