summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-08-27 14:25:23 +0000
committerThomas Sachau <tommy@gentoo.org>2010-08-27 14:25:23 +0000
commit644a904c9ab385da2bd92ad76b6abe87d05c0857 (patch)
tree9293d31c80cd2259bbcf8bc79b3b2dd8657ea5f1 /net-libs
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-644a904c9ab385da2bd92ad76b6abe87d05c0857.tar.gz
gentoo-2-644a904c9ab385da2bd92ad76b6abe87d05c0857.tar.bz2
gentoo-2-644a904c9ab385da2bd92ad76b6abe87d05c0857.zip
Version bump, fixes bug 334803
(Portage version: 2.2_rc69-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/polarssl/ChangeLog9
-rw-r--r--net-libs/polarssl/files/polarssl-0.14.0-ldflags.patch41
-rw-r--r--net-libs/polarssl/files/polarssl-0.14.0-makefile.patch13
-rw-r--r--net-libs/polarssl/polarssl-0.14.0.ebuild66
4 files changed, 128 insertions, 1 deletions
diff --git a/net-libs/polarssl/ChangeLog b/net-libs/polarssl/ChangeLog
index 45e2ae181aab..d3d1b24d556f 100644
--- a/net-libs/polarssl/ChangeLog
+++ b/net-libs/polarssl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/polarssl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.5 2010/07/11 15:13:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.6 2010/08/27 14:25:23 tommy Exp $
+
+*polarssl-0.14.0 (27 Aug 2010)
+
+ 27 Aug 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +polarssl-0.14.0.ebuild, +files/polarssl-0.14.0-ldflags.patch,
+ +files/polarssl-0.14.0-makefile.patch:
+ Version bump, fixes bug 334803
11 Jul 2010; Jeroen Roovers <jer@gentoo.org> polarssl-0.12.0.ebuild:
Marked ~hppa (bug #324941).
diff --git a/net-libs/polarssl/files/polarssl-0.14.0-ldflags.patch b/net-libs/polarssl/files/polarssl-0.14.0-ldflags.patch
new file mode 100644
index 000000000000..a33b3789da5c
--- /dev/null
+++ b/net-libs/polarssl/files/polarssl-0.14.0-ldflags.patch
@@ -0,0 +1,41 @@
+--- library/Makefile 2010-08-27 15:29:51.879773287 +0200
++++ library/Makefile.new 2010-08-27 15:33:53.960648715 +0200
+@@ -43,7 +43,7 @@
+
+ libpolarssl.so: libpolarssl.a
+ echo " LD $@"
+- $(CC) -shared -Wl,-soname,$@ -o $@ $(OBJS)
++ $(CC) ${LDFLAGS} -shared -Wl,-soname,$@ -o $@ $(OBJS)
+
+ libpolarssl.dylib: libpolarssl.a
+ echo " LD $@"
+--- tests/Makefile 2010-06-19 00:47:29.000000000 +0200
++++ tests/Makefile.new 2010-08-27 16:09:58.269773581 +0200
+@@ -2,11 +2,11 @@
+ # To compile on SunOS: add "-lsocket -lnsl" to LDFLAGS
+ # To compile on MinGW: add "-lws2_32" to LDFLAGS
+
+-CFLAGS = -I../include -D_FILE_OFFSET_BITS=64 -Wall -Wdeclaration-after-statement \
++CFLAGS += -I../include -D_FILE_OFFSET_BITS=64 -Wall -Wdeclaration-after-statement \
+ -Wno-unused-function -Wno-unused-value
+
+ OFLAGS = -O
+-LDFLAGS = -L../library -lpolarssl
++LDFLAGS += -L../library -lpolarssl
+
+ APPS = test_suite_aes test_suite_arc4 \
+ test_suite_base64 test_suite_camellia \
+--- programs/Makefile 2010-03-18 21:11:58.000000000 +0100
++++ programs/Makefile.new 2010-08-27 16:09:44.717773482 +0200
+@@ -2,9 +2,8 @@
+ # To compile on SunOS: add "-lsocket -lnsl" to LDFLAGS
+ # To compile on MinGW: add "-lws2_32" to LDFLAGS
+
+-CFLAGS = -I../include -D_FILE_OFFSET_BITS=64 -Wall -Wdeclaration-after-statement
+-OFLAGS = -O
+-LDFLAGS = -L../library -lpolarssl
++CFLAGS += -I../include -D_FILE_OFFSET_BITS=64 -Wall -Wdeclaration-after-statement
++LDFLAGS += -L../library -lpolarssl
+
+ APPS = aes/aescrypt2 hash/hello \
+ hash/md5sum hash/sha1sum \
diff --git a/net-libs/polarssl/files/polarssl-0.14.0-makefile.patch b/net-libs/polarssl/files/polarssl-0.14.0-makefile.patch
new file mode 100644
index 000000000000..807a27d3535e
--- /dev/null
+++ b/net-libs/polarssl/files/polarssl-0.14.0-makefile.patch
@@ -0,0 +1,13 @@
+diff -Naur polarssl-0.12.0.old/library/Makefile polarssl-0.12.0/library/Makefile
+--- polarssl-0.12.0.old/library/Makefile 2009-03-28 18:53:03.000000000 +0100
++++ polarssl-0.12.0/library/Makefile 2010-01-23 10:12:03.000000000 +0100
+@@ -1,8 +1,7 @@
+
+ # Also see "include/polarssl/config.h"
+
+-CFLAGS = -I../include -D_FILE_OFFSET_BITS=64 -Wall -Wdeclaration-after-statement
+-OFLAGS = -O
++CFLAGS += -I../include -D_FILE_OFFSET_BITS=64 -Wall -Wdeclaration-after-statement
+
+ # MicroBlaze specific options:
+ # CFLAGS += -mno-xl-soft-mul -mxl-barrel-shift
diff --git a/net-libs/polarssl/polarssl-0.14.0.ebuild b/net-libs/polarssl/polarssl-0.14.0.ebuild
new file mode 100644
index 000000000000..22edb000997d
--- /dev/null
+++ b/net-libs/polarssl/polarssl-0.14.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-0.14.0.ebuild,v 1.1 2010/08/27 14:25:23 tommy Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Cryptographic library for embedded systems"
+HOMEPAGE="http://polarssl.org/"
+SRC_URI="http://polarssl.org/code/download/${P}-gpl.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="examples sse2"
+
+src_prepare() {
+ cd library
+ if use sse2 ; then
+ sed -i '15iCFLAGS += -DHAVE_SSE2 -fPIC' Makefile
+ else
+ sed -i '15iCFLAGS += -fPIC' Makefile
+ fi
+ sed -i "s:-shared:-shared ${LDFLAGS}:g" library/Makefile
+ epatch "${FILESDIR}"/${P}-{makefile,ldflags}.patch
+}
+
+src_compile() {
+ cd library
+ emake libpolarssl.so || die "emake failed"
+
+ if use examples ; then
+ cd programs
+ emake all || die "emake failed"
+ fi
+}
+
+src_test() {
+ cd "${S}"/programs
+ emake test/selftest || die "emake selftest failed"
+ LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../library" ./test/selftest || die "selftest failed"
+ cd "${S}"
+ emake check || die
+}
+
+src_install() {
+ insinto /usr/include/polarssl
+ doins include/polarssl/*.h || die
+ dolib.so library/libpolarssl.so || die
+ dolib.a library/libpolarssl.a || die
+
+ if use examples ; then
+ for p in programs/*/* ; do
+ if [[ -x "${p}" && ! -d "${p}" ]] ; then
+ f=polarssl_`basename "${p}"`
+ newbin "${p}" "${f}" || die
+ fi
+ done
+ for e in aes hash pkey ssl test ; do
+ docinto "${e}"
+ dodoc programs/"${e}"/*.c || die
+ dodoc programs/"${e}"/*.txt || die
+ done
+ fi
+}