summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-06-28 08:25:59 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-06-28 08:25:59 +0000
commit61765a998e026af453c4169be189634786a5547c (patch)
treecb9efe5a7dafa86134d9404ec6186b7bd410dbea /net-libs
parent removed emake for make, might help on some obscure problems (diff)
downloadgentoo-2-61765a998e026af453c4169be189634786a5547c.tar.gz
gentoo-2-61765a998e026af453c4169be189634786a5547c.tar.bz2
gentoo-2-61765a998e026af453c4169be189634786a5547c.zip
libtoolizning both of theese
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/linc/ChangeLog5
-rw-r--r--net-libs/linc/files/digest-linc-0.5.0-r21
-rw-r--r--net-libs/linc/linc-0.5.0-r2.ebuild54
3 files changed, 59 insertions, 1 deletions
diff --git a/net-libs/linc/ChangeLog b/net-libs/linc/ChangeLog
index 58c8d4b99f6c..064253e79dac 100644
--- a/net-libs/linc/ChangeLog
+++ b/net-libs/linc/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for net-libs/linc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.4 2002/06/26 23:08:15 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.5 2002/06/28 08:25:59 spider Exp $
+linc-0.5.0-r2 (27 Jun 2002)
+ 28 Jun 2002; Spider <spider@gentoo.org> linc-0.5.0-r2.ebuild :
+ libtoolizing this and ORBit2 at the same time works. doing that now.
linc-0.5.0-r1 (27 Jun 2002)
27 Jun 2002; Spider <spider@gentoo.org> linc-0.5.0-r1.ebuild :
diff --git a/net-libs/linc/files/digest-linc-0.5.0-r2 b/net-libs/linc/files/digest-linc-0.5.0-r2
new file mode 100644
index 000000000000..596aace964e4
--- /dev/null
+++ b/net-libs/linc/files/digest-linc-0.5.0-r2
@@ -0,0 +1 @@
+MD5 2793b19b769be65ed3cb7df786b8032e linc-0.5.0.tar.bz2 177900
diff --git a/net-libs/linc/linc-0.5.0-r2.ebuild b/net-libs/linc/linc-0.5.0-r2.ebuild
new file mode 100644
index 000000000000..15767d314b79
--- /dev/null
+++ b/net-libs/linc/linc-0.5.0-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/linc-0.5.0-r2.ebuild,v 1.1 2002/06/28 08:25:59 spider Exp $
+inherit debug
+inherit libtool
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A library to ease the writing of networked applications"
+SRC_URI="mirror://gnome/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-libs/glib-2.0.0
+ >=dev-libs/openssl-0.9.6"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+
+ # if this is disabled (use) ORBit2 will fail to build. Just force it on
+ myconf="${myconf} --with-openssl"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} \
+ --enable-debug=yes || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING HACKING MAINTAINERS README* INSTALL NEWS TODO
+}
+
+
+
+
+