summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-21 03:44:48 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-21 03:44:48 +0000
commit616725ccdbd6032770a74a518856dabe3d54ab0c (patch)
treef6513cd561a531c47ee971b4f1c00dadd1cad5cd /net-libs
parentrequire a newer perl-Module-Build as mentioned in bug #424535 (diff)
downloadgentoo-2-616725ccdbd6032770a74a518856dabe3d54ab0c.tar.gz
gentoo-2-616725ccdbd6032770a74a518856dabe3d54ab0c.tar.bz2
gentoo-2-616725ccdbd6032770a74a518856dabe3d54ab0c.zip
Add the automoc dependency to 0.4.10, make it conditional on USE=kde, remove 0.4.10-r1 ebuild since it differs from 0.4.10 only in the dependency list.
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libproxy/ChangeLog7
-rw-r--r--net-libs/libproxy/libproxy-0.4.10-r1.ebuild78
-rw-r--r--net-libs/libproxy/libproxy-0.4.10.ebuild3
3 files changed, 8 insertions, 80 deletions
diff --git a/net-libs/libproxy/ChangeLog b/net-libs/libproxy/ChangeLog
index cb28510774a5..7f7fee194440 100644
--- a/net-libs/libproxy/ChangeLog
+++ b/net-libs/libproxy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libproxy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.87 2012/10/21 02:55:12 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.88 2012/10/21 03:44:48 tetromino Exp $
+
+ 21 Oct 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ libproxy-0.4.10.ebuild, -libproxy-0.4.10-r1.ebuild:
+ Add the automoc dependency to 0.4.10, make it conditional on USE=kde, remove
+ 0.4.10-r1 ebuild since it differs from 0.4.10 only in the dependency list.
*libproxy-0.4.10-r1 (21 Oct 2012)
diff --git a/net-libs/libproxy/libproxy-0.4.10-r1.ebuild b/net-libs/libproxy/libproxy-0.4.10-r1.ebuild
deleted file mode 100644
index 1960d03b9ce8..000000000000
--- a/net-libs/libproxy/libproxy-0.4.10-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.10-r1.ebuild,v 1.1 2012/10/21 02:55:12 creffett Exp $
-
-EAPI=4
-PYTHON_DEPEND="python? 2:2.6"
-
-inherit cmake-utils eutils mono python
-
-DESCRIPTION="Library for automatic proxy configuration management"
-HOMEPAGE="http://code.google.com/p/libproxy/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-linux"
-IUSE="gnome kde mono networkmanager perl python spidermonkey test webkit"
-
-# NOTE: mozjs/spidermonkey might still cause problems like #373397 ?
-# NOTE: webkit-gtk:3, not :2, needed for libjavascriptcoregtk support
-RDEPEND="gnome? ( >=dev-libs/glib-2.26:2 )
- kde? ( >=kde-base/kdelibs-4.4.5 )
- mono? ( dev-lang/mono )
- networkmanager? ( net-misc/networkmanager )
- perl? ( dev-lang/perl )
- spidermonkey? ( >=dev-lang/spidermonkey-1.8.5 )
- webkit? ( >=net-libs/webkit-gtk-1.6:3 )"
-DEPEND="${RDEPEND}
- dev-util/automoc
- virtual/pkgconfig"
-
-pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README"
-
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- # Gentoo's spidermonkey doesn't set Version: in mozjs185.pc
- epatch "${FILESDIR}/${PN}-0.4.10-mozjs185.pc.patch"
-
- # get-pac-test freezes when run by the ebuild, succeeds when building
- # manually; virtualx.eclass doesn't help :(
- epatch "${FILESDIR}/${PN}-0.4.10-disable-pac-test.patch"
-}
-
-src_configure() {
- # WITH_VALA just copies the .vapi file over and needs no deps,
- # hence always enable it unconditionally
- local mycmakeargs=(
- -DPERL_VENDORINSTALL=ON
- -DCMAKE_C_FLAGS="${CFLAGS}"
- -DCMAKE_CXX_FLAGS="${CXXFLAGS}"
- $(cmake-utils_use_with gnome GNOME3)
- $(cmake-utils_use_with kde KDE4)
- $(cmake-utils_use_with mono DOTNET)
- $(cmake-utils_use_with networkmanager NM)
- $(cmake-utils_use_with perl PERL)
- $(cmake-utils_use_with python PYTHON)
- $(cmake-utils_use_with spidermonkey MOZJS)
- $(cmake-utils_use_with webkit WEBKIT)
- $(cmake-utils_use_with webkit WEBKIT3)
- -DWITH_VALA=ON
- $(cmake-utils_use test BUILD_TESTING)
- )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- use python && python_mod_optimize ${PN}.py
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup ${PN}.py
-}
diff --git a/net-libs/libproxy/libproxy-0.4.10.ebuild b/net-libs/libproxy/libproxy-0.4.10.ebuild
index 75a1bb7a7afb..cd50ab8624c7 100644
--- a/net-libs/libproxy/libproxy-0.4.10.ebuild
+++ b/net-libs/libproxy/libproxy-0.4.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.10.ebuild,v 1.7 2012/10/19 06:35:28 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.10.ebuild,v 1.8 2012/10/21 03:44:48 tetromino Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.6"
@@ -26,6 +26,7 @@ RDEPEND="gnome? ( >=dev-libs/glib-2.26:2 )
spidermonkey? ( >=dev-lang/spidermonkey-1.8.5 )
webkit? ( >=net-libs/webkit-gtk-1.6:3 )"
DEPEND="${RDEPEND}
+ kde? ( dev-util/automoc )
virtual/pkgconfig"
pkg_setup() {