summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-09-12 17:47:15 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-09-12 17:47:15 +0000
commit560b99f7440efad4012f66322f8a615acab79053 (patch)
treeadb7d97a9779a4d0487fb9e0898c5f5ac7c7611e /net-libs
parentRemove monolithic X deps (diff)
downloadgentoo-2-560b99f7440efad4012f66322f8a615acab79053.tar.gz
gentoo-2-560b99f7440efad4012f66322f8a615acab79053.tar.bz2
gentoo-2-560b99f7440efad4012f66322f8a615acab79053.zip
version bump
(Portage version: 2.1.1)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/opal/ChangeLog7
-rw-r--r--net-libs/opal/files/digest-opal-2.2.33
-rw-r--r--net-libs/opal/opal-2.2.3.ebuild104
3 files changed, 113 insertions, 1 deletions
diff --git a/net-libs/opal/ChangeLog b/net-libs/opal/ChangeLog
index 9f201ced4a03..c1c83dae2f35 100644
--- a/net-libs/opal/ChangeLog
+++ b/net-libs/opal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/opal
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.8 2006/08/17 19:58:00 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.9 2006/09/12 17:47:15 genstef Exp $
+
+*opal-2.2.3 (12 Sep 2006)
+
+ 12 Sep 2006; Stefan Schweizer <genstef@gentoo.org> +opal-2.2.3.ebuild:
+ version bump
17 Aug 2006; Markus Rothe <corsair@gentoo.org> opal-2.2.2.ebuild:
Stable on ppc64
diff --git a/net-libs/opal/files/digest-opal-2.2.3 b/net-libs/opal/files/digest-opal-2.2.3
new file mode 100644
index 000000000000..b74d9131c6e1
--- /dev/null
+++ b/net-libs/opal/files/digest-opal-2.2.3
@@ -0,0 +1,3 @@
+MD5 fc1fedd3406e2e74472cc4312cbbfd6a opal-2.2.3.tar.gz 4114610
+RMD160 98696a5ee5492dc2a9fda6115b85496c51b69157 opal-2.2.3.tar.gz 4114610
+SHA256 366859a10c9a15c044fb2697c96c929c7f8f310ad3841f2f87f2757782039e07 opal-2.2.3.tar.gz 4114610
diff --git a/net-libs/opal/opal-2.2.3.ebuild b/net-libs/opal/opal-2.2.3.ebuild
new file mode 100644
index 000000000000..7b4df6491d95
--- /dev/null
+++ b/net-libs/opal/opal-2.2.3.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-2.2.3.ebuild,v 1.1 2006/09/12 17:47:15 genstef Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="OPAL library, used by Ekiga"
+HOMEPAGE="http://www.ekiga.org"
+SRC_URI="http://seconix.com/misc/ekiga-2.0.3/${P}.tar.gz"
+
+IUSE="novideo noaudio debug"
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/pwlib-1.10.2
+ >=media-video/ffmpeg-0.4.7"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Makefile is currently broken with NOTRACE=1, fix that
+ epatch ${FILESDIR}/${PN}-2.1.1-notrace.diff
+}
+
+src_compile() {
+ local makeopts
+ local myconf
+
+ # remove -fstack-protector, may cause problems (bug #75259)
+ filter-flags -fstack-protector
+
+ # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
+ # compile with PTRACING if the user wants to debug stuff
+ if ! use debug; then
+ makeopts="${makeopts} NOTRACE=1"
+ fi
+
+ # doesn't work with osptoolkit-3.3.1
+ # iax2 support is missing in the tarball, disable it too
+ myconf="--disable-transnexusosp --disable-iax --enable-localspeex"
+
+ use novideo \
+ && myconf="${myconf} --disable-video"
+
+ use noaudio \
+ && myconf="${myconf} --disable-audio"
+
+ econf \
+ PWLIBDIR=/usr/share/pwlib \
+ OPALDIR=${S} \
+ ${myconf} || die "configure failed"
+
+ emake ${makeopts} opt || die "make failed"
+}
+
+src_install() {
+ local OPAL_ARCH ALT_ARCH OPAL_SUFFIX
+ local makeopts libdir libname
+
+ # make NOTRACE=1 opt ==> linux_$ARCH_n
+ # make opt ==> linux_$ARCH_r
+ if ! use debug; then
+ OPAL_SUFFIX="n"
+ makeopts="NOTRACE=1"
+ else
+ OPAL_SUFFIX="r"
+ fi
+
+ # use ptlib-config to get the right values here (for hppa, amd64 ...)
+ OPAL_ARCH="$(ptlib-config --ostype)_$(ptlib-config --machtype)_${OPAL_SUFFIX}"
+
+ # set ALT_ARCH
+ if use debug; then
+ ALT_ARCH=${OPAL_ARCH/_r/_n}
+ else
+ ALT_ARCH=${OPAL_ARCH/_n/_r}
+ fi
+
+ ###
+ # Install stuff
+ #
+ make PREFIX=/usr DESTDIR=${D} \
+ ${makeopts} install || die "install failed"
+
+ libdir=$(get_libdir)
+ libname="libopal_${OPAL_ARCH}.so.${PV}"
+
+ # compat symlinks
+ for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
+ dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so.${pv}
+ done
+ dosym ${libname} /usr/${libdir}/libopal_${OPAL_ARCH}.so
+ dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so
+
+ ###
+ # Compatibility "hacks"
+ #
+
+ # install version.h into $OPALDIR
+ insinto /usr/share/opal
+ doins version.h
+}