summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-03-02 20:07:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-03-02 20:07:55 +0000
commit534743995095fec8caadba6995ef3fe2fb0492af (patch)
tree7fd28708d295ec593c80b933a9d451dd3535d7d6 /net-libs
parentprune some unused versions (diff)
downloadgentoo-2-534743995095fec8caadba6995ef3fe2fb0492af.tar.gz
gentoo-2-534743995095fec8caadba6995ef3fe2fb0492af.tar.bz2
gentoo-2-534743995095fec8caadba6995ef3fe2fb0492af.zip
Group and world writable directories cause GrSec to deny exection on the package for security. That is too much permission anyway, so clean up perms better.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/c-client/ChangeLog8
-rw-r--r--net-libs/c-client/c-client-2004g-r1.ebuild4
-rw-r--r--net-libs/c-client/c-client-2004g.ebuild4
-rw-r--r--net-libs/c-client/c-client-2006k.ebuild4
4 files changed, 13 insertions, 7 deletions
diff --git a/net-libs/c-client/ChangeLog b/net-libs/c-client/ChangeLog
index 4a96002dd15e..147113a1fd7e 100644
--- a/net-libs/c-client/ChangeLog
+++ b/net-libs/c-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/c-client
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.45 2008/02/22 07:20:51 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.46 2008/03/02 20:07:55 robbat2 Exp $
+
+ 02 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> c-client-2004g.ebuild,
+ c-client-2004g-r1.ebuild, c-client-2006k.ebuild:
+ Group and world writable directories cause GrSec to deny exection on the
+ package for security. That is too much permission anyway, so clean up perms
+ better.
22 Feb 2008; Gunnar Wrobel <wrobel@gentoo.org> ChangeLog, Manifest:
Clean up changelog.
diff --git a/net-libs/c-client/c-client-2004g-r1.ebuild b/net-libs/c-client/c-client-2004g-r1.ebuild
index 7e64995a1e98..ba0e3ded1f09 100644
--- a/net-libs/c-client/c-client-2004g-r1.ebuild
+++ b/net-libs/c-client/c-client-2004g-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2004g-r1.ebuild,v 1.1 2008/02/22 07:18:16 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2004g-r1.ebuild,v 1.2 2008/03/02 20:07:55 robbat2 Exp $
inherit flag-o-matic eutils libtool
@@ -27,7 +27,7 @@ src_unpack() {
unpack ${A}
# Tarball packed with bad file perms
- chmod -R ug+w "${S}"
+ chmod -R u+rwX,go-w "${S}"
# lots of things need -fPIC, including various platforms, and this library
# generally should be built with it anyway.
diff --git a/net-libs/c-client/c-client-2004g.ebuild b/net-libs/c-client/c-client-2004g.ebuild
index 34acb7d8143b..7120a99ddc43 100644
--- a/net-libs/c-client/c-client-2004g.ebuild
+++ b/net-libs/c-client/c-client-2004g.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2004g.ebuild,v 1.14 2008/02/22 07:18:16 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2004g.ebuild,v 1.15 2008/03/02 20:07:55 robbat2 Exp $
inherit flag-o-matic eutils libtool
@@ -27,7 +27,7 @@ src_unpack() {
unpack ${A}
# Tarball packed with bad file perms
- chmod -R ug+w "${S}"
+ chmod -R u+rwX,go-w "${S}"
# lots of things need -fPIC, including various platforms, and this library
# generally should be built with it anyway.
diff --git a/net-libs/c-client/c-client-2006k.ebuild b/net-libs/c-client/c-client-2006k.ebuild
index 115047726f58..f11b75676ea9 100644
--- a/net-libs/c-client/c-client-2006k.ebuild
+++ b/net-libs/c-client/c-client-2006k.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2006k.ebuild,v 1.1 2008/02/22 07:18:16 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2006k.ebuild,v 1.2 2008/03/02 20:07:55 robbat2 Exp $
inherit flag-o-matic eutils libtool
@@ -31,7 +31,7 @@ src_unpack() {
unpack ${A}
# Tarball packed with bad file perms
- chmod -R ug+w "${S}"
+ chmod -R u+rwX,go-w "${S}"
# lots of things need -fPIC, including various platforms, and this library
# generally should be built with it anyway.