summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-22 05:16:46 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-22 05:16:46 +0000
commit4efaf71495db8e12c3981eb00f4fbe9b57196275 (patch)
tree814ed8806775cd15b78e1580b1475edb20591411 /net-libs
parentVersion bump (diff)
downloadgentoo-2-4efaf71495db8e12c3981eb00f4fbe9b57196275.tar.gz
gentoo-2-4efaf71495db8e12c3981eb00f4fbe9b57196275.tar.bz2
gentoo-2-4efaf71495db8e12c3981eb00f4fbe9b57196275.zip
Fix build failure with USE=kerberos and gcc-4.5 (bug #450706, thanks to Clemente Aguiar). Require mit-krb5 when USE=kerberos; gnome-online-accounts is incompatible with heimdal. Update license, modernize ebuild.
(Portage version: 2.2.0_alpha158/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnome-online-accounts/ChangeLog9
-rw-r--r--net-libs/gnome-online-accounts/files/gnome-online-accounts-3.6.2-GoaKerberosIdentity.patch53
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.4.2.ebuild6
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.6.2.ebuild32
4 files changed, 84 insertions, 16 deletions
diff --git a/net-libs/gnome-online-accounts/ChangeLog b/net-libs/gnome-online-accounts/ChangeLog
index 3a1f5a4b2cfc..f01aa292e65e 100644
--- a/net-libs/gnome-online-accounts/ChangeLog
+++ b/net-libs/gnome-online-accounts/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/gnome-online-accounts
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/ChangeLog,v 1.9 2013/01/06 09:59:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/ChangeLog,v 1.10 2013/01/22 05:16:46 tetromino Exp $
+
+ 22 Jan 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gnome-online-accounts-3.4.2.ebuild, gnome-online-accounts-3.6.2.ebuild,
+ +files/gnome-online-accounts-3.6.2-GoaKerberosIdentity.patch:
+ Fix build failure with USE=kerberos and gcc-4.5 (bug #450706, thanks to
+ Clemente Aguiar). Require mit-krb5 when USE=kerberos; gnome-online-accounts
+ is incompatible with heimdal. Update license, modernize ebuild.
06 Jan 2013; Agostino Sarubbo <ago@gentoo.org>
gnome-online-accounts-3.6.2.ebuild:
diff --git a/net-libs/gnome-online-accounts/files/gnome-online-accounts-3.6.2-GoaKerberosIdentity.patch b/net-libs/gnome-online-accounts/files/gnome-online-accounts-3.6.2-GoaKerberosIdentity.patch
new file mode 100644
index 000000000000..976ae1bd8f10
--- /dev/null
+++ b/net-libs/gnome-online-accounts/files/gnome-online-accounts-3.6.2-GoaKerberosIdentity.patch
@@ -0,0 +1,53 @@
+From 367fae608624cefdf029cc01dd85f71ca5bf1881 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 22 Jan 2013 00:06:58 -0500
+Subject: [PATCH] identity: define GoaKerberosIdentity only in one header
+
+https://bugzilla.gnome.org/show_bug.cgi?id=692251
+---
+ src/goaidentity/goakerberosidentity.h | 2 +-
+ src/goaidentity/goakerberosidentityinquiry.h | 1 -
+ src/goaidentity/goakerberosidentitymanager.c | 2 +-
+ 3 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/src/goaidentity/goakerberosidentity.h b/src/goaidentity/goakerberosidentity.h
+index 73681b0..6e82835 100644
+--- a/src/goaidentity/goakerberosidentity.h
++++ b/src/goaidentity/goakerberosidentity.h
+@@ -27,7 +27,7 @@
+ #include <glib-object.h>
+
+ #include <krb5.h>
+-#include "goakerberosidentityinquiry.h"
++#include "goaidentityinquiry.h"
+
+ G_BEGIN_DECLS
+ #define GOA_TYPE_KERBEROS_IDENTITY (goa_kerberos_identity_get_type ())
+diff --git a/src/goaidentity/goakerberosidentityinquiry.h b/src/goaidentity/goakerberosidentityinquiry.h
+index d6c7d7c..3d5501c 100644
+--- a/src/goaidentity/goakerberosidentityinquiry.h
++++ b/src/goaidentity/goakerberosidentityinquiry.h
+@@ -38,7 +38,6 @@ G_BEGIN_DECLS
+ #define GOA_IS_KERBEROS_IDENTITY_INQUIRY(obj) (G_TYPE_CHECK_INSTANCE_TYPE ((obj), GOA_TYPE_KERBEROS_IDENTITY_INQUIRY))
+ #define GOA_IS_KERBEROS_IDENTITY_INQUIRY_CLASS(klass) (G_TYPE_CHECK_CLASS_TYPE ((klass), GOA_TYPE_KERBEROS_IDENTITY_INQUIRY))
+ #define GOA_KERBEROS_IDENTITY_INQUIRY_GET_CLASS(obj) (G_TYPE_INSTANCE_GET_CLASS((obj), GOA_TYPE_KERBEROS_IDENTITY_INQUIRY, GoaKerberosIdentityInquiryClass))
+-typedef struct _GoaKerberosIdentity GoaKerberosIdentity;
+ typedef struct _GoaKerberosIdentityInquiry GoaKerberosIdentityInquiry;
+ typedef struct _GoaKerberosIdentityInquiryClass GoaKerberosIdentityInquiryClass;
+ typedef struct _GoaKerberosIdentityInquiryPrivate GoaKerberosIdentityInquiryPrivate;
+diff --git a/src/goaidentity/goakerberosidentitymanager.c b/src/goaidentity/goakerberosidentitymanager.c
+index 62c4a2a..1b1dcd1 100644
+--- a/src/goaidentity/goakerberosidentitymanager.c
++++ b/src/goaidentity/goakerberosidentitymanager.c
+@@ -25,7 +25,7 @@
+ #include "goakerberosidentitymanager.h"
+ #include "goaidentitymanager.h"
+ #include "goaidentitymanagerprivate.h"
+-#include "goakerberosidentity.h"
++#include "goakerberosidentityinquiry.h"
+ #include "goalogging.h"
+
+ #include <fcntl.h>
+--
+1.8.1.1
+
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.2.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.2.ebuild
index ce70a44c3cd0..180ddb18a8d1 100644
--- a/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.2.ebuild
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.2.ebuild,v 1.3 2012/09/23 14:11:24 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.2.ebuild,v 1.4 2013/01/22 05:16:46 tetromino Exp $
EAPI="4"
GNOME2_LA_PUNT="yes"
@@ -10,7 +10,7 @@ inherit gnome2
DESCRIPTION="GNOME framework for accessing online accounts"
HOMEPAGE="http://www.gnome.org/"
-LICENSE="LGPL-2"
+LICENSE="LGPL-2+"
SLOT="0"
IUSE="doc gnome +introspection"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.6.2.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.6.2.ebuild
index e93586dbfb48..26268ec0bacd 100644
--- a/net-libs/gnome-online-accounts/gnome-online-accounts-3.6.2.ebuild
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.6.2.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.6.2.ebuild,v 1.4 2013/01/06 09:59:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.6.2.ebuild,v 1.5 2013/01/22 05:16:46 tetromino Exp $
EAPI="5"
GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="GNOME framework for accessing online accounts"
HOMEPAGE="https://live.gnome.org/GnomeOnlineAccounts"
-LICENSE="LGPL-2"
+LICENSE="LGPL-2+"
SLOT="0"
IUSE="gnome +introspection kerberos"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
# pango used in goaeditablelabel
# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
RDEPEND="
>=dev-libs/glib-2.32:2
app-crypt/libsecret
@@ -33,7 +35,7 @@ RDEPEND="
introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
kerberos? (
app-crypt/gcr
- virtual/krb5 )
+ app-crypt/mit-krb5 )
"
# goa-daemon can launch gnome-control-center
PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
@@ -46,14 +48,20 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+src_prepare() {
+ # fix build failure with gcc-4.5 and USE=kerberos, bug #450706
+ # https://bugzilla.gnome.org/show_bug.cgi?id=692251
+ epatch "${FILESDIR}/${PN}-3.6.2-GoaKerberosIdentity.patch"
+ gnome2_src_prepare
+}
+
src_configure() {
# TODO: Give users a way to set the G/Y!/FB/Twitter/Windows Live secrets
- G2CONF="${G2CONF}
- --disable-static
- --enable-documentation
- --enable-exchange
- --enable-facebook
- --enable-windows-live
- $(use_enable kerberos)"
- gnome2_src_configure
+ gnome2_src_configure \
+ --disable-static \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-windows-live \
+ $(use_enable kerberos)
}