summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-01-07 08:54:42 +0000
committerPeter Volkov <pva@gentoo.org>2011-01-07 08:54:42 +0000
commit492cf5bdc2dc84cef0730a788862fe9dedc7bcdd (patch)
tree0681b6abfada96ca2f49b401ed6d4852af9fc1b0 /net-libs
parentDrop maintainership (diff)
downloadgentoo-2-492cf5bdc2dc84cef0730a788862fe9dedc7bcdd.tar.gz
gentoo-2-492cf5bdc2dc84cef0730a788862fe9dedc7bcdd.tar.bz2
gentoo-2-492cf5bdc2dc84cef0730a788862fe9dedc7bcdd.zip
Version bump, thank Jeroen Roovers for report in bug #350555
(Portage version: 2.1.9.29/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libosip/ChangeLog9
-rw-r--r--net-libs/libosip/libosip-3.5.0.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/net-libs/libosip/ChangeLog b/net-libs/libosip/ChangeLog
index 6a0bc1fb4855..04c174e1eeca 100644
--- a/net-libs/libosip/ChangeLog
+++ b/net-libs/libosip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libosip
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosip/ChangeLog,v 1.44 2010/12/19 15:14:44 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosip/ChangeLog,v 1.45 2011/01/07 08:54:42 pva Exp $
+
+*libosip-3.5.0 (07 Jan 2011)
+
+ 07 Jan 2011; Peter Volkov <pva@gentoo.org> +libosip-3.5.0.ebuild:
+ Version bump, thank Jeroen Roovers for report in bug #350555
19 Dec 2010; Peter Volkov <pva@gentoo.org> +libosip-2.2.2.ebuild:
Restore libosip-2.2.2.ebuild as it's used by net-misc/partysip, thank
diff --git a/net-libs/libosip/libosip-3.5.0.ebuild b/net-libs/libosip/libosip-3.5.0.ebuild
new file mode 100644
index 000000000000..655b9f3ee0eb
--- /dev/null
+++ b/net-libs/libosip/libosip-3.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosip/libosip-3.5.0.ebuild,v 1.1 2011/01/07 08:54:42 pva Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+MY_PV=${PV%.?}-${PV##*.}
+MY_PV=${PV}
+MY_P=${PN}2-${MY_PV}
+DESCRIPTION="a simple way to support the Session Initiation Protocol"
+HOMEPAGE="http://www.gnu.org/software/osip/"
+SRC_URI="mirror://gnu/osip/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~ppc-macos ~x86-macos"
+IUSE="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.3.0-out-source-build.patch"
+ AT_M4DIR="scripts" eautoreconf
+}
+
+src_configure() {
+ econf --enable-mt \
+ $(use_enable test)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ dodoc AUTHORS ChangeLog FEATURES HISTORY README NEWS TODO || die
+}