summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-09-22 16:18:31 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-09-22 16:18:31 +0000
commit45071a7118eb3c3da3036517c40350bf26987275 (patch)
treeb96fc3cc48e9774d02f20f00a54373c31c0a4ad7 /net-libs
parentVersion bump to latest. drop older. (diff)
downloadgentoo-2-45071a7118eb3c3da3036517c40350bf26987275.tar.gz
gentoo-2-45071a7118eb3c3da3036517c40350bf26987275.tar.bz2
gentoo-2-45071a7118eb3c3da3036517c40350bf26987275.zip
Version bump, EAPI4, remove la file and don't build static libs. Drop old
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/net6/ChangeLog10
-rw-r--r--net-libs/net6/net6-1.3.12.ebuild28
-rw-r--r--net-libs/net6/net6-1.3.13.ebuild (renamed from net-libs/net6/net6-1.3.10.ebuild)18
3 files changed, 20 insertions, 36 deletions
diff --git a/net-libs/net6/ChangeLog b/net-libs/net6/ChangeLog
index 3d7edf20a192..89a4ca14fe7a 100644
--- a/net-libs/net6/ChangeLog
+++ b/net-libs/net6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/net6
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/net6/ChangeLog,v 1.38 2010/06/13 09:37:25 xarthisius Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/net6/ChangeLog,v 1.39 2011/09/22 16:18:31 xarthisius Exp $
+
+*net6-1.3.13 (22 Sep 2011)
+
+ 22 Sep 2011; Kacper Kowalik <xarthisius@gentoo.org> -net6-1.3.10.ebuild,
+ -net6-1.3.12.ebuild, +net6-1.3.13.ebuild:
+ Version bump, EAPI4, remove la file and don't build static libs. Drop old
*net6-1.3.12 (13 Jun 2010)
diff --git a/net-libs/net6/net6-1.3.12.ebuild b/net-libs/net6/net6-1.3.12.ebuild
deleted file mode 100644
index 8606d40847c0..000000000000
--- a/net-libs/net6/net6-1.3.12.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/net6/net6-1.3.12.ebuild,v 1.1 2010/06/13 09:37:25 xarthisius Exp $
-
-EAPI="2"
-
-DESCRIPTION="Network access framework for IPv4/IPv6 written in C++"
-HOMEPAGE="http://gobby.0x539.de/"
-SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~x86"
-IUSE="nls"
-
-RDEPEND="dev-libs/libsigc++:2
- >=net-libs/gnutls-1.2.10"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.20
- nls? ( sys-devel/gettext )"
-
-src_configure() {
- econf $(use_enable nls)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README || die
-}
diff --git a/net-libs/net6/net6-1.3.10.ebuild b/net-libs/net6/net6-1.3.13.ebuild
index ea61e87077d6..3fad1f43195b 100644
--- a/net-libs/net6/net6-1.3.10.ebuild
+++ b/net-libs/net6/net6-1.3.13.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/net6/net6-1.3.10.ebuild,v 1.1 2009/10/28 20:37:08 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/net6/net6-1.3.13.ebuild,v 1.1 2011/09/22 16:18:31 xarthisius Exp $
-EAPI="2"
+EAPI=4
+
+inherit multilib
DESCRIPTION="Network access framework for IPv4/IPv6 written in C++"
HOMEPAGE="http://gobby.0x539.de/"
SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
@@ -18,11 +21,14 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.20
nls? ( sys-devel/gettext )"
+DOCS=( AUTHORS ChangeLog NEWS README )
+
src_configure() {
- econf $(use_enable nls)
+ econf $(use_enable nls) \
+ --disable-static
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README
+ default
+ rm -f "${D}"/usr/$(get_libdir)/${PN}.la
}