summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-22 21:48:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-22 21:48:30 +0000
commit4302c535a58f1252c2df1a32a4fb616158eb7c74 (patch)
tree00ea7bb5714b674f0fdf50b3c50b2d90dac154bc /net-libs
parentFix documentation handling making it really conditional (bug #359927 by M.B). (diff)
downloadgentoo-2-4302c535a58f1252c2df1a32a4fb616158eb7c74.tar.gz
gentoo-2-4302c535a58f1252c2df1a32a4fb616158eb7c74.tar.bz2
gentoo-2-4302c535a58f1252c2df1a32a4fb616158eb7c74.zip
Fix compability with net-libs/xulrunner >= 2 wrt #359879 by Justin Lecher.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libproxy/ChangeLog6
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.6-xulrunner-2.patch133
-rw-r--r--net-libs/libproxy/libproxy-0.4.6-r1.ebuild7
3 files changed, 143 insertions, 3 deletions
diff --git a/net-libs/libproxy/ChangeLog b/net-libs/libproxy/ChangeLog
index 1dca361d12a9..ab2fc93fad0d 100644
--- a/net-libs/libproxy/ChangeLog
+++ b/net-libs/libproxy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libproxy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.55 2011/03/21 23:18:54 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.56 2011/03/22 21:48:30 ssuominen Exp $
+
+ 22 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> libproxy-0.4.6-r1.ebuild,
+ +files/libproxy-0.4.6-xulrunner-2.patch:
+ Fix compability with net-libs/xulrunner >= 2 wrt #359879 by Justin Lecher.
21 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> libproxy-0.4.6.ebuild:
Fix slot-deps on gnome libs
diff --git a/net-libs/libproxy/files/libproxy-0.4.6-xulrunner-2.patch b/net-libs/libproxy/files/libproxy-0.4.6-xulrunner-2.patch
new file mode 100644
index 000000000000..5f3de3ca5b10
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.4.6-xulrunner-2.patch
@@ -0,0 +1,133 @@
+http://bugs.gentoo.org/359879
+http://code.google.com/p/libproxy/issues/detail?id=158
+
+--- libproxy/cmake/modules/pacrunner_mozjs.cmk
++++ libproxy/cmake/modules/pacrunner_mozjs.cmk
+@@ -7,16 +7,23 @@
+ include_directories("${MOZJS_INCLUDE_DIR}")
+ endif()
+ elseif(NOT APPLE)
+- set(MOZJS_SEARCH_ORDER "xulrunner-js;firefox-js;mozilla-js;seamonkey-js" CACHE STRING "MozJS search order")
++ set(MOZJS_SEARCH_ORDER "mozilla-js;xulrunner-js;firefox-js;seamonkey-js" CACHE STRING "MozJS search order")
+ option(WITH_MOZJS "Search for MOZJS package" ON)
+ if (WITH_MOZJS)
+- pkg_search_module(MOZJS ${MOZJS_SEARCH_ORDER})
+- if(MOZJS_FOUND)
+- include_directories(${MOZJS_INCLUDE_DIRS})
+- link_directories(${MOZJS_LIBRARY_DIRS})
+- else()
+- set(MOZJS_FOUND 0)
+- endif()
++ foreach(MOZJSLIB ${MOZJS_SEARCH_ORDER})
++ pkg_search_module(MOZJS ${MOZJSLIB})
++ if(MOZJS_FOUND)
++ include_directories(${MOZJS_INCLUDE_DIRS})
++ link_directories(${MOZJS_LIBRARY_DIRS})
++ pkg_search_module(MOZJS2 ${MOZJSLIB}>=2.0b10)
++ if(MOZJS2_FOUND)
++ add_definitions(-DHAVE_MOZJS_2)
++ endif(MOZJS2_FOUND)
++ break()
++ else()
++ set(MOZJS_FOUND 0)
++ endif()
++ endforeach()
+ else()
+ set(MOZJS_FOUND 0)
+ endif()
+--- libproxy/modules/pacrunner_mozjs.cpp
++++ libproxy/modules/pacrunner_mozjs.cpp
+@@ -42,12 +42,12 @@
+ #define INET6_ADDRSTRLEN 46
+ #endif
+
+-static JSBool dnsResolve(JSContext *cx, JSObject * /*obj*/, uintN /*argc*/, jsval *argv, jsval *rval) {
++static JSBool dnsResolve_(JSContext *cx, jsval hostname, jsval *vp) {
+ // Get hostname argument
+- char *tmp = JS_strdup(cx, JS_GetStringBytes(JS_ValueToString(cx, argv[0])));
++ char *tmp = JS_EncodeString(cx, JS_ValueToString(cx, hostname));
+
+ // Set the default return value
+- *rval = JSVAL_NULL;
++ JS_SET_RVAL(cx, vp, JSVAL_NULL);
+
+ // Look it up
+ struct addrinfo *info = NULL;
+@@ -66,7 +66,7 @@
+ NI_NUMERICHOST)) goto out;
+
+ // We succeeded
+- *rval = STRING_TO_JSVAL(JS_NewString(cx, tmp, strlen(tmp)));
++ JS_SET_RVAL(cx, vp, STRING_TO_JSVAL(JS_NewStringCopyN(cx, tmp, strlen(tmp))));
+ tmp = NULL;
+
+ out:
+@@ -75,15 +75,20 @@
+ return true;
+ }
+
+-static JSBool myIpAddress(JSContext *cx, JSObject *obj, uintN /*argc*/, jsval * /*argv*/, jsval *rval) {
++static JSBool dnsResolve(JSContext *cx, uintN /*argc*/, jsval *vp) {
++ jsval *argv = JS_ARGV(cx, vp);
++ return dnsResolve_(cx, argv[0], vp);
++}
++
++static JSBool myIpAddress(JSContext *cx, uintN /*argc*/, jsval *vp) {
+ char *hostname = (char *) JS_malloc(cx, 1024);
+ if (!gethostname(hostname, 1023)) {
+- JSString *myhost = JS_NewString(cx, hostname, strlen(hostname));
++ JSString *myhost = JS_NewStringCopyN(cx, hostname, strlen(hostname));
+ jsval arg = STRING_TO_JSVAL(myhost);
+- return dnsResolve(cx, obj, 1, &arg, rval);
++ return dnsResolve_(cx, 1, &arg);
+ }
+ JS_free(cx, hostname);
+- *rval = JSVAL_NULL;
++ JS_SET_RVAL(cx, vp, JSVAL_NULL);
+ return true;
+ }
+
+@@ -91,7 +96,7 @@
+ // This MUST be a static global
+ static JSClass cls = {
+ "global", JSCLASS_GLOBAL_FLAGS,
+- JS_PropertyStub, JS_PropertyStub, JS_PropertyStub, JS_PropertyStub,
++ JS_PropertyStub, JS_PropertyStub, JS_PropertyStub, JS_StrictPropertyStub,
+ JS_EnumerateStub, JS_ResolveStub, JS_ConvertStub, JS_FinalizeStub,
+ NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL
+ };
+@@ -111,7 +116,11 @@
+ //JS_SetOptions(this->jsctx, JSOPTION_VAROBJFIX);
+ //JS_SetVersion(this->jsctx, JSVERSION_LATEST);
+ //JS_SetErrorReporter(cx, reportError);
++ #ifdef HAVE_MOZJS_2
++ if (!(this->jsglb = JS_NewCompartmentAndGlobalObject(this->jsctx, &cls, NULL))) goto error;
++ #else
+ if (!(this->jsglb = JS_NewObject(this->jsctx, &cls, NULL, NULL))) goto error;
++ #endif
+ if (!JS_InitStandardClasses(this->jsctx, this->jsglb)) goto error;
+
+ // Define Javascript functions
+@@ -147,15 +156,19 @@
+ throw bad_alloc();
+ }
+ jsval args[2] = {
+- STRING_TO_JSVAL(JS_NewString(this->jsctx, tmpurl, strlen(tmpurl))),
+- STRING_TO_JSVAL(JS_NewString(this->jsctx, tmphost, strlen(tmphost)))
++ STRING_TO_JSVAL(JS_NewStringCopyN(this->jsctx, tmpurl, strlen(tmpurl))),
++ STRING_TO_JSVAL(JS_NewStringCopyN(this->jsctx, tmphost, strlen(tmphost)))
+ };
+
+ // Find the proxy (call FindProxyForURL())
+ jsval rval;
+ JSBool result = JS_CallFunctionName(this->jsctx, this->jsglb, "FindProxyForURL", 2, args, &rval);
+ if (!result) return "";
+- string answer = string(JS_GetStringBytes(JS_ValueToString(this->jsctx, rval)));
++
++ char * tmpanswer = JS_EncodeString(this->jsctx, JS_ValueToString(this->jsctx, rval));
++ string answer = string(tmpanswer);
++ JS_free(this->jsctx, tmpanswer);
++
+ if (answer == "undefined") return "";
+ return answer;
+ }
diff --git a/net-libs/libproxy/libproxy-0.4.6-r1.ebuild b/net-libs/libproxy/libproxy-0.4.6-r1.ebuild
index eb90b545d571..15ecf60753cd 100644
--- a/net-libs/libproxy/libproxy-0.4.6-r1.ebuild
+++ b/net-libs/libproxy/libproxy-0.4.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.6-r1.ebuild,v 1.3 2011/03/07 11:56:14 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.6-r1.ebuild,v 1.4 2011/03/22 21:48:30 ssuominen Exp $
EAPI="2"
PYTHON_DEPEND="python? 2:2.5"
@@ -31,7 +31,10 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS NEWS README ChangeLog"
-PATCHES=( "${FILESDIR}"/${P}-mozjs-link_directory.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-mozjs-link_directory.patch
+ "${FILESDIR}"/${P}-xulrunner-2.patch
+ )
pkg_setup() {
if use python; then