summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-01-07 08:56:39 +0000
committerPeter Volkov <pva@gentoo.org>2011-01-07 08:56:39 +0000
commit40f6e16224a0f577ecd7bba22ce27a0d6550e0b7 (patch)
tree67c06eab82cd1ec6d12c2f7f831f25e4e18014fa /net-libs
parentVersion bump, thank Jeroen Roovers for report in bug #350555 (diff)
downloadgentoo-2-40f6e16224a0f577ecd7bba22ce27a0d6550e0b7.tar.gz
gentoo-2-40f6e16224a0f577ecd7bba22ce27a0d6550e0b7.tar.bz2
gentoo-2-40f6e16224a0f577ecd7bba22ce27a0d6550e0b7.zip
Version bump.
(Portage version: 2.1.9.29/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libeXosip/ChangeLog9
-rw-r--r--net-libs/libeXosip/libeXosip-3.5.0.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/net-libs/libeXosip/ChangeLog b/net-libs/libeXosip/ChangeLog
index 3238e9e10183..43ba1e8b438d 100644
--- a/net-libs/libeXosip/ChangeLog
+++ b/net-libs/libeXosip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libeXosip
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libeXosip/ChangeLog,v 1.18 2010/12/04 14:18:36 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libeXosip/ChangeLog,v 1.19 2011/01/07 08:56:39 pva Exp $
+
+*libeXosip-3.5.0 (07 Jan 2011)
+
+ 07 Jan 2011; Peter Volkov <pva@gentoo.org> +libeXosip-3.5.0.ebuild:
+ Version bump.
04 Dec 2010; Peter Volkov <pva@gentoo.org> -libeXosip-3.0.3.3.ebuild,
-libeXosip-3.1.0.ebuild, -libeXosip-3.2.0.ebuild:
diff --git a/net-libs/libeXosip/libeXosip-3.5.0.ebuild b/net-libs/libeXosip/libeXosip-3.5.0.ebuild
new file mode 100644
index 000000000000..23ac28d811ca
--- /dev/null
+++ b/net-libs/libeXosip/libeXosip-3.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libeXosip/libeXosip-3.5.0.ebuild,v 1.1 2011/01/07 08:56:39 pva Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+MY_PV=${PV%.?}-${PV##*.}
+MY_PV=${PV}
+MY_P=${PN}2-${MY_PV}
+DESCRIPTION="library that hides the complexity of using the SIP protocol for multimedia session establishement"
+HOMEPAGE="http://savannah.nongnu.org/projects/exosip/"
+SRC_URI="http://download.savannah.nongnu.org/releases/exosip/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="+srv ssl"
+
+DEPEND=">=net-libs/libosip-3.2.0
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ --enable-mt \
+ $(use_enable ssl openssl) \
+ $(use_enable srv srvrec)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}