summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-02-28 23:16:47 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-02-28 23:16:47 +0000
commit3e98625cd65e4159875a08aabadd125149aa26e2 (patch)
tree823e259585237ad1e438f6ad3c85f803813bd390 /net-libs
parentUpdate SRC_URI (diff)
downloadgentoo-2-3e98625cd65e4159875a08aabadd125149aa26e2.tar.gz
gentoo-2-3e98625cd65e4159875a08aabadd125149aa26e2.tar.bz2
gentoo-2-3e98625cd65e4159875a08aabadd125149aa26e2.zip
version bump as per bug #259018 patch thanks to Arfrever Frehtes Taifersar Arahesis
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnutls/ChangeLog9
-rw-r--r--net-libs/gnutls/gnutls-2.7.6.ebuild (renamed from net-libs/gnutls/gnutls-2.6.2.ebuild)20
2 files changed, 18 insertions, 11 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index 9075397339db..4f1fd0e97e1e 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/gnutls
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.178 2009/01/10 22:45:35 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.179 2009/02/28 23:16:47 dragonheart Exp $
+
+*gnutls-2.7.6 (28 Feb 2009)
+
+ 28 Feb 2009; Daniel Black <dragonheart@gentoo.org> -gnutls-2.6.2.ebuild,
+ +gnutls-2.7.6.ebuild:
+ version bump as per bug #259018 patch thanks to Arfrever Frehtes Taifersar
+ Arahesis
*gnutls-2.7.4 (10 Jan 2009)
diff --git a/net-libs/gnutls/gnutls-2.6.2.ebuild b/net-libs/gnutls/gnutls-2.7.6.ebuild
index 527fc76d994c..aec503d3d249 100644
--- a/net-libs/gnutls/gnutls-2.6.2.ebuild
+++ b/net-libs/gnutls/gnutls-2.7.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.6.2.ebuild,v 1.4 2009/01/10 01:33:11 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.7.6.ebuild,v 1.1 2009/02/28 23:16:47 dragonheart Exp $
EAPI="2"
-inherit eutils libtool autotools
+inherit libtool autotools
DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
HOMEPAGE="http://www.gnutls.org/"
@@ -44,17 +44,17 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- for dir in gl/m4 m4 lib/gl/m4 lib/m4 libextra/gl/m4 libextra/m4 ; do
+src_prepare() {
+ for dir in m4 lib/m4 libextra/m4 ; do
rm -f ${dir}/lt* ${dir}/libtool.m4
done
find . -name ltmain.sh -exec rm {} \;
+ for dir in . lib libextra ; do
+ pushd ${dir} > /dev/null
+ eautoreconf
+ popd > /dev/null
+ done
- epatch "${FILESDIR}"/gnutls-2.6.0-cxx-configure.in.patch
- epatch "${FILESDIR}"/gnutls-2.6.0-openpgp-selftest.patch
- eautoreconf
elibtoolize # for sane .so versioning on FreeBSD
}
@@ -62,11 +62,11 @@ src_configure() {
local myconf
use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
econf \
- $(use_with zlib) \
$(use_enable nls) \
$(use_enable guile) \
$(use_enable cxx) \
$(use_enable doc gtk-doc) \
+ $(use_with zlib) \
${myconf}
}