summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-03 06:35:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-03 06:35:29 +0000
commit3d639209ac963321595a5ad41aada6ebb9ab45c4 (patch)
tree75ba81d07a7aaaef08dd75f4bd9e1875fd489de5 /net-libs
parentFix metadata.xml (diff)
downloadgentoo-2-3d639209ac963321595a5ad41aada6ebb9ab45c4.tar.gz
gentoo-2-3d639209ac963321595a5ad41aada6ebb9ab45c4.tar.bz2
gentoo-2-3d639209ac963321595a5ad41aada6ebb9ab45c4.zip
Initial Import from jokey overlay. Dep of newer virtualbox-ose. Ebuilds by Alessio Cassibba.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/ChangeLog12
-rw-r--r--net-libs/gsoap/gsoap-2.7.12.ebuild52
-rw-r--r--net-libs/gsoap/gsoap-2.7.9f.ebuild45
-rw-r--r--net-libs/gsoap/metadata.xml17
4 files changed, 126 insertions, 0 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
new file mode 100644
index 000000000000..7add0a4bf6e3
--- /dev/null
+++ b/net-libs/gsoap/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-libs/gsoap
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.1 2009/03/03 06:35:29 patrick Exp $
+
+*gsoap-2.7.12 (03 Mar 2009)
+*gsoap-2.7.9f (03 Mar 2009)
+
+ 03 Mar 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+ +gsoap-2.7.9f.ebuild, +gsoap-2.7.12.ebuild:
+ Initial Import from jokey overlay. Dep of newer virtualbox-ose. Ebuilds by
+ Alessio Cassibba.
+
diff --git a/net-libs/gsoap/gsoap-2.7.12.ebuild b/net-libs/gsoap/gsoap-2.7.12.ebuild
new file mode 100644
index 000000000000..8e740edd90f1
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.7.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.12.ebuild,v 1.1 2009/03/03 06:35:29 patrick Exp $
+
+EAPI=1
+
+inherit eutils
+
+MY_P="${PN}-2.7"
+DESCRIPTION="A cross-platfor open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.tar.gz"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples +ssl"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf $(use_enable ssl openssl) \
+ $(use_enable examples samples) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ dodir /usr/share/doc/${P}
+ dodoc LICENSE.txt NOTES.txt README.txt
+ dohtml changelog.html
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ rm -rf gsoap/samples/Makefile* README.txt
+ doins -r gsoap/samples
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/
+ fi
+}
diff --git a/net-libs/gsoap/gsoap-2.7.9f.ebuild b/net-libs/gsoap/gsoap-2.7.9f.ebuild
new file mode 100644
index 000000000000..494f031d2a89
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.7.9f.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.9f.ebuild,v 1.1 2009/03/03 06:35:29 patrick Exp $
+
+EAPI=1
+
+inherit eutils
+
+MY_P="${PN}-2.7"
+DESCRIPTION="A cross-platfor open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.tar.gz"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug +ssl"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf $(use_enable ssl openssl) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 install || die "Install failed"
+
+ dodir /usr/share/doc/${P}
+ dodoc NOTES.txt README.txt
+ dohtml changelog.html
+
+ if use doc; then
+ dohtml -r gsoap/doc/
+ fi
+}
diff --git a/net-libs/gsoap/metadata.xml b/net-libs/gsoap/metadata.xml
new file mode 100644
index 000000000000..43f05d8a063b
--- /dev/null
+++ b/net-libs/gsoap/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>jokey@gentoo.org</email>
+ <name>Markus Ullmann</name>
+</maintainer>
+<maintainer>
+ <email>swapon@gmail.com</email>
+ <name>Alessio Cassibba</name>
+</maintainer>
+<maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+</maintainer>
+</pkgmetadata>