summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-15 23:33:54 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-15 23:33:54 +0000
commit39214c6d5007ba16d4b3b80ed14095ad5146a2e0 (patch)
tree27828292e8773643a7c84a181a9bc4fa63a6085c /net-libs
parentBump for #300667 (diff)
downloadgentoo-2-39214c6d5007ba16d4b3b80ed14095ad5146a2e0.tar.gz
gentoo-2-39214c6d5007ba16d4b3b80ed14095ad5146a2e0.tar.bz2
gentoo-2-39214c6d5007ba16d4b3b80ed14095ad5146a2e0.zip
Add boost detection patch to fix bug 295474
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog9
-rw-r--r--net-libs/rb_libtorrent/files/rb_libtorrent-0.14.8-boost-detect.patch33
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.8-r2.ebuild (renamed from net-libs/rb_libtorrent/rb_libtorrent-0.14.8-r1.ebuild)3
3 files changed, 43 insertions, 2 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 8b0ca90257f0..8f3a179c959b 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.77 2010/01/14 16:02:17 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.78 2010/01/15 23:33:53 yngwin Exp $
+
+*rb_libtorrent-0.14.8-r2 (15 Jan 2010)
+
+ 15 Jan 2010; Ben de Groot <yngwin@gentoo.org>
+ -rb_libtorrent-0.14.8-r1.ebuild, +rb_libtorrent-0.14.8-r2.ebuild,
+ +files/rb_libtorrent-0.14.8-boost-detect.patch:
+ Add new boost detection patch to really fix bug 295474
14 Jan 2010; Ben de Groot <yngwin@gentoo.org>
rb_libtorrent-0.14.8-r1.ebuild,
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.8-boost-detect.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.8-boost-detect.patch
new file mode 100644
index 000000000000..6f557547a394
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.8-boost-detect.patch
@@ -0,0 +1,33 @@
+--- m4/ax_boost_base-fixed.m4.orig 2010-01-16 00:10:19.000000000 +0100
++++ m4/ax_boost_base-fixed.m4 2010-01-16 00:12:32.000000000 +0100
+@@ -89,7 +89,7 @@
+ dnl or if you install boost with RPM
+ if test "$ac_boost_path" != ""; then
+ BOOST_LDFLAGS="-L$ac_boost_path/lib"
+- BOOST_CPPFLAGS="-I$ac_boost_path/include"
++ BOOST_CPPFLAGS="-I$ac_boost_path"
+ else
+ for ac_boost_path_tmp in /usr /usr/local /opt /opt/local ; do
+ if test -d "$ac_boost_path_tmp/include/boost" && test -r "$ac_boost_path_tmp/include/boost"; then
+--- bindings/python/setup.py.in.orig 2010-01-16 00:14:36.000000000 +0100
++++ bindings/python/setup.py.in 2010-01-16 00:15:15.000000000 +0100
+@@ -62,7 +62,7 @@
+ source_list = os.listdir(os.path.join(os.path.dirname(__file__), "src"))
+ source_list = [os.path.join("src", s) for s in source_list if s.endswith(".cpp")]
+
+-extra_cmd = '@COMPILETIME_OPTIONS@ @CPPFLAGS@ @LIBS@ @BOOST_FILESYSTEM_LIB@ @BOOST_THREAD_LIB@ @PTHREAD_LIBS@ @SSL_LIBS@ @BOOST_SYSTEM_LIB@ @SSL_LDFLAGS@ @SSL_CXXFLAGS@'
++extra_cmd = '@COMPILETIME_OPTIONS@ @CPPFLAGS@ @LIBS@ @BOOST_LDFLAGS@ @BOOST_FILESYSTEM_LIB@ @BOOST_THREAD_LIB@ @PTHREAD_LIBS@ @SSL_LIBS@ @BOOST_SYSTEM_LIB@ @SSL_LDFLAGS@ @SSL_CXXFLAGS@'
+
+ setup( name='python-libtorrent',
+ version='@PACKAGE_VERSION@',
+--- src/Makefile.am.orig 2010-01-16 00:16:08.000000000 +0100
++++ src/Makefile.am 2010-01-16 00:17:16.000000000 +0100
+@@ -108,7 +108,7 @@
+ $(top_srcdir)/include/libtorrent/version.hpp
+
+
+-libtorrent_rasterbar_la_LDFLAGS = $(LDFLAGS) -version-info $(INTERFACE_VERSION_INFO)
++libtorrent_rasterbar_la_LDFLAGS = $(LDFLAGS) -version-info $(INTERFACE_VERSION_INFO) @BOOST_LDFLAGS@
+ libtorrent_rasterbar_la_LIBADD = @ZLIB@ @BOOST_SYSTEM_LIB@ @BOOST_FILESYSTEM_LIB@ @BOOST_THREAD_LIB@ @PTHREAD_LIBS@ @SSL_LIBS@
+
+ AM_CXXFLAGS= -ftemplate-depth-100 -I$(top_srcdir)/include -I$(top_srcdir)/include/libtorrent @ZLIBINCL@ @DEBUGFLAGS@ @PTHREAD_CFLAGS@ -DBOOST_MULTI_INDEX_DISABLE_SERIALIZATION @SSL_CXXFLAGS@
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.8-r1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.8-r2.ebuild
index 59bdee36a320..8f9a5e269f4c 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.14.8-r1.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.14.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.8-r1.ebuild,v 1.2 2010/01/14 16:02:17 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.8-r2.ebuild,v 1.1 2010/01/15 23:33:53 yngwin Exp $
EAPI="2"
inherit autotools eutils flag-o-matic versionator
@@ -28,6 +28,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/0.14.6-configure-ldflags-fix.patch #290756
epatch "${FILESDIR}"/${P}-as-needed-fix.patch #276873
+ epatch "${FILESDIR}"/${P}-boost-detect.patch #295474
eautoreconf
}