summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-11-10 18:21:59 +0000
committerBen de Groot <yngwin@gentoo.org>2009-11-10 18:21:59 +0000
commit37e80aa314a95866a3b3ad1f3481e923b324ca4d (patch)
tree101ff64dc58e4b520f36e06b3da139f832f7cbc7 /net-libs
parentMarking gcc-4.3.4 ppc64 for bug 288621 (diff)
downloadgentoo-2-37e80aa314a95866a3b3ad1f3481e923b324ca4d.tar.gz
gentoo-2-37e80aa314a95866a3b3ad1f3481e923b324ca4d.tar.bz2
gentoo-2-37e80aa314a95866a3b3ad1f3481e923b324ca4d.zip
Adding patch to fix problematic ldflags use in configure, bug 290756.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog6
-rw-r--r--net-libs/rb_libtorrent/files/0.14.6-configure-ldflags-fix.patch10
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild9
3 files changed, 22 insertions, 3 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index c2324bc81758..92f70fabb463 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.67 2009/10/27 10:39:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.68 2009/11/10 18:21:58 yngwin Exp $
+
+ 10 Nov 2009; Ben de Groot <yngwin@gentoo.org>
+ +files/0.14.6-configure-ldflags-fix.patch, rb_libtorrent-0.14.6.ebuild:
+ Adding patch to fix problematic ldflags use in configure, bug 290756.
27 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
rb_libtorrent-0.14.6.ebuild:
diff --git a/net-libs/rb_libtorrent/files/0.14.6-configure-ldflags-fix.patch b/net-libs/rb_libtorrent/files/0.14.6-configure-ldflags-fix.patch
new file mode 100644
index 000000000000..9a3d27639648
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/0.14.6-configure-ldflags-fix.patch
@@ -0,0 +1,10 @@
+--- libtorrent-rasterbar-0.14.6/configure.in.orig 2009-11-10 19:04:06.000000000 +0100
++++ libtorrent-rasterbar-0.14.6/configure.in 2009-11-10 19:05:06.000000000 +0100
+@@ -157,7 +157,6 @@
+
+ dnl Apply boost config.
+ CPPFLAGS="$CPPFLAGS $BOOST_CPPFLAGS"
+-LDFLAGS="$LDFLAGS $BOOST_LDFLAGS"
+
+ if [[ "x$BUILD_TESTCLIENT" != "xno" ]]; then
+ CLIENT_TEST_BIN=client_test;
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild
index 4964458f5d65..96af94e97c86 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild,v 1.2 2009/10/27 10:39:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild,v 1.3 2009/11/10 18:21:58 yngwin Exp $
EAPI="2"
-inherit eutils flag-o-matic
+inherit autotools eutils flag-o-matic
MY_P=${P/rb_/}
MY_P=${MY_P/torrent/torrent-rasterbar}
@@ -26,6 +26,11 @@ DEPEND="!net-libs/libtorrent
sys-libs/zlib"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/0.14.6-configure-ldflags-fix.patch #290756
+ eautoreconf
+}
+
src_configure() {
append-ldflags -pthread