summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2012-01-28 02:17:07 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2012-01-28 02:17:07 +0000
commit32b7bbc071e43b5bbe38646bb89aa91784c195e0 (patch)
tree9418eda4f3a612140f82857fe785d511a928b429 /net-libs
parentBlock x11-misc/qtnotifydaemon because it's using same .service file. (diff)
downloadgentoo-2-32b7bbc071e43b5bbe38646bb89aa91784c195e0.tar.gz
gentoo-2-32b7bbc071e43b5bbe38646bb89aa91784c195e0.tar.bz2
gentoo-2-32b7bbc071e43b5bbe38646bb89aa91784c195e0.zip
Version bump, remove old, bug 399223.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libgadu/ChangeLog10
-rw-r--r--net-libs/libgadu/libgadu-1.11.1.ebuild70
-rw-r--r--net-libs/libgadu/libgadu-1.9.1.ebuild48
3 files changed, 78 insertions, 50 deletions
diff --git a/net-libs/libgadu/ChangeLog b/net-libs/libgadu/ChangeLog
index 46ecd9cad63b..41095761cbcb 100644
--- a/net-libs/libgadu/ChangeLog
+++ b/net-libs/libgadu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libgadu
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.64 2011/07/09 16:49:16 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.65 2012/01/28 02:17:07 reavertm Exp $
+
+*libgadu-1.11.1 (28 Jan 2012)
+
+ 28 Jan 2012; Maciej Mrozowski <reavertm@gentoo.org> +libgadu-1.11.1.ebuild,
+ -libgadu-1.9.1.ebuild:
+ Version bump, remove old, bug 399223.
09 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> libgadu-1.11.0.ebuild:
ppc stable wrt #372785
diff --git a/net-libs/libgadu/libgadu-1.11.1.ebuild b/net-libs/libgadu/libgadu-1.11.1.ebuild
new file mode 100644
index 000000000000..7eea4d02a3b1
--- /dev/null
+++ b/net-libs/libgadu/libgadu-1.11.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/libgadu-1.11.1.ebuild,v 1.1 2012/01/28 02:17:07 reavertm Exp $
+
+EAPI="4"
+
+MY_P="${P/_/-}"
+
+inherit autotools-utils
+
+DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
+HOMEPAGE="http://toxygen.net/libgadu/"
+SRC_URI="http://toxygen.net/libgadu/files/${MY_P}.tar.gz"
+
+# Bug 373215, relies on remote server presence
+RESTRICT="test"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+IUSE="doc gnutls ssl static-libs threads"
+
+REQUIRED_USE="
+ gnutls? ( ssl )
+"
+COMMON_DEPEND="
+ sys-libs/zlib
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/openssl-0.9.6m )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${COMMON_DEPEND}
+ !=net-im/kadu-0.6.0.2
+ !=net-im/kadu-0.6.0.1
+"
+
+S="${WORKDIR}/${MY_P}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=(AUTHORS ChangeLog NEWS README)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with threads pthread)
+ )
+
+ if use ssl; then
+ myeconfargs+=(
+ $(use_with gnutls gnutls)
+ $(use_with !gnutls openssl)
+ )
+ else
+ myeconfargs+=(
+ --without-gnutls
+ --without-openssl
+ )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=(docs/html/)
+ autotools-utils_src_install
+}
diff --git a/net-libs/libgadu/libgadu-1.9.1.ebuild b/net-libs/libgadu/libgadu-1.9.1.ebuild
deleted file mode 100644
index f466a4122073..000000000000
--- a/net-libs/libgadu/libgadu-1.9.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/libgadu-1.9.1.ebuild,v 1.8 2011/03/25 10:17:47 xarthisius Exp $
-
-EAPI="3"
-
-MY_P="${P/_/-}"
-
-inherit autotools-utils
-
-DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
-HOMEPAGE="http://toxygen.net/libgadu/"
-SRC_URI="http://toxygen.net/libgadu/files/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
-SLOT="0"
-IUSE="doc ssl static-libs threads"
-
-COMMON_DEPEND="
- ssl? ( >=dev-libs/openssl-0.9.6m )
-"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
-"
-RDEPEND="${COMMON_DEPEND}
- !=net-im/kadu-0.6.0.2
- !=net-im/kadu-0.6.0.1
-"
-
-S="${WORKDIR}/${MY_P}"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-DOCS=(AUTHORS ChangeLog NEWS README)
-
-src_configure() {
- myeconfargs=(
- $(use_with ssl openssl)
- $(use_with threads pthread)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- use doc && HTML_DOCS=(docs/html/)
- autotools-utils_src_install
-}