summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-21 05:37:50 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-21 05:37:50 +0000
commit30a179ac9baca7f60894599ed35cbf10a9c1a6b0 (patch)
treee2889be6da3c00faa6b9b1e9eec52e354721d3d2 /net-libs
parentVersion bump. (diff)
downloadgentoo-2-30a179ac9baca7f60894599ed35cbf10a9c1a6b0.tar.gz
gentoo-2-30a179ac9baca7f60894599ed35cbf10a9c1a6b0.tar.bz2
gentoo-2-30a179ac9baca7f60894599ed35cbf10a9c1a6b0.zip
Version bump. Add workaround for failing tests (bug #333319).
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh2/ChangeLog7
-rw-r--r--net-libs/libssh2/libssh2-1.3.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index 88b5821f8601..33557ecac1cd 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libssh2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.38 2011/08/20 23:04:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.39 2011/09/21 05:37:50 radhermit Exp $
+
+*libssh2-1.3.0 (21 Sep 2011)
+
+ 21 Sep 2011; Tim Harder <radhermit@gentoo.org> +libssh2-1.3.0.ebuild:
+ Version bump. Add workaround for failing tests (bug #333319).
*libssh2-1.2.9 (20 Aug 2011)
diff --git a/net-libs/libssh2/libssh2-1.3.0.ebuild b/net-libs/libssh2/libssh2-1.3.0.ebuild
new file mode 100644
index 000000000000..6cdc3f7f1f35
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.3.0.ebuild,v 1.1 2011/09/21 05:37:50 radhermit Exp $
+
+EAPI="4"
+
+inherit autotools-utils
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="http://www.${PN}.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-macos ~x86-solaris"
+IUSE="gcrypt static-libs test zlib"
+
+DEPEND="!gcrypt? ( dev-libs/openssl )
+ gcrypt? ( dev-libs/libgcrypt )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf
+
+ if use gcrypt; then
+ myconf="--with-libgcrypt"
+ else
+ myconf="--with-openssl"
+ fi
+
+ # Disable tests that require extra permissions (bug #333319)
+ use test && export ac_cv_path_SSHD=
+
+ econf \
+ $(use_with zlib libz) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dodoc README
+ use static-libs || remove_libtool_files
+}