summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-05-14 11:10:34 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-05-14 11:10:34 +0000
commit308b55ae6b6dedf485b2cd2ba0abc35bc0284124 (patch)
tree98aabf877b0631fc3ce21e0395c5538a1d2eb91f /net-libs
parent[QA] Restore deleted ebuild from attic. Version >=2.12.0 is in package.mask, ... (diff)
downloadgentoo-2-308b55ae6b6dedf485b2cd2ba0abc35bc0284124.tar.gz
gentoo-2-308b55ae6b6dedf485b2cd2ba0abc35bc0284124.tar.bz2
gentoo-2-308b55ae6b6dedf485b2cd2ba0abc35bc0284124.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmicrohttpd/ChangeLog8
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.42.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/net-libs/libmicrohttpd/ChangeLog b/net-libs/libmicrohttpd/ChangeLog
index 5e36a69ddfe4..eb41f886bbb4 100644
--- a/net-libs/libmicrohttpd/ChangeLog
+++ b/net-libs/libmicrohttpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libmicrohttpd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.92 2015/04/30 11:35:47 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.93 2015/05/14 11:10:34 blueness Exp $
+
+*libmicrohttpd-0.9.42 (14 May 2015)
+
+ 14 May 2015; Anthony G. Basile <blueness@gentoo.org>
+ +libmicrohttpd-0.9.42.ebuild:
+ Version bump.
30 Apr 2015; Anthony G. Basile <blueness@gentoo.org>
-libmicrohttpd-0.9.37.ebuild, -libmicrohttpd-0.9.38.ebuild:
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.42.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.42.ebuild
new file mode 100644
index 000000000000..746c8e2c0fcb
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.42.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/libmicrohttpd-0.9.42.ebuild,v 1.1 2015/05/14 11:10:34 blueness Exp $
+
+EAPI="5"
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application"
+HOMEPAGE="http://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+IUSE="epoll messages ssl static-libs test"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0
+ net-libs/gnutls
+ )"
+
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( >=net-misc/curl-7.25.0-r1[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_configure() {
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-spdy \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable messages postprocessor) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}