summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-12-08 22:58:58 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-12-08 22:58:58 +0000
commit2fc8ee856abe328551572260ee27f23196af1eb7 (patch)
tree23c0cf1791bb6de5cf9abac61b06b9fc8daec7f2 /net-libs
parentx11-apps/xinit: update Gentoo patch to fix bug #295616 (diff)
downloadgentoo-2-2fc8ee856abe328551572260ee27f23196af1eb7.tar.gz
gentoo-2-2fc8ee856abe328551572260ee27f23196af1eb7.tar.bz2
gentoo-2-2fc8ee856abe328551572260ee27f23196af1eb7.zip
Version bump. Respect LDFLAGS. A bug was introduced in the PTMP rewrite which fails to clear timers before they are set. This can cause scheduling and Q.921 link failures.
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpri/ChangeLog12
-rw-r--r--net-libs/libpri/files/libpri-1.4.10.2-respect-ldflags.patch12
-rw-r--r--net-libs/libpri/libpri-1.4.10.2.ebuild32
3 files changed, 54 insertions, 2 deletions
diff --git a/net-libs/libpri/ChangeLog b/net-libs/libpri/ChangeLog
index 4610b28902ef..b84690d75702 100644
--- a/net-libs/libpri/ChangeLog
+++ b/net-libs/libpri/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libpri
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/ChangeLog,v 1.76 2009/07/27 19:59:30 volkmar Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/ChangeLog,v 1.77 2009/12/08 22:58:57 chainsaw Exp $
+
+*libpri-1.4.10.2 (08 Dec 2009)
+
+ 08 Dec 2009; <chainsaw@gentoo.org> +libpri-1.4.10.2.ebuild,
+ +files/libpri-1.4.10.2-respect-ldflags.patch:
+ Version bump. Respect LDFLAGS. A bug was introduced in the PTMP rewrite
+ which fails to clear timers before they are set. This can cause scheduling
+ and Q.921 link failures.
*libpri-1.4.10.1 (27 Jul 2009)
diff --git a/net-libs/libpri/files/libpri-1.4.10.2-respect-ldflags.patch b/net-libs/libpri/files/libpri-1.4.10.2-respect-ldflags.patch
new file mode 100644
index 000000000000..93f0c2ea8d31
--- /dev/null
+++ b/net-libs/libpri/files/libpri-1.4.10.2-respect-ldflags.patch
@@ -0,0 +1,12 @@
+diff -uNr libpri-1.4.10.2.ORIG/Makefile libpri-1.4.10.2/Makefile
+--- libpri-1.4.10.2.ORIG/Makefile 2009-12-08 22:55:12.729738494 +0000
++++ libpri-1.4.10.2/Makefile 2009-12-08 22:55:58.645775496 +0000
+@@ -145,7 +145,7 @@
+ ranlib $(STATIC_LIBRARY)
+
+ $(DYNAMIC_LIBRARY): $(DYNAMIC_OBJS)
+- $(CC) -shared $(SOFLAGS) -o $@ $(DYNAMIC_OBJS)
++ $(CC) -shared $(SOFLAGS) $(LDFLAGS) -o $@ $(DYNAMIC_OBJS)
+ $(LDCONFIG) $(LDCONFIG_FLAGS) .
+ ln -sf libpri.so.$(SONAME) libpri.so
+
diff --git a/net-libs/libpri/libpri-1.4.10.2.ebuild b/net-libs/libpri/libpri-1.4.10.2.ebuild
new file mode 100644
index 000000000000..42b3799315ef
--- /dev/null
+++ b/net-libs/libpri/libpri-1.4.10.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/libpri-1.4.10.2.ebuild,v 1.1 2009/12/08 22:58:57 chainsaw Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Primary Rate ISDN (PRI) library"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/${PN}/releases/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.4.9-respect-cflags.patch"
+ epatch "${FILESDIR}/${PN}-1.4.9-multilib.patch"
+ epatch "${FILESDIR}/${P}-respect-ldflags.patch"
+
+ # remove -Werror, fix bug 260923
+ sed -i -e "s/-Werror //" Makefile || die "sed failed"
+}
+
+src_install() {
+ emake INSTALL_PREFIX="${D}" LIBDIR="${D}/usr/$(get_libdir)" install \
+ || die "emake install failed"
+
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}